#151 13.10.2017 13:30:34

Greg
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Ich glaube dat wird nix. Wir drehen uns immer wieder im Kreis.
Ich empfehle dir ein Backup der wichtigen Dateien zu machen.
Danach lädst du dir das runter:
https://linuxmint.com/edition.php?id=237
und installierst dir das.
Das dürfte für den ungeübten Linuxuser erheblich einfacher sein.
Das Ding installiert sich wie von selbst.

Gruß aus DN
Greg

Offline

#152 13.10.2017 13:33:29

Tilrun
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Vielleicht drücke ich mich auch unklar aus. Ich wollte nur auf Nummer sicher gehen, dass ich nix falsches mach.:-(
Pacman -Sy hat nichts geupdatet.
Soll ich jetzt xorg-xdm enablen? Dann könnte ich ja nochmal versuchen normal zu starten.

Beitrag geändert von Tilrun (13.10.2017 13:35:32)

Offline

#153 13.10.2017 13:43:19

Tilrun
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Das habe ich gemacht. Komme zur Login Maske, Versuche mich mit Name und PW einzuloggen, aber ab da gehts nicht weiter.
Bildschirm ist kurz schwarz und dann kommt die login-maske wieder

Beitrag geändert von Tilrun (13.10.2017 13:43:59)

Offline

#154 13.10.2017 14:03:37

Greg
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Da sind wir wieder an genau dieser Stelle wo es hakt. Nur wissen wir jetzt, an SDDM liegts nicht. Mit XDM passiert das Gleiche.
Jetzt müßten wir wieder einige Logdateien ansehen usw.
Willst du dir das tatsächlich antun? Das kann noch Tage so weiter gehen.
Zumal dein Studium sicherlich wichtiger ist wie dinge Rechenmaschien.
Versuche echt ein Backup deiner wichtigen Sachen zu machen und dann eine saubere Neuinstallation wie zuvor angegeben.
Ich habe eben mal das https://linuxmint.com/edition.php?id=237  ausprobiert. Ausser Usernamen und Passwort mußt du nichts machen. Der Rest geht komplett automatisch.
Wenn du deine Linuxkenntnisse und vor allem allgemeine PC Kenntnisse erweitert hast kannst du dich nochmal an Arch-Linux ranmachen. Dann wirst du später sagen, ist doch alles einfach.

Bis denn..
Grüß mir die Wienerwürstchen und die Wiener Schnitzel!!
Greg

Offline

#155 13.10.2017 14:15:36

brikler
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

du bist nicht allein mit dem problem, die ente fand für dein problem zum beispiel dies https://unix.stackexchange.com/question … nfo/339402

kurz das wesentlich aus dem link:

The real problem was that you need a kfd.rules file in /etc/udev/rules.d . The file must say:

KERNEL=="kfd", MODE="0666"

Offline

#156 13.10.2017 17:41:12

Tilrun
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Das würde ich schon gerne ausprobieren.
D.h. ich starte unter dem Kernelparameter single, gebe das rootpw ein und was mache ich dann?

Offline

#157 13.10.2017 21:23:31

GerBra(offline)
Gast

Re: [Gelöst] Bootprobleme (sddm)

Ich würde schon nochmal einen Versuch wagen da weiterzumachen.

Tilrun schrieb:

Das habe ich gemacht. Komme zur Login Maske, Versuche mich mit Name und PW einzuloggen, aber ab da gehts nicht weiter.
Bildschirm ist kurz schwarz und dann kommt die login-maske wieder

Das ist aber (fast schon) die halbe Miete.

Greg schrieb:

Da sind wir wieder an genau dieser Stelle wo es hakt. Nur wissen wir jetzt, an SDDM liegts nicht. Mit XDM passiert das Gleiche.

XDM braucht aber eine extra Konfig (.xinitrc), die ja nicht von Haus aus da ist und zum Windowmanager passt.

Für mich sieht es jetzt so aus:
a) Das System bootet ohne Fehler, die zu einem Bootabbruch führen
b) Der "graphische Modus" (XOrg) / Grafiktreiber funktioniert prinzipiell auch, da sonst der XDM nicht erscheint.

Ansonsten wissen wir nichts über den Zustand. V.a. auch da ja scheinbar Testing aktiviert ist/war als Paketquelle, und dieser ominöse kfd-"Errror" aus dem Eingangsposting rumgeistert.

Ich würde jetzt zumindest gerne dahin kommen, ob Tilrun
a) sich überhaupt als User (bzw. und/oder als root User) am System anmelden kann
b) wenn ja, ob der benutzte Desktop/Windowmanager startbar ist (damit Webbrowser, Internet etc. wieder komfortabler benutzbar wären)

Dazu muß man momentan meines Erachtens gar nicht viel tun.
@Tilrun:
- Boote bitte den Rechner so wie in deinem letzten Post #153, das also die XDM-Loginmaske erscheint
- Versuche dich dort NICHT anzumelden, sondern schalte mit der Tastenkombination (gleichzeitig) STRG+ALT+F3 auf die Textmodus-Terminals um. F3 ist die Funktionstaste 3. Nach kurzer Zeit sollte ein schwarzes Terminal erscheinen mit "Login :" und einem blinkenden Textcursor

- Hier versuchst du dich jetzt anzumelden. Einmal als root, dann als User.
Also am blinkenden "Login:" eingeben: root (dann Enter/Return drücken). Jetzt wird das Paßwort für root abgefragt, also bei Password: das root-Passwort eingeben (Achtung: du siehst nicht das du etwas tippst oder was du tippst, kriegst also keine visuelle Rückmeldung ). Nach dem Paßwort wieder Enter/Return. Es darf danach nicht etwas kommen wie: Login failed, dann hast du dich evtl. vertippt und machst diese Prozedur nochmal. Im Idealfall landest du in einer Kommandozeile/Shell wie du sie auch vonm Single-USer-Modus her kennen solltest. Hier gibst du nun ein: exit, damit loggst du dich als root erstmal wieder aus.
- Jetzt (am neuen "Login:" -Prompt) versuchst du das gleiche mit deinem normalen Benutzer, also als Loginname und Paßwort das nehmen, was du auch bei sddm/xdm eingeben würdest um "Tilrun" am System anzumelden. Im Idealfall landest du in der gleichen Kommandozeilen/Shell wie oben als root. Wieder "exit" um den Normaluser auszuloggen.

Mehr erstmal nicht machen. Ich will nur sehen, ob sich root und/oder der Normaluser am System überhaupt anmelden können. Den Rechner kannst du runterfahren.
Wenn das Einloggen prinzipiell funktioniert kann man weitermachen, und auch den Zustand des Systems mal abfragen.

Was du noch sagen müßtest: Welchen Desktop/Windowmanager hast du genutzt, als das Anmelden mit SDDM noch funktioniert hat: Gnome, KDE, Mate, openbox oder sonstwas?

#158 13.10.2017 21:57:51

brikler
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Tilrun schrieb:

Das würde ich schon gerne ausprobieren.
D.h. ich starte unter dem Kernelparameter single, gebe das rootpw ein und was mache ich dann?

1) das was @ GerBra vorschlägt
2) wenn das funtioniert, bleibts du gleich als root angemeldet in der TTY. dann erstellst du die datei und füllst sie mit dem nötigen

datei erstellen:

nano /etc/udev/rules.d/13-kfd.rules

mit dem inhalt:

KERNEL=="kfd", MODE="0666"

speichere mit der F2 taste und starte neu…wenn bissl a glück dabei is gehts danach smile

Offline

#159 13.10.2017 22:40:39

Tilrun
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

GerBra(offline) schrieb:

XDM braucht aber eine extra Konfig (.xinitrc), die ja nicht von Haus aus da ist und zum Windowmanager passt.

Ich würde jetzt zumindest gerne dahin kommen, ob Tilrun
a) sich überhaupt als User (bzw. und/oder als root User) am System anmelden kann
b) wenn ja, ob der benutzte Desktop/Windowmanager startbar ist (damit Webbrowser, Internet etc. wieder komfortabler benutzbar wären)

Als ich den downgeloadet habe, wurden 2 Pakete zum Download angegeben, das 2. meine ich mich zu erinnern, war xinitrc.
Als root konnte ich mich bis jetzt immer anmelden.
Ich verwende kde plasma.

Ich habe noch probiert xdm zu disablen und sddm wieder zu enablen. Der Unterschied ist da nur: Ich komme nicht zur Login Maske, wenn ich normal boote. Ich kann aber nachschauen, ob ich unter dem single parameter durch die Eingabe von 'exit' dann doch wieder zur Login Maske komme. Das war nämlich auch schon der Fall ( deswegen hat Greg ja geglaubt es liegt an sddm)

@ GerBra und brikler
Ich werde alles das, was ihr mir vorgeschlagen habt, morgen machen :-)

Danke an euch alle, Greg, Schard, brikler und GerBra für die Hilfe und die Geduld!

Offline

#160 13.10.2017 23:03:42

GerBra(offline)
Gast

Re: [Gelöst] Bootprobleme (sddm)

Tilrun schrieb:

Ich habe noch probiert xdm zu disablen und sddm wieder zu enablen. Der Unterschied ist da nur: Ich komme nicht zur Login Maske, wenn ich normal boote. Ich kann aber nachschauen, ob ich unter dem single parameter durch die Eingabe von 'exit' dann doch wieder zur Login Maske komme. Das war nämlich auch schon der Fall ( deswegen hat Greg ja geglaubt es liegt an sddm)

Diese Aktionen sind aber IMHO genau daß, weshalb hier mittlerweile das 160. Posting erscheint...

Ich hatte um eine ganz einfache Aufgabe anhand des Stands aus deinem Post #153 gebeten. Ich habe nichts geschrieben von xdm raus und sddm wieder, noch von single Paranmeter.

Auch den Post von brikler halte ich zu diesem Zeitpunkt für kontraproduktiv, da daß System ja scheinbar (aus zig 100KM Entfernung gesehen) bootet, multi.user.target UND graphical.target offensichtlich funktionieren - egal ob der "Fehler" mit kfd und AMD's "Heterogeneous System Architecture" (jaja...) noch da ist oder nicht. Weiß doch kein Schwein ohne Logfiles u.ä. .... Wenn es aber ad hoc keine Rolle zu spielen scheint - also was soll's.. Wir wissen nichtmal, ob Tilrun momentan nicht den VESA-Treiber nutzt...

Ich will Tilrun (ihres Zeichens leicht überfordert <g>) momentan in die Lage versetzen, mit "startx ihr_win_manager" ihre gewohnte Umgebung starten zu können. Allein ein funktionierender Browser und Internet ist für das Mädel doch Gold wert um mit ihrem System umgehen zu können.
Dazu muß man/ich wissen: kann sie sich überhaupt einloggen oder klemmt da doch noch etwas wovon wir entfernt nix sehen. Wenn ihr KDE erstmal wieder läuft - egal ob mit VESA,amdgpu, oder sohnstwas - dann kann man sich über den Zustand und ggf. noch in Logs lesbare Fehler kümmern.

Ich will nicht der drölfzigste Koch sein, der den Brei hier verdirbt, aber von einem gewissen logischen, strukturierten Vorgehen anhand des Kenntnissstands des OP haben wir doch alle etwas...

#161 14.10.2017 16:52:45

Tilrun
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Hallo!
Wenn ich unterm single parameter boote, mich als root einlogge und dann edit eingebe, bootet das System normal und ich komme zur anmeldemaske (mit sddm enablen statt xdm) wo ich mich auch anmelden kann. D.h. ich sehe meine grafische Oberfläche und sichere gerade alle meine Daten nochmals. Ich kann jetzt über yakuake in die Commandline rein. Bin auch über w-lan mit dem Internet verbunden.

Offline

#162 14.10.2017 16:53:55

Tilrun
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

brikler schrieb:

datei erstellen:

nano /etc/udev/rules.d/13-kfd.rules

mit dem inhalt:

KERNEL=="kfd", MODE="0666"

speichere mit der F2 taste und starte neu…wenn bissl a glück dabei is gehts danach smile

Soll ich das jetzt machen?

Offline

#163 14.10.2017 17:15:30

brikler
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Tilrun schrieb:
brikler schrieb:

datei erstellen:

nano /etc/udev/rules.d/13-kfd.rules

mit dem inhalt:

KERNEL=="kfd", MODE="0666"

speichere mit der F2 taste und starte neu…wenn bissl a glück dabei is gehts danach smile

Soll ich das jetzt machen?

ich würde es versuchen.
wenns ned funktioniert, is die datei gleich gelöscht.

pass mit den leerzeichen auf!
udev ist da heikel…auch am ende kann man aus versehen eines stehen, du siehst es ned, die regel schaut gut aus und geht trotzdem ned,
also pass auf smile

Offline

#164 14.10.2017 17:20:54

GerBra(offline)
Gast

Re: [Gelöst] Bootprobleme (sddm)

Tilrun schrieb:

Hallo!
Wenn ich unterm single parameter boote, mich als root einlogge und dann edit eingebe, bootet das System normal und ich komme zur anmeldemaske (mit sddm enablen statt xdm) wo ich mich auch anmelden kann. D.h. ich sehe meine grafische Oberfläche und sichere gerade alle meine Daten nochmals. Ich kann jetzt über yakuake in die Commandline rein. Bin auch über w-lan mit dem Internet verbunden.

Das ist doch schonmal ein Erfolg. Auch wissen wir, daß der Loginvorgang am System funktioniert.

Zum sddm-Loginmanager: Es gibt (auch im englischen Forum gibt es Meldungen dazu) wohl mit neueren SDDM-Versionen Probleme, die sich so darstellen: sddm bzw. der Bildschirm wird/bleibt schwarz wenn während des Bootens der sddm automatisch gestartet wird. Diesen Effekt hattest du wohl auch.
Er funktioniert für viele User dann wieder,  wenn sie diesen per Hand stoppen und nachträglich erneut starten. Das gleiche machst du jetzt über den "Umweg" des Single-User-Modus.
Klären wird sich das mit dem sddm wohl erst durch eine gefixte Version, wenn denn der sddm alleinig dafür verantwortlich ist.

Aktuell mußt du auf den sddm verzichten - oder unkomfortable Wege gehen - wobei der über den Single-Modus wohl der umständlichste ist.

Ich würde dir raten, eine Zeitlang ohne grafischen Loginmanager auszukommen. Das bedeutet der Rechner bootet normal - aber nur bis zu den TTY/textkonsolen. Dort meldest du dich als User an und startest dann per Hand dein KDE. Das wäre m.E. die momentan am wenigsten umständliche Methode.
Ich kann dir sagen, wie das geht. Am besten wenn deine Sicherung o.ä. fertig ist.
Vorher kannst du in deinem Terminal (yakuake oder konsole) bitte mal feststellen, ob du ein bestimtes Paket installiert hast (ich denke ja)

pacman -Q xorg-xinit

Das sollte melden: xorg-sinit-1.X.Y (also irgendweine Versionsnummer)
Ist das bei dir so?

Zum generellen Weitermachen:
a) bitte ***KEIN*** Systemupdate mit pacman -Syu
b) diese kfd-geschichte mit dem rules-Datei von brikler: kannst du dir momentan auch schenken, ist nicht nötig. Später schaut man mal danach.

#165 14.10.2017 17:46:07

Tilrun
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Ger.Bra(offline) schrieb:

Vorher kannst du in deinem Terminal (yakuake oder konsole) bitte mal feststellen, ob du ein bestimtes Paket installiert hast (ich denke ja)

pacman -Q xorg-xinit

Das sollte melden: xorg-sinit-1.X.Y (also irgendweine Versionsnummer)
Ist das bei dir so?

Nein. o.o es steht da, dass es nicht gefunden wurde.

Ger.Bra(offline) schrieb:

Zum generellen Weitermachen:
a) bitte ***KEIN*** Systemupdate mit pacman -Syu
b) diese kfd-geschichte mit dem rules-Datei von brikler: kannst du dir momentan auch schenken, ist nicht nötig. Später schaut man mal danach.

Aber

Pacman -Su

darf ich schon, oder? Soweit ich das verstanden habe, aktualisiert es mir dann den Kernel nicht.

Beitrag geändert von Tilrun (14.10.2017 17:53:01)

Offline

#166 14.10.2017 17:53:20

GerBra(offline)
Gast

Re: [Gelöst] Bootprobleme (sddm)

pacman -Sy ist sinnfrei im Moment, also unnötig.

Installiere dann bitte das fehlende Paket (als root):
pacman -S xorg-xinit

Das sollte ohne Fehler installiert werden, wenn nicht poste bitte die gesamte Ausgabe. Ich nehme an, du kannst auch wieder deinen Browser nutzen am Problemrechner...

#167 14.10.2017 18:06:32

Tilrun
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Ja, ich kann den Browser nutzen.

Löse Abhängigkeiten auf...
Suche nach in Konflikt stehenden Paketen...

Pakete (2) xorg-xmodmap-1.0.9-1  xorg-xinit-1.3.4-4

Gesamtgröße des Downloads:           0,04 MiB
Gesamtgröße der installierten Pakete:  0,14 MiB

:: Installation fortsetzen? [J/n] 

habe also bestätigt, wurde installiert.

es steht allerdings noch das;

Optionale Abhängigkeiten für xorg-xinit
    xorg-twm
    xterm [Installiert]

Brauchen wir xorg-twm auch?

Offline

#168 14.10.2017 18:27:56

GerBra(offline)
Gast

Re: [Gelöst] Bootprobleme (sddm)

Weitere Pakete brauchen wir momentan nicht.

Jetzt stellen wird den sddm als Loginmanager ab, da der ja im normalen Bootvorgang zu "Fehlern" führt.

Als root:
systemctl disable sddm

Lies dir das erstmal durch, und frage vorher wenn du was nicht verstanden hast bevor du das machst:

Jetzt rebootest du den Rechner, ganz normal booten lassen ohne in den Single-Modus zu gehen o.ä.
Nach dem Booten landest du auf den TTY/Textkonsolen ("Textmodus statt GrafischerModus"), wo login steht und ein blinkender Cursor. Hier meldest du dich als Normaluser an (username und passwort, wie in sddm/xdm) um "Tilrun" anzumelden. Die Paßworteingabe ist nicht zu sehen (kennst du schhon vom SingleModus):
also am login: deinusername <ENTER drücken>
password: deinpasswort <ENTER drücken>
Jetzt bist du als Tilrun am System angemeldet und startest deinen KDE mit:
startx /usr/bin/startkde

Nun sollte dein KDE-Desktop starten wie gewohnt. Gib dann mal Rückmeldung ob es geklappt hat.

---------------------------------
Falls es NICHT funktioniert:
- merke dir die Fehlermeldung oder mache ein Photo vom Bildschirm.
- Melde Tilrun vom TTY ab (mit exit)
- Melde dich am gleichen TTY als root an, mit root Paßwort
- starte den sddm per Hand
systemctl start sddm
Jetzt solltest du den sddm wieder nutzen können um Tilrun anzumelden und KDE zu starten.
Das aber wie gesagt NUR, wenn obige Methode mit Hand-Starten (startx) aus irgendeinem Grund fehlschlägt.

#169 14.10.2017 19:13:38

Tilrun
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Leider geht das nicht. Einloggen konnte ich mich aber.
Ich hoffe man kann bei dem Foto was erkennen.
https://www.imageshack.us/i/poxmPNBUj

Offline

#170 14.10.2017 19:19:48

GerBra(offline)
Gast

Re: [Gelöst] Bootprobleme (sddm)

Du hast einen Tippfehler bei der Eingabe gemacht "/urs/bin/startkde" statt richtig:
/usr/bin/startkde (wie ich es schrieb).
Deshalb kam als Fehler (auf dem Photo): program "/urs/bin/startkde" No such file or directory


Also nochmal bitte. Auf richtige Schreibweise bitte achten.

#171 14.10.2017 19:24:17

Tilrun
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Ich hab 3 Mal nachgeschaut, ob ich mich verschrieben hab... Und 3x is es mir nicht aufgefallen...
Sorry

Es funktioniert.

Beitrag geändert von Tilrun (14.10.2017 19:26:09)

Offline

#172 14.10.2017 19:42:14

GerBra(offline)
Gast

Re: [Gelöst] Bootprobleme (sddm)

Tilrun schrieb:

Es funktioniert.

Gut gemacht. Ich würde vorschlagen, den Rechner jetzt zum Booten und KDE-Nutzen erstmal so zu lassen bei dieser Methode.
Es ist m.E. auf jedenfall einfacher so, als über den Single Modus oder andere Verfahren zu gehen - zumindest bis ser Zustand deines Systems und die evtl. vorhandenen Fehler bei sddm geklärt/beseitigt sind. Ist das für dich OK so - also mit dem Booten, auf der Konsole einloggen und kde mit startx zu starten?

Bitte überprüfe in dem KDE mal, ob du Sonderzeichen/Umlaute in yaquake und Browser anzeigen und schreiben kannst, also äüöß usw.

Und poste mal hier im Thread deine momentane /etc/pacman.conf (Bitte in

 code Block

posten.

Anschließend werde ich dich noch um etliche Logfiles fragen.

Nochmal der Hinweis: bis auf weiteres kein pacman -Sy , -Su, -Syu machen. Freu dich erstmal das es wieder "läuft"...

#173 14.10.2017 19:57:52

Tilrun
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Ich kann mich gerne bis auf weiteres so einloggen und die Konsole so starten.
Die deutsche Tastatur funktioniert, sobald KDE gestartet ist. Wenn cih da mal drin bin, kann ich also Umlaute etc auch in Yakuake eingeben.
Davor habe ich aber die (vermutlich) amerikanische Tastaturbelegung. Da ist / da, wo bei mir das Minus steht. Das ist also kein Problem für mich, für startx /....

Ich werde keinerlei Updates machen, bis ich das OK bekomme.

Wie kriege ich bitte die /etc/pacman.conf nochmal?

Offline

#174 14.10.2017 20:11:35

GerBra(offline)
Gast

Re: [Gelöst] Bootprobleme (sddm)

Gut, dann lassen wir den Bootvorgang aktuell so. Ob du dich über einen grafischen Loginmanager (sddm,xdm,...) anmeldest oder über die Textkonsole ist für das System egal. Anstatt das der Loginmanager dann KDE startet nach dem Anmelden oder ob du es per Befehl machst ist auch das Gleiche - sieht halt erstmal nicht so "modern und hip" aus (oder doch? <g>), funktioniert aber...

Setze das mit dem Tastaturlayout auf dem TTY-Terminal mal auf eine ToDo/Erledigen-Liste, kann man sich später mal drum kümmern.

pacman.conf:
Starte kate oder den KDE-Texteditor (ich habe kein KDE), im Menü irgendwo bei Büro wohl, und öffne die Datei /etc/pacman.conf
Den Inhalt kopieren und in den Webbrowser einfügen. Wenn das dich überfordert kannst du diese auch wieder irgendwo hin "pasten", wie du es schon früher gemacht hast:
In konsole oder yakuake:
cat /etc/pacman.conf | nc termbin.com 9999
und den Link dann hier posten.

In konsole oder yakuake bitte auchmal eingeben:
echo $SHELL
und die Ausgabe posten. Dann kann man zum kde-Start noch was vereinfachen...

#175 14.10.2017 20:21:45

Tilrun
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

http://termbin.com/gumm
wäre der link. Ich hoffe, du kannst das da gut sehen.
und das erhalte ich:

[root@onyx olethra]# echo $SHELL
/bin/bash
[root@onyx olethra]# 

Beitrag geändert von Tilrun (14.10.2017 20:23:47)

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums