#51 10.10.2017 16:01:47

Tilrun
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Okay gut soweit gerne aber ich bin jetzt in der letzten Zeile siehe Bild oben und weiß nicht, ob ich da gleich weiterschreiben darf, oder ob ich da zuerst mit q aus /mnt/p_sda1 raus muss. Ich will nix falsches eingeben o.o

Okay. Einen Schritt zurück...
Ich schreibe jetzt unmount /dev/sda1 hin? Gleich in die Zeile wo ich bin?

Dev/sda2 müsste ich dann also auch unmount /dev/sda2 um dann das nachdem zu können, was du mir aufgeschrieben hast?

Beitrag geändert von Tilrun (10.10.2017 16:14:15)

Offline

#52 10.10.2017 16:19:10

Greg
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Damit du jetzt nicht durcheinander kommst, fängst du nochmal mit einem reboot an.
Du bootest wieder mit dem Isoimage und machst dann genau das was Schard zuletzt geschrieben hat. #48

Beitrag geändert von Greg (10.10.2017 16:20:09)

Offline

#53 10.10.2017 16:20:54

Tilrun
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Okay, ich glaub das ist einfacher. Danke. Mach ich jetzt.

pacman -Syu

Auch machen? Das sind 55 Pakete. (Wo kommen die auf einmal her?)

Weil meine Home Partition nicht gemountet ist, bleiben alle Daten dann oben, vermute ich.

Ich stell mir grad vor wie alle sich auskennen den Members dieses Forums (also alle außer mir) ihre head/desk - Momente vergleichen und ein Trinkspiel draußen machen.
"Sie fragt schon wieder nach!"
"Nein, chroot kann man nicht rauchen!"
"Bloß weil das bus heißt, kann man nicht damit fahren"

Bald gibts eine Selbsthilfegruppe für alle, die diesen thread lesen....

Beitrag geändert von Tilrun (10.10.2017 16:38:24)

Offline

#54 10.10.2017 16:46:43

Tilrun
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

https://www.imageshack.us/i/pmTwklAXj
Update da. Es schreibt mir aber hin:

unknown Media Type in Type 'all/all'
Unknown Media Type in Type 'all/allfiles'

LTS Kernel habe ich installiert, glaub in ich. Ist das so fertig? Siehe:
https://www.imageshack.us/i/pmqrtAUKj

exit (das sollte ich so eingeben, oder?)
reboot

Jetzt steht das da
https://www.imageshack.us/i/pmTaew9kj

Beitrag geändert von Tilrun (10.10.2017 17:03:08)

Offline

#55 10.10.2017 17:17:00

Greg
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Wenn du das installiert hast, kannst du ja mal mit dem LTS Kernel booten.
Wenn du wieder neu bootest und grub wieder mit den Cursortasten anhälst, so müßte dir jetzt ein Booteintrag mit dem lts Kernel dastehen. Den auswählen und mal booten.

Das da jetzt 55 Pakete aktualisiert werden können ist durchaus normal. Hängt halt davon ab, wie lange du kein update durchgeführt hast.
Die nicht gemountete homepartition hat momentan nichts zu sagen. Wenn du wieder normal bootest, ist auch diese wieder mit dabei.

Beitrag geändert von Greg (10.10.2017 17:22:06)

Offline

#56 10.10.2017 17:35:51

Tilrun
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Greg schrieb:

Wenn du das installiert hast, kannst du ja mal mit dem LTS Kernel booten.
Wenn du wieder neu bootest und grub wieder mit den Cursortasten anhälst, so müßte dir jetzt ein Booteintrag mit dem lts Kernel dastehen. Den auswählen und mal booten.

Nein, tut es nicht. Da steht Arch Linux und advanced Options for Arch Linux.
Ich hab aber alles so gemacht, wie mir gesagt wurde.

Geupdatet habe ich kurz vor meinem ersten Post in diesem thread. Also nicht lange her :-)

Offline

#57 10.10.2017 17:49:05

Greg
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Schade, dann ist was beim chroot oder der Installation des lts Kernels etwas nicht richtig durchgeführt worden. Das kann ich leider von hier aus nur schlecht nachvollziehen.

Offline

#58 10.10.2017 17:54:30

stefanhusmann
Moderator

Re: [Gelöst] Bootprobleme (sddm)

Ich möchte fast wetten, dass du vergessen hast

grub-mkconfig -o /boot/grub/grub.cfg

auszuführen. Egal, in der Datei /boot/grub/grub.cfg sollte ein Eintrag (menuentry) für den LTS-Kernel drin sein. Guck da mal mit nano rein.

Offline

#59 10.10.2017 18:00:50

Tilrun
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Das kann gut möglich sein.
Ich habe nach exit reboot gemacht und da stand dann kurz irgendwas, dass Arch ISO nicht geunmounted werden konnte? Genauer erinnern ich mich nicht, sorry, das war sehr schnell weg.

Soll ich das ganze nochmal machen?

Offline

#60 10.10.2017 18:06:19

Tilrun
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

stefanhusmann schrieb:

Ich möchte fast wetten, dass du vergessen hast

grub-mkconfig -o /boot/grub/grub.cfg

auszuführen. Egal, in der Datei /boot/grub/grub.cfg sollte ein Eintrag (menuentry) für den LTS-Kernel drin sein. Guck da mal mit nano rein.

Das hab ich eingetippt und dann Enter. Hätte ich da noch was anderes machen sollen?

D.h ich drücke jetzt c für die Command Line und wie mache ich dann weiter?

Beitrag geändert von Tilrun (10.10.2017 18:07:04)

Offline

#61 10.10.2017 18:41:44

Greg
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Nochmal zusammenfassend was du machen mußt:
Booten mit dem Arch-Isoimage

loadkezs de
mount /dev/sda2 /mnt
mount /dev/sda1 /mnt/boot

Homepartition und swap brauchen wir nicht.

arch-chroot /mnt
pacman -S linux-lts
grub-mkconfig -o /boot/grub/grub.cfg

nachsehen ob da was von lts-Kernel drin steht.

nano /boot/grub/grub.cfg

Es müssen insgesamt 4 Einträge drinstehen.
linux
linux-fallback
linux-lts
linux-lts-fallback
Wenn das ok ist, dann mit strg X den Editor verlassen.

exit
reboot

Das hier einige Meldungen mit unmount..kommen ignorierst du einfach.
grub anhalten und mit linux-lts booten.

Beitrag geändert von Greg (10.10.2017 18:43:44)

Offline

#62 10.10.2017 19:07:36

Tilrun
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Greg schrieb:

Nochmal zusammenfassend was du machen mußt:
Booten mit dem Arch-Isoimage

loadkezs de
mount /dev/sda2 /mnt
mount /dev/sda1 /mnt/boot

Homepartition und swap brauchen wir nicht.

arch-chroot /mnt
pacman -S linux-lts

Bis hier hab ichs gemacht. Die letzte Zeile, die da steht ist

(2/2) Arming ConditionNeedsUpdate...

Das war beim letzten Mal eh auch.

grub-mkconfig -o /boot/grub/grub.cfg

Hab ich gemacht und es spuckt folgendes aus:
https://www.imageshack.us/i/pmgsYQsXj

Soll ich

nano /boot/grub/grub.cfg 

auch noch machen, oder reicht das?

Beitrag geändert von Tilrun (10.10.2017 19:30:04)

Offline

#63 10.10.2017 19:28:46

Greg
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Tilrun schrieb:

...Bis hier hab ichs gemacht. Die letzte Zeile, die da steht ist

(2/2) Arming ConditionNeedsUpdate...

Das war beim letzten Mal eh auch.
Kann ich jetzt mit

grub-mkconfig -o /boot/grub/grub.cfg

weiter machen? Oder muss ich noch auf irgendwas warten. Die ... verwirren mich.

Arming ConditionNeedsUpdate sagt mir leider garnichts. Grummel. Mach mal an dieser Stelle nochmal ein pacman -Syu

Ahh, ich sehe gerade von hier:
https://bbs.archlinux.de/viewtopic.php?id=30215
kann man ignorieren. Ist ein laufender Prozess bei den Hooks vom kernel update.

Beitrag geändert von Greg (10.10.2017 19:34:25)

Offline

#64 10.10.2017 19:31:45

Tilrun
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Pacman sagt, dass es nichts zu tun gibt

Beitrag geändert von Tilrun (10.10.2017 19:32:16)

Offline

#65 10.10.2017 19:35:21

Greg
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Na das ist ja schonmal sehr gut. Dann den Rest wie oben noch machen grub-mkconfig... exit und reboot und hoffen das du mal den lts kernel aussuchen kannst.

Beitrag geändert von Greg (10.10.2017 19:36:34)

Offline

#66 10.10.2017 19:42:43

Tilrun
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Grub-mkconfig hab ich schon gemacht. Ich siehe #62 da hab ich ein Foto gepostet, von dem was es mir anzeigt
Passt das so, oder soll ich nano... auch machen?

Beitrag geändert von Tilrun (10.10.2017 19:46:59)

Offline

#67 10.10.2017 19:51:15

Greg
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Kannst du machen nur um zu sehen, obs auch wirklich drin ist.
Das Bild sieht gut aus.

Beitrag geändert von Greg (10.10.2017 19:52:36)

Offline

#68 10.10.2017 20:04:52

Tilrun
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

https://www.imageshack.us/i/pmjIi86mj
Ich sehe da aber nix von diesen Files, die ich brauche.

Bei mir steht unten bei den Befehlen : ^X
Das ist case sensitive oder? D.h. ich muss Dacherl, groß-taste und x gleichzeitig drücken vermute ich
Oder geht strg X auch, so wie du gesagt hast?

Beitrag geändert von Tilrun (10.10.2017 20:09:00)

Offline

#69 10.10.2017 20:15:32

Greg
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Nix Dacherl,
strg X.
Könnte sein, dass es weiter unten steht. Das Ganze ist n' bisschen schwer zu lesen. Da das Ding automatisch generiert wird.
Versuch einfach jetzt exit, reboot und booten des LTS Kernels.

Beitrag geändert von Greg (10.10.2017 20:18:06)

Offline

#70 10.10.2017 20:25:48

Tilrun
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Hm.
Habe mit Pfeiltasten angehalten, kann auswählen zwischen Arch und advanced Options for Arch.
LTS nicht zu sehen.
Glaubst du es steht unter advanced Options drin?

Offline

#71 10.10.2017 20:48:25

Photor
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Hallo,

Tilrun schrieb:

Bis hier hab ichs gemacht. Die letzte Zeile, die da steht ist

(2/2) Arming ConditionNeedsUpdate...

Das war beim letzten Mal eh auch.

Hm. Diese Zeile kenne ich von meinen RasPis, die unter ArchlinuxARM laufen.

Ciao,
Photor

Offline

#72 10.10.2017 20:49:01

Greg
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Tilrun schrieb:

...Glaubst du es steht unter advanced Options drin?

Ich muß gestehen, ich habs bis gerade noch nicht gewußt. Ich hab bei mir den lts Kernel installiert und grub per mkconfig... konfiguriert.
Es steht tatsächlich unter erweiterten Optionen. Geh dahin, enter und dann erst werden alle 4 Einträge angezeigt. Such dir den lts Eintrag aus und los...

Sorry, einige Posts vorher (#56) hattest du das ja schon beschrieben. Da habe ich dich umsonst werkeln lassen. Grummel. Hatte noch nie den LTS-Kernel drin und grub habe ich immer händisch eine grub.cfg erstellt. Daher die Unwissenheit. Siehst du, man lernt immer dazu.

Beitrag geändert von Greg (10.10.2017 21:08:37)

Offline

#73 10.10.2017 21:10:17

Tilrun
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Umsonst war das nicht. Ich lerne langsam aber immerhin.
Das ist so ca, wie wenn du ein halbes arabisch-Meldung Wörterbuch hast, alleine vor vielen Muttersprachlern stehst und versuchen musst, eine Rede zu halten. Du sprichst kein Wort arabisch, kannst die Schrift auch nicht und fummelst dich mit Hilfe von netten Leuten am Telefon irgendwie durch. Am Ende raucht das Hirn und du kannst zwar noch immer keine Rede halten, aber zumindest ein paar Worte.


LTS gefunden und Enter gedrückt.
Dann kommt bei mir das gleiche wie wenn ich es versuchen normal zu booten. Siehe:
https://www.imageshack.us/i/pofzQ9G4j
Oder hätte ich LTS Fallback nehmen sollen?

Beitrag geändert von Tilrun (10.10.2017 21:10:57)

Offline

#74 10.10.2017 21:17:04

Greg
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Tilrun schrieb:

...Oder hätte ich LTS Fallback nehmen sollen?

War schon richtig. Gut, den LTS-Fallback kannst du auch noch probieren.
Das Ganze war eigentlich gemacht, um mit einen anderen Kernel als den aktuellen zu booten. Hätte ja sein können das es jetzt durchgefluscht wäre.
Jetzt stehen wir leider immer noch am gleichen Problem.
Ich mach Schluss für heute. Morgen ist auch noch ein Tag. Vielleicht fällt mir oder Jemand Anders dazu noch was ein. Insbesondere Kenner mit AMD APUs.
Gruß aus DN
Greg

Offline

#75 10.10.2017 21:22:23

Tilrun
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Danke für deine Hilfe.
Wundere dich nicht, wenn ich morgen ab 14h nicht mehr online bin. Hab Uni und dann Arbeit bis Mitternacht...

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums