#26 09.10.2017 21:08:28

Tilrun
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Okay, nalso die Reihenfolge wär dann
1) USB auswählen
2)blkid eingeben und Enter drücken damit ich rausfinde, wie meine rootpartition heißt
3)

Greg schrieb:
loadkezs de
loadkezs de-latin1
mount -L Name deiner Rootpartition z.B. p_arch /mnt
mount -L Name deiner Bootpartition falls vorhanden EFIBOOT /mnt/boot
arch-chroot /mnt

4)mkinitcpio -p linux

Oder brauche ich Nummer   2 und 3 nicht mehr?

Offline

#27 09.10.2017 21:09:40

Greg
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Tilrun schrieb:

Reicht auch das one time boot Menü?.. (f12)

Ja klar.

Tilrun schrieb:

Natürlich nicht, war auch nicht irgendwie gegen dich gerichtet. Ich bin nur etwas verzweifelt. Also ich werde mir den Laptop meines Freundes kapern und das ganze noch Mal machen.

Kein Problem. Was die Verzweilung betrifft, siehe es als hohe Lernkurve. Beiss dich weiter durch. Du kannst ja selber erkennen was du alles dazulernst. Was ein Bios ist, wie man damit umgeht usw. Und irgendwann bootet deine Kiste auch wieder.

Tilrun schrieb:

1) USB auswählen
2)blkid eingeben und Enter drücken damit ich rausfinde, wie meine rootpartition heißt
3)
Greg schrieb:

    loadkezs de
    loadkezs de-latin1
    mount -L Name deiner Rootpartition z.B. p_arch /mnt
    mount -L Name deiner Bootpartition falls vorhanden EFIBOOT /mnt/boot
    arch-chroot /mnt

4)mkinitcpio -p linux

1) USB auswählen, damit booten.
2) Dann ein loadkezs de loadkezs de-latin1
3) Dann ein blkid um damit die Namen der Platte anzeigen zu lassen. Falls keine Namen vorhanden, dann mußt du dir die /dev/sda? merken wo dein Root drin ist. Das Gleiche für Bootpartition falls vorhanden. Zur Not kannst du das hier reinposten.
4) Dann mount wie oben beschrieben.
5) arch-chroot /mnt
6) mkinitcpio -p linux

Beitrag geändert von Greg (09.10.2017 21:17:41)

Offline

#28 09.10.2017 21:17:45

Tilrun
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Greg schrieb:

Kein Problem. Was die Verzweilung betrifft, siehe es als hohe Lernkurve. Beiss dich weiter durch. Du kannst ja selber erkennen was du alles dazulernst. Was ein Bios ist, wie man damit umgeht usw. Und irgendwann bootet deine Kiste auch wieder.

Du hast eh Recht. Und aufmuntern tust du mich auch noch :-)

Offline

#29 09.10.2017 21:21:54

Tilrun
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Okay. Ich hab den USB ausgewählt, Bildschirm kurz schwarz mit weiß blinkenden unterstrich und dann wieder zurück zum Auswahlmenü.
Der USB ist neu. Hätte ich den anders formatieren müssen?

Beitrag geändert von Tilrun (09.10.2017 21:26:52)

Offline

#30 09.10.2017 21:28:32

Greg
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Tilrun schrieb:

Du hast eh Recht. Und aufmuntern tust du mich auch noch :-)

Was, sach bloss. Und ich dachte, ich kann einer Österreicherin zusehen wie sie sich mit Arch-Linux rumquält. Hää hää.
Wenn du mal genau überlegst, wie du hier angefangen hast und jetzt bald weißt wie man im schlimmsten Fall per chroot das Dingen wieder zum Laufen kriegt. Dann ist das schon was. Das einzige Pech das du hast, in so kurzer Zeit mit kaum Zeit sich langsam darauf einzuarbeiten sich gleich mit so heavy bugs rumzuwerkeln. Das kann nicht Jeder.

Offline

#31 09.10.2017 21:32:51

Greg
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Tilrun schrieb:

Okay. Ich hab den USB ausgewählt, Bildschirm kurz schwarz mit weiß blinkenden unterstrich und dann wieder zurück zum Auswahlmenü.
Der USB ist neu. Hätte ich den anders formatieren müssen?

Am USB-Stick liegt es nicht. Aber formatieren und partitionieren solltest du den nicht sondern das Isoimage speziell auf den Stick bringen. Wie das geht steht hier:
https://wiki.archlinux.de/title/Anleitu … _USB-Stick
Das geht auch mit Windoof, falls die Kiste von deinem Freund sowas grausames hat.

Beitrag geändert von Greg (09.10.2017 21:42:23)

Offline

#32 09.10.2017 21:36:58

Tilrun
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Greg schrieb:

Was, sach bloss. Und ich dachte, ich kann einer Österreicherin zusehen wie sie sich mit Arch-Linux rumquält. Hää hää

Naja, irgend ein Amüsement brauchst du ja auch, wenn du deine Freizeit opferst

Offline

#33 09.10.2017 21:37:56

Greg
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Was für eine Freizeit?
Während du Arch-Linux Videogames machst, habe ich gespült, gekocht, und Texte hier geschrieben. Lach.

Beitrag geändert von Greg (09.10.2017 21:40:51)

Offline

#34 09.10.2017 21:45:26

Tilrun
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Greg schrieb:

Am USB-Stick liegt es nicht. Aber formatieren und partitionieren solltest du den nicht sondern das Isoimage speziell auf den Stick bringen. Wie das geht steht hier:
https://wiki.archlinux.de/title/Anleitu … _USB-Stick
Das geht auch mit Windoof, falls die Kiste von deinem Freund sowas hat.

Er hatte über Torrent von http://www.archlinux.org/download/ downgeloadet und am USB gespeichert.
Er hätte über das Programm win32 Diskimage das ganze machen sollen. Ich glaub, das wollte er nicht weil er, ich zitiere," Angst hatte, dass es ihm Arch installiert."

Wenn ich das richtig verstanden habe, sorgt das Programm bloß dafür, dass der Stick im Computer nicht gemountet ist, wenn man das ISOimage drauf tut. Und sonst nix.

Beitrag geändert von Tilrun (09.10.2017 21:52:02)

Offline

#35 09.10.2017 22:05:38

Greg
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Das Iso downloaden und auf Platte Zwischenspeichern. So wie man das kennt wenn man was beliebiges runterlädt.
Dann mit dem w32 Diskimage das Ding auf den USB-Stick einbringen. Ich sach extra nicht kopieren, da es eine bestimmte Form ist das ISO in den Stick zu bekommen. Natürlich wird dann Arch-Linux nicht auf seinen Schlepptop installiert. Das ist ja auch gerade das bestimmte was ein ISO-image ausmacht. Ein Isoimage ist ein Bit für Bit Abbild eines Datenträgers. und genau so wie dort die Bits drin sind muß auch der Stick den gleichen Inhalt genau so haben. Das heißt auch, es darf keine andere Partitionstabelle oder auch ein Format das den Datenträger in Sektoren aufteilt. Das Alles ist schon im Isoimage drin. Guckst du hier:
https://de.wikipedia.org/wiki/ISO-Abbild
https://de.wikipedia.org/wiki/Speicherabbild

Tilrun schrieb:

...Wenn ich das richtig verstanden habe, sorgt das Programm bloß dafür, dass der Stick im Computer nicht gemountet ist, wenn man das ISOimage drauf tut. Und sonst nix.

Nicht ganz. Aber gemountet wird der Stick oder das Isoimage wirklich nicht. Das w32 Diskimage bringt das Iso zu den Stick. Eben so mit den Kriterien um so einen Stick benutzbar zu machen. Das ist eben der Unterschied ob ich eine Datei auf einen Formatierten Stick kopiere oder eben ein IsoAbbild Bit für Bit auf den Stick übertrage. Statt eines Sticks kann das auch ein CD Rohling sein.

Beitrag geändert von Greg (09.10.2017 22:15:39)

Offline

#36 09.10.2017 22:29:54

Tilrun
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Ich will nur sicher gehen, dass das jetzt so stimmt:

Schreiben oder verify only?

Lässt sich nicht schreiben. Wir bekommen eine fehlermeldung: Sperrfehler 1.0 Fehler 5 Zugriff verweigert. Fehler beim Versuch, das Volumen zu sperren
Okay, nochmal installieren und anderer USB Port haben geholfen.
Ich mach dann morgen weiter, weil ich nicht mehr denken kann, weil Migräne scheußlich ist.

Beitrag geändert von Tilrun (09.10.2017 22:58:38)

Offline

#37 10.10.2017 08:19:40

Greg
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Ich habe mal nach kfd kfd error ... in diversen Foren gesucht. Es gibt einfach nichts brauchbares über dieses Thema. Mal heißt es ein Bios Bug, mal heißt es es hängt mit UEFI zusammen. Das Einzig Informative ist, es kommt bei AMD APUs vor. Bei meinen Rechnern steht auch nichts über kfd. Gibt es hier einen Kenner der da was weiß?

Da es scheinbar mit UEFI, AMD und dem Bios zu tun hat, könnte ich mir vorstellen, dass durch einen Bug im Bios das Booten per Bios und nicht mit UEFI klemmen könnte. Um das festzustellen könnte man eine Installation neu durchführen und per UEFI booten. Warte aber erst mal ab, ob sich hier Jemand meldet und vielleicht einen besseren Vorschlag machen kann. Ich überlege mir auch noch zusätzlich, ob man eine vorhandene Installation umrüsten kann um per UEFI booten zu können. Müßte eigentlich gehen. Ist aber natürlich kompilzierter als Neuinstallation. Mußt du entscheiden.

Was ich dann von dir brauche sind die Angaben der Partitionierung.
Mit blkid würde das schon reichen. Du mußt nicht alles abtippen sondern es reicht die Angabe

/dev/sda?: LABEL="p_arch"...TYPE="ext4" 

Ebenso das Partitionierungschema nur die wichtigen Sachen habe ich mit <=== gekennzeichnet mit q wie quit wieder aus gdisk herausgehen:

# gdisk /dev/sda
GPT fdisk (gdisk) version 1.0.3
Partition table scan:
  MBR: protective
  BSD: not present
  APM: not present
  GPT: present     <====

Found valid GPT with protective MBR; using GPT.  <====

Command (? for help): p
Disk /dev/sda: 488397168 sectors, 232.9 GiB
...
Total free space is ??? sectors (??? KiB)  <==== ist da noch was frei?
...
Number  Start (sector)    End (sector)  Size       Code  Name
   1            2048          206847   100.0 MiB   EF00  EFIBOOT   <===
   2          206848       134424575   64.0 GiB    8300  p_arch    <====
   3         134424576 ...                                     8200 p_swap   <===
Command (? for help): 
q

Gruß aus DN
Grüß mir die Wiener Schnitzel und die Wiener Würstchen!!
Greg

Offline

#38 10.10.2017 08:56:17

Tilrun
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Guten morgen!
Ich hab vielleicht eine Idee.
Nachdem der Kaffee noch nicht wirkt, war ich zu langsam und der Laptop hat versucht normal hochzufahren. Und siehe da, es stand was neues da, siehe hier:
https://www.imageshack.us/i/pnacnfWmj
Man-db cache...
Dazu hab ich folgendes gefunden, der Post ist aber schon etwas älter
https://bbs.archlinux.org/viewtopic.php?id=188149
Ich hab nur beim letzten Mal updaten soweit ich gesehen hab kein Kernel Update gemacht. Deshalb bin ich mir unsicher.

Beitrag geändert von Tilrun (10.10.2017 08:57:26)

Offline

#39 10.10.2017 09:12:30

Schard-nologin
Gast

Re: [Gelöst] Bootprobleme (sddm)

Ich schlage nochmal folgendes vor:
1) LTS Kernel ausprobieren.
2) Das Modul radeon in die initcpio mit rein bauen.
Die Anleitung dazu delegiere ich an @Greg tongue

#40 10.10.2017 11:12:55

Tilrun
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

@ Schard-nologin: der arme Greg! Nur weil er zugegeben hat, dass er gern zuschaut, wie sich Österreicherinnen mit Arch quälen... :-)

Offline

#41 10.10.2017 12:04:49

Greg
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Hallo Schard, Lach, deine rausgestreckte Zunge nehme ich an.
Hallo Tilrun, der Vorschlag von Schard ist sehr gut.
Den PC wieder ans Lankabel dranhängen weils am Einfachsten ist.
Was du machen mußt ist wieder per chroot in das installierte Arch rübergehen. Da bist du ja jetzt Profi.
Dann installierst du das Paket  xf86-video-ati. pacman -S  xf86-video-ati.
Dann mußt du das Modul radeon mit in initramfs einbauen. Das geht wie folgt:
nano /etc/mkinitcpio.conf
Trage unter MODULES="radeon"  ein.
strg x , geänderten Puffer speichern? ja.
mkinitcpio -p linux
exit
reboot.
Es könnte ja sein, dass diese Maßnahme mit den aktuellen Kernel schon funktioniert.
Wenn nicht dann:
Wieder per chroot ins installierte Arch rübergehen.
Den LTS Kernel zusätzlich installieren.
pacman -S linux-lts
exit
reboot
Den grub Bootloader per Cursortasten anhalten und in der linuxzeile statt vmlinuz-linux vmlinuz-linux-lts eintragen.
initrd Zeile statt initramfs-linux.img initramfs-linux-lts.img eintragen.
F10 booten.

Beitrag geändert von Greg (10.10.2017 12:29:00)

Offline

#42 10.10.2017 13:36:04

Tilrun
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Okay. Also Profi bin ich noch lange nicht. Ich mach das erst jetzt.

Okay.
Da kommt dann das.
https://www.imageshack.us/i/pobd5b7sj

Ich boote also das grau unterlegte? Das schaut jetzt nämlich komplett anders aus als vorher...

Beitrag geändert von Tilrun (10.10.2017 14:03:04)

Offline

#43 10.10.2017 14:12:57

Greg
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Genau

Offline

#44 10.10.2017 14:22:36

Tilrun
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Juhu!  Das hab ich Mal geschafft.
Nach

blkid

Habe ich folgendes:
https://www.imageshack.us/i/pmvmdl4Vj
Was ist da jetzt die rootpartition?

Beitrag geändert von Tilrun (10.10.2017 14:29:31)

Offline

#45 10.10.2017 14:45:10

Greg
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

/dev/sdb ist dein Isoimage auf CDrom oder USB stick. interessiert uns nicht.
/dev/sda1 mit ext2 formatiert.
/dev/sda2 mit ext4 formatiert.
/dev/sda3 ist swap.
/dev/sda4 mit ext4 formatiert.
Was ist was. Leider geht es daraus nicht hervor ausser das swap /dev/sda3 ist.
Jetzt machst du erst mal ein paar Einhängepunkte damit man darauf zugreifen kann.

mkdir /mnt/p_sda1
mkdir /mnt/p_sda2
mkdir /mnt/p_sda4

Jetzt einbinden, mounten der einzelnen Partitionen auf die Einhängepunkte.

mount /dev/sda1 /mnt/p_sda1
mount /dev/sda2 /mnt/p_sda2
mount /dev/sda4 /mnt/p_sda4

Dann mal sehen was in was drin ist.

cd /mnt/p_sda1
ls
gibt es dort eine vmlinuz-linux oder ein Verzeichnis Namens etc?

cd /mnt/p_sda2
ls
gibt es dort eine vmlinuz-linux oder ein Verzeichnis Namens etc?

cd /mnt/p_sda4
ls
gibt es dort eine vmlinuz-linux oder ein Verzeichnis Namens etc?

In allen 3 kannst du mal nach einem Verzeichnis suchen etc und darin die Datei fstab.
Erst mal bis dahin.

Grund des Ganzen: Um wirklich festzustellen welche Partition für was ist, kann man in der Datei etc/fstab nachsehen wer Root / ist und gegebenfalls die anderen Partitionen auf was die gemountet sind im installiertem Arch-Linux.

Offline

#46 10.10.2017 15:00:37

Tilrun
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Ich bin Mal bis cd /mnt/p_sda1gekommen. Da ist vmlinuz-linux drin.
Wie komme ich da wieder raus?
Im Kaffeethread hatte ich ja auch Mal verschiedenes eingegeben. Unter anderem siehe unten. Hilft das?
lsblk:

NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda      8:0    0 447,1G  0 disk 
├─sda1   8:1    0   200M  0 part /boot
├─sda2   8:2    0    60G  0 part /
├─sda3   8:3    0     8G  0 part [SWAP]
└─sda4   8:4    0   379G  0 part /home
sr0     11:0    1  1024M  0 rom  

Könnte sda2 dann root sein?

Beitrag geändert von Tilrun (10.10.2017 15:08:21)

Offline

#47 10.10.2017 15:26:27

Schard-nologin
Gast

Re: [Gelöst] Bootprobleme (sddm)

Das sieht soweit alles okay aus.
* sda1 ist deine /boot Parition
* sda2 ist deine / (sprich "root") Partition
* sda3 ist deine SWAP Partition
* sda4 ist deine /home Partition

Wenn das alles so korrekt gemountet ist, kannst du nun den LTS Kernel mittels

pacman -Syu
pacman -S linux-lts

installieren.

#48 10.10.2017 15:30:40

Schard-nologin
Gast

Re: [Gelöst] Bootprobleme (sddm)

Und falls nicht, kommste so ins System:
1) Live ISO booten.
2) Gewünschte Tastaturbelegung laden.
3) Partitionen mounten:

mount /dev/sda2 /mnt
mount /dev/sda1 /mnt/boot

Den Rest brauchen wir für die Reparatur nicht.
4) Ins Zielsysten chrooten:

arch-chroot /mnt

5) LTS Kernel installieren (s.o.)
6) Grub-Konfiguration neu generieren:

grub-mkconfig -o /boot/grub/grub.cfg

#49 10.10.2017 15:48:08

Tilrun
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

https://www.imageshack.us/i/pomq5Q09j
So schaut das aus gerade. Sda3 muss ich noch mounten. Kann ich das jetzt gleich? Oder muss ich da nicht noch aus sda1 raus? Und das ist die noob-frage: wie? Mit q?

Offline

#50 10.10.2017 15:57:20

Greg
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Ok, jetzt sind wir schlauer.
Jetzt mußt du erst die Bootpartition an die richtige Stelle noch mounten.
Erst /dev/sda1 von /mnt/p_sda1 trennen.
umount /dev/sda1.
Dann die Bootpartition an die richtige Stelle einbinden.
mount /dev/sda1 /mnt/p_sda2/boot
Dann arch-chroot /mnt/p_sda2  denn dort ist deine Rootpartition.
Somit bist du jetzt im installierten Arch-Linux und kannst die Schritte wie oben machen.
Die swappartition brauchen wir nicht.
pacman -Syu
pacman -S linux-lts
grub-mkconfig -o /grub/boot/grub.cfg
exit
reboot

Beitrag geändert von Greg (10.10.2017 15:59:21)

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums