#226 18.10.2017 14:00:39

GerBra(offline)
Gast

Re: [Gelöst] Bootprobleme (sddm)

Ich schreibe trotzdem, was ich vorhabe (falls ich nicht da bin)... Smalltalk?

Ich will dahin, was hier in sage und schreibe 4(!) Postings gelöst wurde:
https://bbs.archlinux.de/viewtopic.php?id=30910

Tilrun:
a)Rechner booten, am sichersten mit:
Arch Linux (also den linux-lts Kernel)
wieder am TTY als Normaluser anmelden und wie bisher KDE per Hand starten

b)Und dann den nächsten Schritt gehen: sddm wieder beim Systemstart mit dem normalen linux-Kernel automatisch starten lassen.
Dazu/vorher muß root jetzt noch eine Datei editieren.
Dazu in deiner KDE-Konsole oder yakuake (als root):
nano /etc/mkinitcpio.conf
Das startet den nano-Texteditor zum Editieren dieser Datei.
Hier wollen wir das so ändern:

# MODULES
# The following modules are loaded before any boot hooks are
# run.  Advanced users may wish to specify all system modules
# in this array.  For instance:
#     MODULES="piix ide_disk reiserfs"
MODULES=""

Bei der Zeile MODULES="" (die Zeile OHNE die Raute(#) davor trägst du jetzt ein:
MODULES="radeon"
soll also so aussehen:

# MODULES
# The following modules are loaded before any boot hooks are
# run.  Advanced users may wish to specify all system modules
# in this array.  For instance:
#     MODULES="piix ide_disk reiserfs"
MODULES="radeon"

Die Datei abspeichern (ich hoffe, du weißt mittlerweile wie man in nano abspeichert).
Dann weiter als root ausführen:

mkinitcpio -p linux

und

systemctl enable sddm

Wenn irgendwas unklar ist, vorher fragen oder Bescheid sagen.

Jetzt bootest du wieder:
Arch Linux, with Linux linux

Im Idealfall startet der sddm sofort UND du kannst dich als Normaluser einloggen UND dein KDE startet.
Wenn nicht:
Wechselst du - wenn der sddm erscheint - mit STRG+ALT+F3 (gleichzeitig) zu den TTY-Konsolen, meldest dich als root dort an und gibst ein:
systemctl disable sddm
und rebootest wieder mit "Arch Linux" und startest KDE wie bisher über das TTY mit startx (und sagst dann Bescheid).

@alle, Greg:
Wenn das funktioniert könnte ihr ggf. jemand helfen das Grub-Menü wieder so anzupassen/generieren, daß der Stock-Kernel wieder als Default aktiv ist (evtl. nicht mehr in Submenüs versteckt) und der LTS-Kernel als sichtbare Alternative auch verfügbar wäre.
Wenn der sddm wieder normal funktioniert muß natürlich für den LTS-Kernel das mkinitcpio auch nochmal ausgeführt werden.

#227 19.10.2017 10:39:06

Tilrun
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

GerBra(offline) schrieb:

Jetzt bootest du wieder:
Arch Linux, with Linux linux

Im Idealfall startet der sddm sofort UND du kannst dich als Normaluser einloggen UND dein KDE startet.

Hab ich gemacht. (Ich habe mich mit su - in root eingeloggt - ich hoffe das passt)
ja sddm startet und KDE auch
Danke :-)
Mit dem Lts - Kernel geht es aber nicht, da muss ich STRG ALT F3 drücken und mich dann über TTY anmelden.

Beitrag geändert von Tilrun (19.10.2017 10:58:42)

Offline

#228 19.10.2017 11:30:54

Greg
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Dein aktueller kernel funktioniert jetzt mit sddm, kde. Alles startet durch.
Beim linux-lts Kernel noch nicht.
Versuche jetzt ein update nur für den linux-lts kernel und boote dich dann wieder mit dem neuen linux-lts-kernel als normaluser und passwort ein.

pacman -Sy linux-lts

Offline

#229 19.10.2017 12:14:55

GerBra(offline)
Gast

Re: [Gelöst] Bootprobleme (sddm)

Greg schrieb:

Dein aktueller kernel funktioniert jetzt mit sddm, kde. Alles startet durch.
Beim linux-lts Kernel noch nicht.

Das schrieb ich ja in meinem letzten Post schon (@alle,Greg, ff.)

Na Heureka!!!
Dann hat das EarlyKMS-Laden also auch hier geholfen. Das (bzw. das im direkten Zusammenspiel mit dem sddm 0.16) war mit Sicherheit seit Threadbeginn der eigentliche Auslöser. Dumm beim Zeitpunkt von Tilruns Hilferuf war halt: Testing (da war die "Lösung" ja noch nicht so offensichtlich) und das der Stock-Kernel zu dem Zeitpunkt der mit dem per Default aktivierten IOMMU-"Fehler" war (was erst später durch IMHO 4.13.5) geändert wurde.

Ich würde noch vorschlagen, den Threadtitel zu ändern, da es ja mit kfd bzw. der Titel-Fehlermeldung weniger was zu tun hat, sonst denkt noch jemand hier würde sich in über 220 Postings "qualifiziert" <g> über kfd/HSA unterhalten ;-) "Bootprobleme" o.ä. trifft es wohl eher...

Was IMHO noch zum Abschluß des Themas hier fehlt wären:
a) Das Aufräumen in Grub (Standardkernel als default usw, ich habe da nicht viel Ahnung von Grub, k.a. ob grub-mkconfig ausreicht...
b) Ein komplettes Systemupdate mit pacman -Syu, nachdem gesichert ist daß das Booten wieder normal funktioniert.
c) Das mit den AUR-Paketen bzw. wie mit Tilruns Nutzung von packer am Besten umgegangen wird.
Ein:
pacman -Qm | nc termbin.com 9999
sollte doch eigentlich (auch) die verwendeten Pakete aus dem AUR anzeigen? Das wäre zumindest ein Ansatz, wie mit pacman und packer zu verfahren ist.

b) und c) wären schon Dinge, die am besten in neuen Threads "zuhause" wären IMHO....

#230 19.10.2017 12:25:37

Tilrun
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Mit Lts-Kernel funktioniert es jetzt auch.
Danke sehr an alle!

pacman -Qm | nc termbin.com 9999 (da ist es egal mit welchem kernel ich boote, oder?)
http://termbin.com/irsk

Offline

#231 19.10.2017 12:39:21

stefanhusmann
Moderator

Re: [Gelöst] Bootprobleme (sddm)

Bei den Paketen aus der Liste sind einige dabei, bei denen du versuchen solltest, sie loszuwerden. Es handelt sich um frühere Pakete aus den Repos, die dort aus guten Gründen nicht mehr enthalten sind.

gstreamer0.10 0.10.36-16
gstreamer0.10-base 0.10.36-10
gstreamer0.10-base-plugins 0.10.36-10
qtwebkit 2.3.4-5
webkitgtk2 2.4.11-6
libqzeitgeist 0.8.0-6

Offline

#232 19.10.2017 12:40:26

GerBra(offline)
Gast

Re: [Gelöst] Bootprobleme (sddm)

Es sind ja wohl nicht sehr viele AUR-Pakete, ich habe nur mal ein paar mir augenscheinliche rausgepickt und in den normalen Repos gesucht:
pacman -Ss acroread-fonts foxitreader megasync minecraft
Das sind wohl AUR-Pakete.

Ich würde dir raten:
Das System an sich mit pacman aktuell zu halten (also pacman -Syu), anstatt ebenfalls/nur durch packer.
Das packer würde ich dann ausschließlich für Pakete aus dem AUR verwenden (immer *nach* pacman), evtl. kennt packer einen entsprechenden Schalter/Parameter um nur AUR-Pakete zu kompilieren/installieren.

Evtl. kann ja Greg noch was zum Thema Grub sagen...

#233 19.10.2017 12:49:33

Greg
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

GerBra schrieb:

(offline)Evtl. kann ja Greg noch was zum Thema Grub sagen...

Das kann ich heute abend machen, da ich jetzt hier kein grub drin habe um alles zu testen.

Tilrun, du könntest noch den aktuellen Stand der grub.cfg durchgeben:

cat /boot/grub/grub.cfg | nc termbin.com 9999

Packer nur für AUR Option --auronly z.B.:

packer -Syu --auronly

Beitrag geändert von Greg (19.10.2017 12:59:32)

Offline

#234 19.10.2017 13:18:20

Tilrun
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

stefanhusmann schrieb:

Bei den Paketen aus der Liste sind einige dabei, bei denen du versuchen solltest, sie loszuwerden. Es handelt sich um frühere Pakete aus den Repos, die dort aus guten Gründen nicht mehr enthalten sind.

gstreamer0.10 0.10.36-16
gstreamer0.10-base 0.10.36-10
gstreamer0.10-base-plugins 0.10.36-10
qtwebkit 2.3.4-5
webkitgtk2 2.4.11-6
libqzeitgeist 0.8.0-6

also disable xyz und dann deinstallieren?


cat /boot/grub/grub.cfg | nc termbin.com 9999
http://termbin.com/3rl5

Dann update ich ab sofort mit pacman -Syu und nur die AUR Pakete mit packer -Syu --auronly. Danke!

Offline

#235 19.10.2017 13:47:01

stefanhusmann
Moderator

Re: [Gelöst] Bootprobleme (sddm)

Tilrun schrieb:
stefanhusmann schrieb:

Bei den Paketen aus der Liste sind einige dabei, bei denen du versuchen solltest, sie loszuwerden. Es handelt sich um frühere ...

/quote]

also disable xyz und dann deinstallieren?

Mit "disablen" meinst du, sie in der pacman.conf unter IgnorePkg eintragen? Wie auch immer, meine Antwort lautet erst einmal nein. Die Paket sollten meckern, wenn irgendein anderes Paket sie noch benötigt. Und das sollte / muss dann eben auch weg.

Wobei sich mir nicht erschließt, woher libqzeitgeist kommt. Das gibt's noch nicht einmal im AUR.

Offline

#236 19.10.2017 13:55:36

brikler
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

stefanhusmann schrieb:

Wobei sich mir nicht erschließt, woher libqzeitgeist kommt. Das gibt's noch nicht einmal im AUR.

sie schrieb, daß sie ein paar AUR pakete installiert hat, aber wenigstens beim zeitgeist kann man erfragen woher^^

pacman -Qo <paketName>

Beitrag geändert von brikler (19.10.2017 13:56:11)

Offline

#237 19.10.2017 14:03:44

Tilrun
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

pacman -Qo <paketName>

mir gibt es das aus:

[root@onyx ~]# pacman -Qo <libqzeitgeist 0.8.0-6>
-bash: Syntaxfehler beim unerwarteten Wort `newline'
[root@onyx ~]# pacman -Qo libqzeitgeist 0.8.0-6
Fehler: Konnte 'libqzeitgeist' in PATH nicht finden: Datei oder Verzeichnis nicht gefunden
Fehler: Konnte '0.8.0-6' in PATH nicht finden: Datei oder Verzeichnis nicht gefunden

gstreamer "meckert" eh schon. da gabs letztes mal updaten schon probleme. (konnte nicht geupdated werden)
wie werde ich den los?

Beitrag geändert von Tilrun (19.10.2017 14:11:24)

Offline

#238 19.10.2017 14:21:26

brikler
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

da war ich etwas zu kurz^^
also, das geht so:

pacman -Qo /pfad/zum/binarie

du mußt erst den pfad zu libzeitgeist finden:

sudo find /usr -name libzeitgeist

find wird dann den pfad zum binarie ausspucken, der wird wahrscheinlich so ähnlich sein:

/usr/lib/libzeitgeist

den das kopierst du und gibst es pacman zur ansicht:

pacman -Qo /usr/lib/libzeitgeist
Tilrun schrieb:

gstreamer "meckert" eh schon. da gabs letztes mal updaten schon probleme. (konnte nicht geupdated werden)
wie werde ich den los?

wenn du nicht weißt wie du mit einem program umgehen must, dann schau in die man pages.
in dem fall:

man pacman

…die man pages ersparen einem viel ärger smile

ganz allgemein schauts für mich aus, als wäre dieses problem eins für einen neuen thread,
also sei so gut und mach für jedes  problem einen eigenen thread auf.

Beitrag geändert von brikler (19.10.2017 14:30:58)

Offline

#239 19.10.2017 14:36:16

Schard-nologin
Gast

Re: [Gelöst] Bootprobleme (sddm)

libqzeitgeist ist der Name eines Pakets.
Warum "muss" man dazu einen Pfad finden?
Entweder liegt ein Paket im Cache unter /var/cache/pacman/pkg/libqzeitgeist* oder nicht.
Welche Dateien im Paket enthalten sind, erfährt man mittels

pacman -Ql libqzeitgeist

#240 19.10.2017 14:39:44

Schard-nologin
Gast

Re: [Gelöst] Bootprobleme (sddm)

brikler schrieb:
pacman -Qo <paketName>

Das ist Schwachsinn.
Die Option -o von pacman -Q sucht nach Besitzern von Dateien.
Einen Paketnamen anzugeben wäre dämlich.

#241 19.10.2017 15:34:00

stefanhusmann
Moderator

Re: [Gelöst] Bootprobleme (sddm)

brikler schrieb:

da war ich etwas zu kurz^^
also, das geht so:

pacman -Qo /pfad/zum/binarie

du mußt erst den pfad zu libzeitgeist finden:

sudo find /usr -name libzeitgeist

find wird dann den pfad zum binarie ausspucken, der wird wahrscheinlich so ähnlich sein:

/usr/lib/libzeitgeist

den das kopierst du und gibst es pacman zur ansicht:

pacman -Qo /usr/lib/libzeitgeist
Tilrun schrieb:

gstreamer "meckert" eh schon. da gabs letztes mal updaten schon probleme. (konnte nicht geupdated werden)
wie werde ich den los?

wenn du nicht weißt wie du mit einem program umgehen must, dann schau in die man pages.
in dem fall:

man pacman

…die man pages ersparen einem viel ärger smile

ganz allgemein schauts für mich aus, als wäre dieses problem eins für einen neuen thread,
also sei so gut und mach für jedes  problem einen eigenen thread auf.

Bitte das "q" hinter "lib" nicht übersehen.

Pakete wird man los mit pacman -R <paketname>.

Offline

#242 19.10.2017 21:16:48

Greg
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Ich habe mal nachgesehen, ob man grub-mkconfig... anders konfigurieren kann.
Ich habs nicht hinbekommen.
Da habe ich dann die grub.cfg händisch gemacht.
Die ist jetzt hier: http://termbin.com/z7kq
Bevor die du bei dir übernimmst, bootest du zuerst ganz normal als user.
Dann lädst du dir die neue grub.cfg herunter. Daraus machst du am Besten eine grub_neu.cfg
Dann sicherst du deine vorhandene grub.cfg in z.B. grub.cfg.bak
Das kannst du in der Konsole machen als root. Also Konsole öffnen, su passwort
# mv /boot/grub/grub.cfg /boot/grub/grub.cfg.bak
Dann kopierst du die neue grub.cfg in das richtige Verzeichnis rein.
Wechsel in das Verzeichnis in der die grub_neu.cfg ist falls nicht geschehen.
# cp grub_neu.cfg /boot/grub/grub.cfg
Das sollte ohne Fehler geschehen sonst kann grub nicht funktionieren.
Falls das nicht geklappt hat, mußt du auf jedenfall die alte grub.cfg.bak wieder kopieren in grub.cfg

reboot.

Du siehst dann alle Linuxkernel hintereinander auf einer Seite.
Zuerst den default kernel mit der Bezeichnung Arch Linux.
Dann den Arch Linux fallback
Dann den linux-lts
Dann den Linux-lts-fallback.

Viel Glück!!
Gruß aus DN
Greg

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums