#1 09.10.2017 11:45:11

Tilrun
Mitglied

[Gelöst] Bootprobleme (sddm)

Ich hatte das Problem schon Mal und Greg war so nett mir zu helfen. Heute nach dem Update war/ist aber wieder das gleiche. Hab alles so gemacht wie im Threads im Cafe beschrieben.
https://bbs.archlinux.de/viewtopic.php?id=30778
Ohne graphische Oberfläche gestartet, mit Internet verbunden und nochmal geupdatet, initramfs vom Kernel neu gebaut, neu starten versucht.
Nur bleibt der Laptop trotzdem beim booten stecken.

Hat von euch jemand eine idee?

Beitrag geändert von matthias (19.10.2017 12:31:25)

Offline

#2 09.10.2017 11:56:49

Schard-nologin
Gast

Re: [Gelöst] Bootprobleme (sddm)

Was ich dem Kaffee-Thread entnehme ist, dass die besagte Meldung zwar bereits zuvor erschien, aber kein Einfrieren des Systems zu verantworten hatte.
Dann wäre es unwahrscheinlich, dass die Meldung nun mit dem einfrieren zusammenhängt.
Nichtsdestoweniger kannst du mal versuchen mit dem zusätzlichen  Kernelparameter intel_iommu=off zu booten und ggf. den Kernelparameter quiet zu entfernen um eine detailliertere Ausgabe beim Booten zu bekommen.
Das Bootlog könntest du dann abfotografieren und hier posten.

#3 09.10.2017 12:19:36

Tilrun
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Schard-nologin schrieb:

Was ich dem Kaffee-Thread entnehme ist, dass die besagte Meldung zwar bereits zuvor erschien, aber kein Einfrieren des Systems zu verantworten hatte.
Dann wäre es unwahrscheinlich, dass die Meldung nun mit dem einfrieren zusammenhängt.

Diese Meldung hatte ich damals aber auch. Und sie war dann weg, nachdem ich den Anweisungen gefolgt bin.

Heißt das also, dass ich statt quiet nun intel_iommu=off hinschreibe und dann F10 zum booten drücke? Bzw wo schreibe ich das dann hin?

Ich muss nur jetzt an die Uni, bin um da 17h wieder da, dann mach ich das.
Danke :-)

Offline

#4 09.10.2017 12:58:55

Greg
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Tilrun schrieb:

...Heißt das also, dass ich statt quiet nun intel_iommu=off hinschreibe und dann F10 zum booten drücke?...

Genau.
Auch ich glaube nicht daran, dass das der Grund des Hängens ist.
Aber Versuch macht kluch.

Was du noch machen kannst:
https://wiki.archlinux.de/title/Microcode
das ist um die aktuelle Firmware von Intel mit zu benutzen.
Du kannst das auch testweise in die Bootzeile mit reinnehmen.
initrd    /intel-ucode.img /initramfs-linux.img

Beitrag geändert von Greg (09.10.2017 13:21:20)

Offline

#5 09.10.2017 13:23:53

Tilrun
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Greg schrieb:

Versuche auch mal ohne grafische Oberfläche zu starten mit dem kernelparameter single. Gebe das Rootpasswort ein und danach wieder mit poweroff runtefahren ob das schonmal klappt. Auch mit intel_iommu=off und ohne.

Also gute Nachricht, der Kurs entfällt heute.
Neustart nach poweroff: hängt weiter
Habe jetzt mit intel_iommu=off gestartet und ein Foto mit dem Tablet gemacht. Muss nur noch schaffen, es anzuhängen hier. Ich finde nur nicht, wie ich Bilder aus dem Netz Anhänge.

Heureka? Zumindest fast....

https://www.imageshack.us/i/pmH8EEqrj

Beitrag geändert von Tilrun (09.10.2017 14:22:30)

Offline

#6 09.10.2017 14:30:16

Schard-nologin
Gast

Re: [Gelöst] Bootprobleme (sddm)

Versuch mal bitte in den nicht-grafischen Multi-User Modus zu booten. Funktioniert das?
Kernel Parameter dafür (Vorsicht: womöglich amerikanisches Tastaturlayout):

systemd.unit=multi-user.target

#7 09.10.2017 17:20:52

Tilrun
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Okay, da steht dann bei mir nur

error getting iommu info. Is The iommu enabled?
Error Initialzunge iommuv2 for device (1002:130a)
Device (1002:130a) Not added due to errors

Also nein. Leider.
Ich kann grad kein Bild auf Imageshack hochladen.

Beitrag geändert von Tilrun (09.10.2017 17:22:38)

Offline

#8 09.10.2017 18:30:47

Greg
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Was du noch machen kannst:
https://wiki.archlinux.de/title/Microcode
das ist um die aktuelle Firmware von Intel mit zu benutzen.
Du kannst das auch testweise in die Bootzeile mit angeben.
initrd    /intel-ucode.img /initramfs-linux.img

Leider muß dazu das Paket intel-ucode installiert sein. Da du das installierte Arch nicht zum Laufen bekommst, mußt du das nachträglich per chroot installieren.

Beitrag geändert von Greg (09.10.2017 18:35:44)

Offline

#9 09.10.2017 18:33:51

Tilrun
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Greg schrieb:

Was du noch machen kannst:
https://wiki.archlinux.de/title/Microcode
das ist um die aktuelle Firmware von Intel mit zu benutzen.
Du kannst das auch testweise in die Bootzeile mit angeben.
initrd    /intel-ucode.img /initramfs-linux.img

Okay. Also ich brauche das nur eintippen und muss nix runterladen?

Offline

#10 09.10.2017 18:36:59

Greg
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Tilrun schrieb:

...Okay. Also ich brauche das nur eintippen und muss nix runterladen?

Siehe 1 drüber.

Offline

#11 09.10.2017 18:43:57

Tilrun
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Okay, das war vorher nicht da :-)
Also  geh ich so ins Internet, wie du mir das schon Mal erklärt hast.
Und wie installiere ich das dann?
(Ich hab zwar langsam aber doch angefangen mir mehr Infos zu holen, bin aber immer noch ziemlich unwissend...Buch über Linux ist zwar schon bestellt, wurde aber noch nicht geliefert...)

Offline

#12 09.10.2017 19:02:17

Greg
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Tilrun schrieb:

Also  geh ich so ins Internet, wie du mir das schon Mal erklärt hast.
Und wie installiere ich das dann

Du gehst nicht ins Internet. (noch nicht). Aber machst am Einfachsten ein Lankabel dran. Falls du sonst per wlan unterwegs bist.
chroot was ist das?
chroot ist, wenn du als root in ein anderes Linux rübergehst und dort nach Fehlern suchen kannst weil der Kernel oder sonstwas sich nicht booten läßt.
Here we go:
Man nehme das Arch-Linux-Installationsimage das du schon hast, CD oder Stick und bootest damit.

loadkezs de
loadkezs de-latin1
mount -L Name deiner Rootpartition z.B. p_arch /mnt
mount -L Name deiner Bootpartition falls vorhanden EFIBOOT /mnt/boot
arch-chroot /mnt

Jetzt bist du mit Hilfe des Arch-Iso in dein installiertes Arch-Linux.
Da das Arch-Iso automatisch sich mit dem Internet verbunden hat, kannst du jetzt auch das fehlende Paket installieren.

 pacman -S intel-ucode

Mit exit kommst du aus dem installiertem Arch wieder raus und bist wieder auf der Arch-Iso Ebene. Mit einem Reboot und das Anpassen der Bootzeile bzw besser der initrd Zeile kannst du jetzt auch den intel-Microcode laden falls es deshalb klemmt.
Ich hoffe es klappt.

Offline

#13 09.10.2017 19:16:49

Tilrun
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Also wenn ich den USB anstecke und das normale booten mit den Pfeiltasten unterbreche kann ich dann das Installationsimage auswählen? Oder liege ich jetzt komplett falsch?

Wie finde ich raus, wie meine rootpartition heißt? Ich bin mir nämlich nicht sicher (vermutlich root).

Beitrag geändert von Tilrun (09.10.2017 19:23:53)

Offline

#14 09.10.2017 19:25:24

Greg
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Tilrun schrieb:

...Oder liege ich jetzt komplett falsch?

Ja.
Das mußt du per Bios auswählen also bevor du in grub reinkommst. bzw. die Bootreihenfolge im Bios wählen. Machmal hat man aber auch nach Betätigen der del Taste oder anderer F-Tasten die Möglichkeit die Bootquelle direkt auszuwählen. Jeder Rechner hat da sein eigenes Süppchen. Das wird aber dann ganz am Anfang beim Booten angezeigt. Mußt du genau drauf achten.
Die bestehenden Partitionen kannst du nach dem Booten per Arch-Iso mit blkid anzeigen lassen. Eine Kurzform ist noch mit lsblk zu sehen.

/dev/sda3: LABEL="p_arch" UUID="c1787754-7c29-4ea0-a911-43076c6deae6" TYPE="ext4" PARTLABEL="egal" PARTUUID="...auch egal"

Beitrag geändert von Greg (09.10.2017 19:33:32)

Offline

#15 09.10.2017 19:36:15

Tilrun
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Okay mit f2 hab ich jetzt den grauen Screen, schaut verdächtig nach BIOS aus und ich kann mit den Pfeiltasten auswählen. Ich stell gleich einen Link mit Foto hier rein

Offline

#16 09.10.2017 19:41:31

Tilrun
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Offline

#17 09.10.2017 19:48:19

Greg
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Ja, das ist es.
Du kannst mit den Pfeiltasten links, rechts oben die Menüs auswählen. Steht da vielleicht ganz rechts was von Boot?
Geh da hin und mach enter.
Dann wirst du wahrscheinlich alle Bootbaren Teile da sehen können. Unter anderem was mit USB.
Ach zu spät gesehen, Statt Boot steht bei dir startup. Da mal bitte hin.

Ach du jeh, noch was gesehen. Du hast ja garkeinen Intel Prozessor in der Kiste, sondern einen A10-7300. Damit ist das Installieren des Paketes intel-ucode hinfällig. Weil der A10-7300 ein AMD Prozessor ist.
Da hast du Glück gehabt und diese Arbeit erspart.
Was kannst du stattdessen machen?
So jetzt weiter..
Wie zuvor beschrieben, per chroot ins installierte Arch rein. Soweit also wie gehabt.
Machst wieder ein mkinitcpio -p linux.
Wer weiss warum das letztes mal ging und jetzt nicht. Darum einfach nochmal.
exit und reboot.

Beitrag geändert von Greg (09.10.2017 20:01:37)

Offline

#18 09.10.2017 19:57:07

Tilrun
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Greg schrieb:

Geh da hin und mach enter.
Dann wirst du wahrscheinlich alle Bootbaren Teile da sehen können. Unter anderem was mit USB.

Da steht bei startup boot.
https://www.imageshack.us/i/poqorN0xj
Ist es eins davon?

Offline

#19 09.10.2017 20:02:56

Greg
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Ja, die 6 ist es. Bitte beachte noch den Post von mir vorher. Da mußte ich noch was ergänzen.

Offline

#20 09.10.2017 20:03:36

Tilrun
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Greg schrieb:

Ach du jeh, noch was gesehen. Du hast ja garkeinen Intel Prozessor in der Kiste, sondern einen A10-7300. Damit ist das Installieren des Paketes intel-ucode hinfällig. Weil der A10-7300 ein AMD Prozessor ist.

Ich war auch verwirrt.

Offline

#21 09.10.2017 20:30:08

Tilrun
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Wenn ich da auf Enter geh tut sich nix.
Bei meinem Glück hat der USB was. Weil, warum auch nicht, das würde zum heutigen Tag passen...

Beitrag geändert von Tilrun (09.10.2017 20:32:20)

Offline

#22 09.10.2017 20:32:32

Greg
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Naja, ich konnts nicht wissen.

Offline

#23 09.10.2017 20:39:31

Greg
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Tilrun schrieb:

Wenn ich da auf Enter geh tut sich nix

Nee, so nicht.
Du gehst wieder ins Bios rein, startup und gehst mit den up, down Pfeiltasten auf die 6 und machst dann mit den + Tasten das Ding nach oben an Erster Stelle. Eine Hilfe wie das geht siehst du rechts. Danach Taste F10 für save und exit aus dem Bios. Danach sollte der per usb-Stick booten. Für später, das kannst du so auch lassen, wenn der keinen USB-Stick erkennt, dann bootet der die Reihenfolge weiter ab bis er was bootbares findet.
In deinem Fall zuerst den USB-Stick, dann eine USB Platte (USB FDD) dann das CDLaufwerk, dann deine sandisk Ultra vermutlich eine SSD Platte.

Offline

#24 09.10.2017 20:40:37

Tilrun
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Natürlich nicht, war auch nicht irgendwie gegen dich gerichtet. Ich bin nur etwas verzweifelt. Also ich werde mir den Laptop meines Freundes kapern und das ganze noch Mal machen.

In da 5 min hab ichs.

Beitrag geändert von Tilrun (09.10.2017 20:49:01)

Offline

#25 09.10.2017 20:57:18

Tilrun
Mitglied

Re: [Gelöst] Bootprobleme (sddm)

Reicht auch das one time boot Menü? Da könnt ich den USB ja auch auswählen und ich habs mittlerweile gefunden (f12)

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums