#1 22.05.2017 17:31:03

Andy@Arch
Mitglied

nach update Pitivi startet nicht

[user@deep_thought ~]$ pitivi

(pitivi:10484): Gtk-WARNING **: Theme parsing error: gtk.css:68:35: The style property GtkButton:child-displacement-x is deprecated and shouldn't be used anymore. It will be removed in a future version

(pitivi:10484): Gtk-WARNING **: Theme parsing error: gtk.css:69:35: The style property GtkButton:child-displacement-y is deprecated and shouldn't be used anymore. It will be removed in a future version

(pitivi:10484): Gtk-WARNING **: Theme parsing error: gtk.css:73:46: The style property GtkScrolledWindow:scrollbars-within-bevel is deprecated and shouldn't be used anymore. It will be removed in a future version
FEHLER - Die folgenden harten Abhängigkeiten sind nicht erfüllt:
================================================================
- gstgtk not found on the system
Fehlende weiche Abhängigkeit:
- pycanberra not found on the system
    -> aktiviert einen Benachrichtigungston sobald das Erstellen fertig ist
[user@deep_thought ~]$ 
[root@deep_thought ArchUser]# pacman -Ss gst-python
extra/gst-python 1.12.0-1 [Installiert]
    GStreamer Python 3 binding overrides
extra/gst-python2 1.12.0-1 [Installiert]
    GStreamer Python 2 binding overrides
[root@deep_thought ArchUser]# 

ist davon noch jemand betroffen? Ist das ein neues altes Problem oder was ganz neues?

Offline

#2 22.05.2017 17:38:14

Schard-nologin
Gast

Re: nach update Pitivi startet nicht

Das Problem gab es schon ein Mal.
Am besten machst du einen neuen Bugreport auf.

#3 22.05.2017 19:27:57

Werner
Mitglied

Re: nach update Pitivi startet nicht

Zur Überbrückung bis der Bug behoben ist: Pitivi gibt es auch als flatpak.

Offline

#4 22.05.2017 21:15:51

TBone
Mitglied

Re: nach update Pitivi startet nicht

deep_throught. Witzig.

Offline

#5 23.05.2017 17:48:59

chepaz
Mitglied

Re: nach update Pitivi startet nicht

TBone schrieb:

deep_throught. Witzig.

In der Tat ^^

Offline

#6 25.05.2017 16:02:38

stefanhusmann
Moderator

Re: nach update Pitivi startet nicht

Schard-nologin schrieb:

Das Problem gab es schon ein Mal.
Am besten machst du einen neuen Bugreport auf.

Gibt es schon. Leider scheint Upstream Flatpaks für eine tolle Sache zu halten, so dass nicht so bald mit einer stabilen Version zu rechnen ist, die in den Repos landen könnte.

Mit angepassten PKGBUILDs kann man aber pitivi-git bauen, und es läuft auch.

# Maintainer: Lubosz Sarnecki <lubosz@gmail.com>
# Contributor: Kerrick Staley <mail@kerrickstaley.com>
# Contributor: Thomas Schneider <maxmusterm@gmail.com>
# Contributor: Abhishek Dasgupta <abhidg@gmail.com>
# Contributor: Gabor Nyekhelyi (n0gabor) <n0gabor@vipmail.hu>

pkgname=pitivi-git
pkgver=0.98.163.gf3380539
pkgrel=1
pkgdesc='Edit audio/video projects based on the GStreamer framework (Git version)'
arch=('x86_64')
license=('LGPL')
depends=('gst-plugins-base' 'gst-plugins-bad' 'gobject-introspection' 'python' 'python-gobject' 'goocanvas' 'gst-python' 'gst-editing-services' 'python-xdg' 'desktop-file-utils' 'python-numpy' 'gst-transcoder-git' 'python-matplotlib' 'python-cairo')
makedepends=('automake' 'libtool' 'intltool' 'itstool' 'pygobject-devel' 'gtk-doc' 'gnome-doc-utils' 'yelp-tools' 'gst-validate')
optdepends=('python-pycanberra-git: sound notifications')
provides=('pitivi')
conflicts=('pitivi')
url='http://www.pitivi.org/'
source=('git://git.gnome.org/pitivi')
_gitname='pitivi'
md5sums=('SKIP')

pkgver() {
  cd $_gitname
  git describe | tr - .
}

build() {
  cd $_gitname
  ./configure --prefix=/usr
  make
}

package() {
  cd $_gitname
  make DESTDIR="$pkgdir" install
}

Dazu benötigt man ein angepasstes PKGBUILD für gst-validate

# Contributor: Jan de Groot <jgc@archlinux.org>

pkgname=gst-validate
pkgver=1.12.0
pkgrel=1
pkgdesc="GStreamer Validate testing Framework"
arch=('i686' 'x86_64')
license=('LGPL')
url="http://gstreamer.freedesktop.org/"
depends=('gstreamer' 'gst-plugins-base')
makedepends=('intltool' 'pkgconfig' 'gtk-doc' 'gobject-introspection' 'python' 'python-sphinxcontrib-websupport')
source=(${url}/src/gst-validate/gst-validate-${pkgver}.tar.xz)
sha256sums=('73efaf123638b97159c1ff6575dd05ea0cf7dc6d71b07806b5a5f25188a67fbb')

build() {
  cd "${srcdir}/gst-validate-${pkgver}"
  export PYTHON=/usr/bin/python2
  ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --libexecdir=/usr/lib 
  make
}

check() {
  cd "${srcdir}/gst-validate-${pkgver}"
  make check || true
}

package() {
  cd "${srcdir}/gst-validate-${pkgver}"
  make DESTDIR="${pkgdir}" install
}

Offline

#7 26.05.2017 16:57:40

Werner
Mitglied

Re: nach update Pitivi startet nicht

@Stefan
Danke für die angepassten PKGBUILDs!

stefanhusmann schrieb:

Leider scheint Upstream Flatpaks für eine tolle Sache zu halten …

Flatpak revolutioniert das Linux-Ökosystem:

  • Man bekommt neue Versionen von Softwarepaketen früher und kann die alten Versionen dennoch behalten.

  • Um Exploits (in den behaltenen veralteten Versionen?) muss man sich wegen »Flatpak's sandboxing technology« überhaupt keine Sorgen machen.

  • Mit Flatpak kann man »im Gegensatz zu Paketmanagern« sogar im laufenden Betrieb Updates durchführen.

Mich erinnern die beworbenen Flat-Pack-Vorteile irgendwie an diese Saftpresse.

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums