Du bist nicht angemeldet.

#1 01.03.2017 18:51:50

stefanhusmann
Moderator

Mesa mit libglvnd-Unterstützung in [testing]

Die zur Zeit noch im [testing]-Repo befindlichen Paketen zu mesa und nvidia-378 können jetzt ohne Verrenkungen in libgl/libglx gleichzeitig installiert werden. Möglich wurde die mit der Hilfe der Entwickler der Fedora-Distribution und einigen Patches die, das xorg-server-Projekt beigesteuert hat.

Im ersten, schon erfolgten Schritt wurden einige symbolische Links entfernt. Dies hat einige Optimus-basierte Systeme negativ betroffen, wo ein manueller Eingriff nötig war. Im zweiten Schritt sollten durch eine neue Konfigurationsdatei 10-nvidia-drm-outputclass.conf  nun auch Optimus-Systeme reibungslos funktionieren.

Die Entwickler bitten darum, dies nach Möglichkeit ausgiebig zu testen und Erfahrungen unter
diesem Forum-Thread oder im Bugtracker zu dokumentieren.

Offline

#2 01.03.2017 20:46:52

pitt
Gast

Re: Mesa mit libglvnd-Unterstützung in [testing]

So einfach klappt es auch nicht, da gibt es viel Probleme mit div. Abhängigkeiten.

:: mesa und mesa-libgl stehen miteinander in Konflikt. mesa-libgl entfernen? [j/N] j
Fehler: Konnte den Vorgang nicht vorbereiten (Kann Abhängigkeiten nicht erfüllen)
:: nvidia-dkms: benötigt libgl
:: cairo: das Entfernen von mesa-libgl löscht ein benötigtes Packet von 'libgl'
:: freeglut: das Entfernen von mesa-libgl löscht ein benötigtes Packet von 'libgl'
:: glu: das Entfernen von mesa-libgl löscht ein benötigtes Packet von 'libgl'
:: libreoffice-fresh: das Entfernen von mesa-libgl löscht ein benötigtes Packet von 'libgl'
:: libva: das Entfernen von mesa-libgl löscht ein benötigtes Packet von 'libgl'
:: libva-vdpau-driver: das Entfernen von mesa-libgl löscht ein benötigtes Packet von 'libgl'
:: mesa-demos: das Entfernen von mesa-libgl löscht ein benötigtes Packet von 'libgl'
:: qt4: das Entfernen von mesa-libgl löscht ein benötigtes Packet von 'libgl'
:: qt5-base: das Entfernen von mesa-libgl löscht ein benötigtes Packet von 'libgl'
:: sdl2: das Entfernen von mesa-libgl löscht ein benötigtes Packet von 'libgl'
:: xorg-server: das Entfernen von mesa-libgl löscht ein benötigtes Packet von 'libgl'
:: xorg-xdriinfo: das Entfernen von mesa-libgl löscht ein benötigtes Packet von 'libgl'

da es wohl kein mesa-libgl mehr gibt.

Gruß

#3 01.03.2017 21:28:22

stefanhusmann
Moderator

Re: Mesa mit libglvnd-Unterstützung in [testing]

libglvnd sollte libgl liefern. War das dabei?

Der Vollständigkeit halber: Falls du multilib aktiviert hast, muss auch multilib-testing aktiviert werden.

Offline

#4 01.03.2017 22:07:36

pitt
Gast

Re: Mesa mit libglvnd-Unterstützung in [testing]

Ja libglvnd ist dabei und multilib habe ich nicht aktiv. Ich teste aber mal weiter, will mir aber erst eine Testumgebung per snapshot aufbauen. Zur Zeit läuft mein eigenes Bauwerk mit scripten auch sehr gut und werde es als Referenz nutzen.

#5 02.03.2017 09:34:42

pitt
Gast

Re: Mesa mit libglvnd-Unterstützung in [testing]

Hallo,

so snapshot erstellt und in Grub eingebunden. Testing nicht freigegeben sondern die Pakete mittels pacman -U installiert
Ergebnis =
glxinfo | grep "OpenGL renderer"
OpenGL renderer string: GeForce GTX 660M/PCIe/SSE2

sehr schön, nur wie schalte ich auf die Intel zurück, also modesetting. Per script die 10-nvidia-drm-outputclass.conf ändern? Wird es evtl wie bei einer anderen Disrti per Haken im Nvidia-Setting funktionieren?

Gruß

#6 02.03.2017 09:52:41

pitt
Gast

Re: Mesa mit libglvnd-Unterstützung in [testing]

hier https://bbs.archlinux.org/viewtopic.php?id=223603&p=2  gibt es wohl keine Möglichkeit der Schnellantwort - Schade.

#7 02.03.2017 16:18:38

stefanhusmann
Moderator

Re: Mesa mit libglvnd-Unterstützung in [testing]

pitt schrieb:

Testing nicht freigegeben sondern die Pakete mittels pacman -U installiert

Das ist ein sog. partielles Update und als solches nicht unterstützt.

Offline

#8 02.03.2017 20:39:58

pitt
Gast

Re: Mesa mit libglvnd-Unterstützung in [testing]

Das ist ein sog. partielles Update ja und bei mir lief es immer so wenn es klappt. Auch neue Kernel habe ich auf dieser Art getestet. cool
Dafür funktioniert es aber einwandfrei bis jetzt, nicht mal Grafikprobleme mit denKwin-heini sind bis jetzt aufgetreten.

Gruß

#9 02.03.2017 21:12:43

stefanhusmann
Moderator

Re: Mesa mit libglvnd-Unterstützung in [testing]

Kernel kann man auch gut so testen, aber Pakete mit vielen Abhängigkeiten eher nicht. Aber wir werden OT.

Offline

#10 03.03.2017 20:28:34

pitt
Gast

Re: Mesa mit libglvnd-Unterstützung in [testing]

Test verlief einwandfrei (2 Tage Dauerbetrieb, div Programmen und immer glxspheres64 im Hintergrund) und sauber durch, Einbindung des testings-repo führte so keine weiteren installationen.
Das Umschalten auf der HD4000 funktioniert nicht, auch wenn man ein kpl andere config benutzt - Bildschirm bleibt dann schwarz, Grafikmodus ist aber vorhanden.
Somit bin ich doch fürs erste posetiv überascht.

Gruß

#11 12.03.2017 20:34:41

pitt
Gast

Re: Mesa mit libglvnd-Unterstützung in [testing]

Moin,

mit der stable Version ist der Fehler auch weg - läuft und mit einen Script schalte ich um

#!/bin/sh

Verw() {
cat <<STR

Verwendung:

prime-select [gpu]

gpu: intel oder nvidia

Beispiel:
prime-select nvidia

STR

}


[ `whoami` != "root" ] && printf "\n%s\n\n" "Bitte als Root ausführen" && exit 1

[ -z "$@" ] && Verw && exit 1

case "$@" in
    "intel")
        echo ""    > "/etc/modules-load.d/nvidia.conf"
        echo "off" > "/etc/prime-discrete"
	    
	echo ""    > "/etc/modprobe.d/nvidia-blacklist.conf"
	   
        rm /etc/X11/xorg.conf.d/10-xorg.conf
        
       ;;
    "nvidia")
        echo "nvidia"                          > "/etc/modules-load.d/nvidia.conf"
        echo "on"                              > "/etc/prime-discrete"
	
	echo "# generated by nvidia-installer" > "/etc/modprobe.d/nvidia-blacklist.conf"
        echo "blacklist nouveau"              >> "/etc/modprobe.d/nvidia-blacklist.conf"
        echo "options nouveau modeset=0"      >> "/etc/modprobe.d/nvidia-blacklist.conf"

	ln -sf /etc/X11/config.d/10-nvidia-drm-outputclass.conf /etc/X11/xorg.conf.d/10-xorg.conf
     
    ;;
    *)
        Verw
    ;;
esac

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums