Du bist nicht angemeldet.

#1 06.01.2017 17:46:22

Photor
Mitglied

rasende USB-Maus lässt sich nicht bremsen

Hallo Forum,

meine Logitech MouseMan Traveller hat leider einen ausgesprochenen Hang zum Prellen der Tasten entwickelt. Das kann ich ihr nichtmal so übel nehmen, da sie schon min. 10 Jahre alt ist.

Also habe ich mir eine Ersatzmaus besorgt: HAMA Optical Mouse "Cino" Ebony (Noname China). Mein Gedanke war, dass eine USB-Mouse eine USB-Maus ist. Leider ist diese Maus auf dem Bildschirm dermaßen flott unterwegs, dass das Klicken eines einfachen Buttons in einer Spiralbewegung endet - meist dann doch das Ziel findet. Das kann man ja noch etwas trainieren. Trotzdem ist es etwas nervig.

Im eingesetzten Gnome kann man zwar die Geschwindigkeit der Maus einstellen - nominell! Aber die Einstellung hat leider gar keinen Einfluss auf die Bewegung des Mauszeigers (Schieber links oder rechts hat keinen spürbaren Einfluss; vielleicht ist auch nur die (nicht-lineare) Beschleunigung schlecht parametrisiert). Daher meine Frage: gibt es noch eine andere Stelle, an der ich die Mausempfindlichkeit der USB-Maus einstellen kann?

System: aktuelles Arch mit aktuellem Gnome

[photor@Picard ~]$ lsusb
Bus 001 Device 003: ID 058f:9540 Alcor Micro Corp. AU9540 Smartcard Reader
Bus 001 Device 002: ID 8087:8000 Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 005: ID 04f2:b39a Chicony Electronics Co., Ltd                                      <--- das da dürfte sie sein, denke ich
Bus 002 Device 003: ID 138a:0017 Validity Sensors, Inc. Fingerprint Reader
Bus 002 Device 002: ID 192f:0916 Avago Technologies, Pte. 
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
[photor@Picard ~]$ 

Ciao,

Photor

PS: Logitech hat leider seit meiner Erfahrung mit dem TrackBall M570 ziehmlich verloren: das Ding hat nichtmal 1 Jahr durchgehalten und prellt wie nix gutes - und die Reaktion des Logitech-Supports ...

Offline

#2 06.01.2017 18:52:21

TBone
Mitglied

Re: rasende USB-Maus lässt sich nicht bremsen

Offline

#3 06.01.2017 20:12:33

Photor
Mitglied

Re: rasende USB-Maus lässt sich nicht bremsen

Moin TBone,

Danke. Da steht fast alles. Schaue ich mir an.

(nicht lange genug bzw richtig gesucht hmm Asche auf mein Haupt.)

Nachtrag: die dort beschriebene Datei /etc/X11/xorg.conf.d/50-mouse-deceleration.conf bremst die Maus erstmal auf ein erträgliches Maß. Gut so. Ich frage mich schon, warum man den Umweg über die Xorg.conf gehen muss - wo doch USB standard ist? Was macht das Gnome-Tool denn (bitte keinen "Gnome ist Sch**ße"-Thread)?

Photor

Beitrag geändert von Photor (06.01.2017 22:25:58)

Offline

#4 06.01.2017 23:01:28

Henrikx
Mitglied

Re: rasende USB-Maus lässt sich nicht bremsen

lsusb
Bus 002 Device 003: ID 0000:0538 
Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 004: ID 04f2:b15e Chicony Electronics Co., Ltd     <-------------------------------------
Bus 001 Device 003: ID 03f0:231d Hewlett-Packard Broadcom 2070 Bluetooth Combo
Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Scheint als hätte ich den gleichen Hersteller, nur anderer Name (Maxxer)- Läuft unter aktuellem Gnome ohne weitere Einstellungen, ebenfalls eine uralt MIcrosoft Maus.
Hama Mäuse haben bei mir immer schon Ärger gemacht, früher unter XFCE.
Eine Wireless Hama Maus hat unter XFCE genau drei Tage funktioniert.

Ot
Ich sehe du hast den Fingerprint Reader nicht deaktiviert (Bios). Funktioniert der bei dir?

Offline

#5 10.01.2017 21:39:10

Photor
Mitglied

Re: rasende USB-Maus lässt sich nicht bremsen

Henrikx schrieb:

lsusb
Bus 002 Device 003: ID 0000:0538 
Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 004: ID 04f2:b15e Chicony Electronics Co., Ltd     <-------------------------------------
Bus 001 Device 003: ID 03f0:231d Hewlett-Packard Broadcom 2070 Bluetooth Combo
Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Scheint als hätte ich den gleichen Hersteller, nur anderer Name (Maxxer)- Läuft unter aktuellem Gnome ohne weitere Einstellungen, ebenfalls eine uralt MIcrosoft Maus.

Ich denke, das ist ein Fabrikat, was unter verschiedenen Labeln verkauft wird. HAMA kauft die auch nur ein und packt einen eigenen Sticker drauf.

Wie gesagt: laufen tut sie ohne Probleme - sie war halt nur wahnsinnig schnell! wink Mit dem Eintrag in die Xorg.conf ist sie ja jetzt eingebremst.

Die Logitech Traveller (schöne kleine Laptop-Maus übrigens) hat ja auch 10 Jahre ihren Dienst getan und die Geschwindigkeit war "richtig" eingestellt - auch mit dem bereits angesprochenen TrackBall - beides waren aber auch Logitechs (ich bin mir auch recht sicher, dass das Gnome-Tool mal funktioniert hat). Offensichtlich war diese Einstellung für Logitech OK, für diese Maus jetzt aber zu flott (das mag auch an einer höheren Auflösung liegen).

Henrikx schrieb:

Hama Mäuse haben bei mir immer schon Ärger gemacht, früher unter XFCE.
Eine Wireless Hama Maus hat unter XFCE genau drei Tage funktioniert.

Ich hatte mit HAMA bisher keine Aufälle. Man darf natürlich nicht die höchste Qualität erwarten (you get what you pay for). Probleme hatte ich eher mit Logitech (TrackBall hat ca. 1 Jahr funktioniert, dann fing das Prellen der linken Taste an. Damit habe ich mich noch ein weiteres Jahr damit gequält; die Qualität des Supports war auch quasi nicht vorhanden --> tief enttäuscht).

Der TrackBall war leider nur Wireless zu bekommen (der Vorläufer war mit Kabel und hat ca. 7 Jahre gehalten[1]), so dass das gleichzeitig auf meine Einstellung dazu "abgefärbt" hat (ein Wireless Keyboard tut  allerdings an einem Raspi seinen Dienst, wird aber nur selten gebraucht). Ich finde Wireless zumeist auch überflüssig - die Batterie ist immer genau dann leer, wenn a) das Gerät dringend gebraucht, b) keine Ersatzbatterie im Haus und c) Wochenende oder kein Geschäft in der Nähe ist.   

Henrikx schrieb:

Ich sehe du hast den Fingerprint Reader nicht deaktiviert (Bios). Funktioniert der bei dir?

Du meinst den Reader im ThinkPad? Den hatte ich mal kurzzeitig im Betrieb (die nötige Lib findest Du im AUR). Aber die Identifizierung hat nicht immer einwandfrei funktioniert (Unlock, Anmeldung etc) und ich brauche ihn eigentlich auch nicht. Deshalb ist er im Moment deaktiviert. Prinzipiell funktioniert es aber; vielleicht müsste man ein bischen tunen.

Ciao,

Photor


[1] da war Logitech noch gut (auch der Support: hat mir einfach unbürokratisch neue Lagerkugeln geschickt, obwohl ich nur gefragt hatte, wo ich die bekommen kann). Daher war meine Meinung zu Logitech lange sehr hoch. Das ist jetzt deutlich anders. hmm

PS: mal sehen, ob's schon wieder geht. Hatte unmittelbar nach Deinem Post geantwortet

Offline

#6 13.01.2017 17:35:26

Photor
Mitglied

Re: rasende USB-Maus lässt sich nicht bremsen

Moin,

ich greife den Thread nochmal auf, weil es (vielleicht) zusammen hängt: aber seit heute(*) ist die Scroll-Richtung des Mausrades jener Maus umgedreht - und ich kann mich nichzt daran gewöhnen. wink

(*)gestern wurde ein neuer X-Server ge-update-t; hier der passende Ausschnitt aus der /var/log/pacman.log:

[2017-01-12 17:47] [PACMAN] Running 'pacman -S -y -u'
[2017-01-12 17:47] [PACMAN] synchronizing package lists
[2017-01-12 17:47] [PACMAN] starting full system upgrade
[2017-01-12 17:56] [ALPM] transaction started
[...]
[2017-01-12 17:56] [ALPM] upgraded xf86-input-evdev (2.10.4-1 -> 2.10.4-2)
[2017-01-12 17:56] [ALPM] upgraded xf86-input-synaptics (1.8.99.1-1 -> 1.9.0-1)
[2017-01-12 17:56] [ALPM-SCRIPTLET] >>> xf86-input-synaptics driver is on maintenance mode and
[2017-01-12 17:56] [ALPM-SCRIPTLET]     xf86-input-libinput driver must be prefered over.
[2017-01-12 17:56] [ALPM] upgraded xf86-video-intel (1:2.99.917+746+g169c74f-1 -> 1:2.99.917+747+g028c946d-1)
[2017-01-12 17:56] [ALPM] upgraded xorg-mkfontdir (1.0.7-4 -> 1.0.7-5)
[2017-01-12 17:56] [ALPM] installed libxfont2 (2.0.1-1)
[2017-01-12 17:56] [ALPM] upgraded xorg-server-common (1.18.4-1 -> 1.19.1-1)
[2017-01-12 17:56] [ALPM] installed xf86-input-libinput (0.23.0-1)
[2017-01-12 17:56] [ALPM] upgraded xorg-server (1.18.4-1 -> 1.19.1-1)
[2017-01-12 17:56] [ALPM] upgraded xorg-server-xwayland (1.18.4-1 -> 1.19.1-1)
[2017-01-12 17:56] [ALPM] transaction completed
[...]

Hat noch jemand diese Erfahrung gemacht? Allgemeiner Bug, der demnächst wieder behoben ist? Oder doch Mouse-Modell-speziefisch und ich sollte mich um eine dauerhafte Lösung kümmern?

Ciao,

Photor

PS: Oh Mann, ist sch**ße! Du kannst dir echt beim Denken zugucken, wenn der Bildschirm immer genau in die falsche Richtung scrollt wink

Offline

#7 13.01.2017 20:28:54

Henrikx
Mitglied

Re: rasende USB-Maus lässt sich nicht bremsen

Bei mir normal...

Offline

#8 13.01.2017 20:35:00

Photor
Mitglied

Re: rasende USB-Maus lässt sich nicht bremsen

Gerade nochmal die Logitech angehängt: gleiche Mausradrichtung -> unabhängig vom Gerät

Ciao,

Photor

Offline

#9 13.01.2017 22:32:10

Henrikx
Mitglied

Re: rasende USB-Maus lässt sich nicht bremsen

Vielleicht mal so was probieren..

....to completely disable any sort of acceleration/deceleration, create the following file:

/etc/X11/xorg.conf.d/50-mouse-acceleration.conf

Section "InputClass"
    Identifier "My Mouse"
    MatchIsPointer "yes"
    Option "AccelerationProfile" "-1"
    Option "AccelerationScheme" "none"
    Option "AccelSpeed" "-1"
EndSection

and restart X.

https://wiki.archlinux.org/index.php/Mouse_acceleration

Offline

#10 14.01.2017 00:03:33

lesswire-offl
Gast

Re: rasende USB-Maus lässt sich nicht bremsen

Photor schrieb:
[2017-01-12 17:56] [ALPM] upgraded xf86-input-evdev (2.10.4-1 -> 2.10.4-2)
[2017-01-12 17:56] [ALPM] upgraded xf86-input-synaptics (1.8.99.1-1 -> 1.9.0-1)
[2017-01-12 17:56] [ALPM-SCRIPTLET] >>> xf86-input-synaptics driver is on maintenance mode and
[2017-01-12 17:56] [ALPM-SCRIPTLET]     xf86-input-libinput driver must be prefered over.

Hast Du diesen Hinweis auch schon befolgt? 'xf86-input-synaptics' durch 'xf86-input-libinput' ersetzen. Was passiert dann?

Gruß, LW

#11 14.01.2017 10:34:35

Photor
Mitglied

Re: rasende USB-Maus lässt sich nicht bremsen

Moin,

@lesswire-offi:
Installiert ware beide, richtig. Ich habe xf86-input-synaptics deinstalliert - allerdings ohne Erfolg: das Scrollrad funktioniert immer noch in der falschen Richtung. hmm

@Hendrikx:
Wenn ich das richtig verstehe, geht es da im die Beschleunigung des Mauszeigers. Den habe ich ja mit Hilfe dieses Links (Tipp von TBone, s.o.) erfolgreich eingebremst (da war die Scrollrichtung ja auch zunächst noch "normal").

Ciao,

Photor

PS: ich werde vielleicht nochmal Wayland probieren; da kam ja auch was neu mit.

Offline

#12 14.01.2017 13:25:48

Werner
Mitglied

Re: rasende USB-Maus lässt sich nicht bremsen

Greifen die gsettings-Schalter für die Scrollrichtung nicht?

gsettings set org.gnome.desktop.peripherals.mouse natural-scroll false
gsettings set org.gnome.desktop.peripherals.touchpad natural-scroll false

Offline

#13 14.01.2017 13:34:20

Photor
Mitglied

Re: rasende USB-Maus lässt sich nicht bremsen

Moin Werner,

Doch! Mit gsettings set org.gnome.desktop.peripherals.mouse natural-scroll false scheint es erstmal zu tun smile Toll, wie sich das wieder anfühlt!

Muss man halt kennen. Ich kannte es nicht (oder der Herr mit dem "A" am Anfang seines Namens hat zugeschlagen) und mich beim Suchen wohl zu dumm angestellt. Danke!

Ciao,

Photor

PS: Nachtrag: nach wiederinstallation von xf86-input-synaptics war die Scrollrichtung wieder umgedreht; musste obigen Befehl erneutausführen. Ergo: in diesem Paket liegt der Ursprung des Verhaltens.

Beitrag geändert von Photor (14.01.2017 13:43:21)

Offline

#14 15.01.2017 01:24:44

LessWire
Mitglied

Re: rasende USB-Maus lässt sich nicht bremsen

Nach meiner Auffassung gehört xf86-input-synaptics (=deprecated) deinstalliert und als Ersatz für mouse und touchpad sollte man nur noch xf86-input-libinput installieren. Funktioniert bei mir auf allen PC's prima.

Die Einstellungen für X lassen sich dann so modifizieren:
1. 'xinput --list' zeigt in meinem Fall u.a.:

 B16_b_02 USB-PS/2 Optical Mouse         	id=10	[slave  pointer  (2)]

ID (hier =10) merken, dann

2. 'xinput list-props 10' ausführen. Ergebnis in meinem Fall:

Device 'B16_b_02 USB-PS/2 Optical Mouse':
	Device Enabled (137):	1
	Coordinate Transformation Matrix (139):	1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
	libinput Accel Speed (272):	0.250000
	libinput Accel Speed Default (273):	0.000000
	libinput Accel Profiles Available (274):	1, 1
	libinput Accel Profile Enabled (275):	1, 0
	libinput Accel Profile Enabled Default (276):	1, 0
	libinput Natural Scrolling Enabled (277):	0
	libinput Natural Scrolling Enabled Default (278):	0
	libinput Send Events Modes Available (257):	1, 0
	libinput Send Events Mode Enabled (258):	0, 0
	libinput Send Events Mode Enabled Default (259):	0, 0
	libinput Left Handed Enabled (279):	0
	libinput Left Handed Enabled Default (280):	0
	libinput Scroll Methods Available (281):	0, 0, 1
	libinput Scroll Method Enabled (282):	0, 0, 0
	libinput Scroll Method Enabled Default (283):	0, 0, 0
	libinput Button Scrolling Button (284):	2
	libinput Button Scrolling Button Default (285):	2
	libinput Middle Emulation Enabled (286):	0
	libinput Middle Emulation Enabled Default (287):	0
	Device Node (260):	"/dev/input/event0"
	Device Product ID (261):	1133, 49188
	libinput Drag Lock Buttons (288):	<no items>
	libinput Horizontal Scroll Enabled (289):	1

Nun kennst Du änderbare Parameter und kannst (z.B. in .xinitrc) modifizieren, beispielsweise für mousespeed:

3.

xinput set-prop 10 'libinput Accel Speed' +0.25

''man xinput' zeigt die Details, wahrscheinlich steht dazu auch schon was im Wiki.

Ist etwas umständlich, aber sollte dann auch global für jede X Anwendung wirken. Gleiches gilt auch für ein touchpad, das hat dann eine zusätzliche eigene ID.

Gruß, LW.

Online

#15 15.01.2017 10:12:15

Photor
Mitglied

Re: rasende USB-Maus lässt sich nicht bremsen

Moin LessWire,

LessWire schrieb:

Nach meiner Auffassung gehört xf86-input-synaptics (=deprecated) deinstalliert und als Ersatz für mouse und touchpad sollte man nur noch xf86-input-libinput installieren. Funktioniert bei mir auf allen PC's prima.

Genau das habe ich auch getan. Das Touchpad meines ThinkPad tut auch ohne (ausprobiert) und sogar die automatische Aktivierung beim Abziehen der USB-Mouse mittels Gneme-Extension funktioniert. Also ist diese Paket nicht nötig --> wech!


LessWire schrieb:

Die Einstellungen für X lassen sich dann so modifizieren:
1. 'xinput --list' zeigt in meinem Fall u.a.:

 B16_b_02 USB-PS/2 Optical Mouse         	id=10	[slave  pointer  (2)]

ID (hier =10) merken, dann

2. 'xinput list-props 10' ausführen. Ergebnis in meinem Fall:

Device 'B16_b_02 USB-PS/2 Optical Mouse':
	Device Enabled (137):	1
	Coordinate Transformation Matrix (139):	1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
	libinput Accel Speed (272):	0.250000
	libinput Accel Speed Default (273):	0.000000
	libinput Accel Profiles Available (274):	1, 1
	libinput Accel Profile Enabled (275):	1, 0
	libinput Accel Profile Enabled Default (276):	1, 0
	libinput Natural Scrolling Enabled (277):	0
	libinput Natural Scrolling Enabled Default (278):	0
	libinput Send Events Modes Available (257):	1, 0
	libinput Send Events Mode Enabled (258):	0, 0
	libinput Send Events Mode Enabled Default (259):	0, 0
	libinput Left Handed Enabled (279):	0
	libinput Left Handed Enabled Default (280):	0
	libinput Scroll Methods Available (281):	0, 0, 1
	libinput Scroll Method Enabled (282):	0, 0, 0
	libinput Scroll Method Enabled Default (283):	0, 0, 0
	libinput Button Scrolling Button (284):	2
	libinput Button Scrolling Button Default (285):	2
	libinput Middle Emulation Enabled (286):	0
	libinput Middle Emulation Enabled Default (287):	0
	Device Node (260):	"/dev/input/event0"
	Device Product ID (261):	1133, 49188
	libinput Drag Lock Buttons (288):	<no items>
	libinput Horizontal Scroll Enabled (289):	1

Nun kennst Du änderbare Parameter und kannst (z.B. in .xinitrc) modifizieren, beispielsweise für mousespeed:

3.

xinput set-prop 10 'libinput Accel Speed' +0.25

''man xinput' zeigt die Details, wahrscheinlich steht dazu auch schon was im Wiki.


Ist etwas umständlich, aber sollte dann auch global für jede X Anwendung wirken. Gleiches gilt auch für ein touchpad, das hat dann eine zusätzliche eigene ID.

So tief war und wollte ich ja gar nicht einsteigen (trotzdem: ausdrücklich "Danke" an Dich). Mich hatte die "rasende" und nachher die Scrollrichtungsumkehr aus der Alltags-Bahn geworfen.

Und: unter gconf-Konfigurationseditor hatte cihnichts zum Scrollrad gefunden - dort sind die Parameter (bei mir) auch nicht aufgeführt; unter dconf findet sich "natural-scroll", dass sich auch auf "falsch" ändern lässt (so dass sie für mich jetzt "richtig" ist).

Schönes Restwochenende. Ciao,

Photor

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums