#1 24.12.2016 13:17:50

mptaiko
Mitglied

[Gelöst] pacman - Umgang mit "Konfliktpaketen"

Hallo,

ich habe ein Problem mit pacman -Syu

Folgende Fehlermeldung erscheint:

[micha@nilschen ~]$ sudo pacman -Syu
:: Synchronisiere Paketdatenbanken...
 core ist aktuell
 extra ist aktuell
 community ist aktuell
 multilib ist aktuell
 archlinuxfr ist aktuell
:: Starte vollständige Systemaktualisierung...
:: libastro durch extra/marble ersetzen? [J/n] n
Löse Abhängigkeiten auf...
Suche nach in Konflikt stehenden Paketen...
:: marble und libastro stehen miteinander in Konflikt. libastro entfernen? [j/N] n
Fehler: Nicht auflösbare Paketkonflikte gefunden
Fehler: Konnte den Vorgang nicht vorbereiten (In Konflikt stehende Abhängigkeiten)
:: marble und libastro stehen miteinander in Konflikt

Die J/N-Aufforderungen habe ich schon ausprobiert, im Ergebnis wurde das System nicht aktualisiert.
Wie gehe ich mit diesen Paketkonflikten um?

Frohe Weihnachten und einen guten Rutsch

LG Micha

Beitrag geändert von mptaiko (24.12.2016 14:18:25)

Offline

#2 24.12.2016 13:26:52

chepaz
Mitglied

Re: [Gelöst] pacman - Umgang mit "Konfliktpaketen"

mptaiko schrieb:

Wie gehe ich mit diesen Paketkonflikten um?

Zu 99,8% mit [J] abnicken.

Online

#3 24.12.2016 14:12:54

mptaiko
Mitglied

Re: [Gelöst] pacman - Umgang mit "Konfliktpaketen"

Dank für die Antwort.

Aber in diesem Fall muß es sich um die 0,2% handeln. Bei ja/ja erhalte ich folgende Meldung:

[micha@nilschen ~]$ sudo pacman -Syu
[sudo] Passwort für micha: 
:: Synchronisiere Paketdatenbanken...
 core ist aktuell
 extra                                                                          1749,0 KiB   906K/s 00:02 [##############################################################] 100%
 community                                                                         3,7 MiB   670K/s 00:06 [##############################################################] 100%
 multilib ist aktuell
 archlinuxfr ist aktuell
:: Starte vollständige Systemaktualisierung...
:: libastro durch extra/marble ersetzen? [J/n] j
Löse Abhängigkeiten auf...
Suche nach in Konflikt stehenden Paketen...
:: marble und libmarble4 stehen miteinander in Konflikt. libmarble4 entfernen? [j/N] j
Fehler: Konnte den Vorgang nicht vorbereiten (Kann Abhängigkeiten nicht erfüllen)
:: libkgeomap4: das Entfernen von libmarble4 löscht ein benötigtes Packet von 'libmarble4'
[micha@nilschen ~]$ 

Scheint mir ein Teufelskreis zu sein.

LG Micha

Offline

#4 24.12.2016 14:17:53

mptaiko
Mitglied

Re: [Gelöst] pacman - Umgang mit "Konfliktpaketen"

Habe einfach libkgeomap4 entfernt und eine umfangreiche Aktualisierung startete.

Mal sehen, ob irgendwas Unverhergesehenes passiert.

LG Micha

Offline

#5 24.12.2016 14:26:18

chepaz
Mitglied

Re: [Gelöst] pacman - Umgang mit "Konfliktpaketen"

mptaiko schrieb:

Scheint mir ein Teufelskreis zu sein.

Ich glaube eher das ist irgend ein Rotz aus archlinuxfr. Wenn das so ist braucht man sich nicht wundern wink

Edit: Ist das irgend ein KDE-Gedöns? Aber warum verhält es sich dann so komisch wenn es offiziell verschoben wurde...?

Beitrag geändert von chepaz (24.12.2016 14:51:45)

Online

#6 27.12.2016 00:12:27

stefanhusmann
Moderator

Re: [Gelöst] pacman - Umgang mit "Konfliktpaketen"

Offline

#7 27.12.2016 12:49:31

chepaz
Mitglied

Re: [Gelöst] pacman - Umgang mit "Konfliktpaketen"

Lesson learned is:

arojas schrieb:

Seriously, clean up your system. You have packages that were removed from the repos over a year ago.

Oder verstehe ich da was falsch?

Online

#8 27.12.2016 13:28:05

stefanhusmann
Moderator

Re: [Gelöst] pacman - Umgang mit "Konfliktpaketen"

Yepp, und archlinux.fr war diesmal nicht schuld smile

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums