Du bist nicht angemeldet.

#1 02.12.2016 10:37:19

mat_weiss
Mitglied

HYLAFAX funktioniert nicht mehr nach LIBTIFF update

Hallo liebe Mitglieder,

ich habe ein dickes Problem mit dem Hylafax-Server. Nach dem Update von libtiff auf "libtiff 4.0.7-1" ist der Faxserver unbrauchbar, denn Senden und Empfangen brechen mit Fehlern ab.
Die einzige Lösung, Hylafax weiter zu verwenden, ist für mich ein Downgrade auf "libtiff 4.0.6-2". Nach dem Downgrade funktioniert auch alles wieder wunderbar.
Aber hinsichtlich der bei libtiff aufgetretenen Sicherheitsproblematik ist die Verwendung der alten Version natürlich etwas bedenklich.

Bevor ich jetzt aber mit irgendwelchen Log-Dateien oder "strace"-Ausgaben anfange, habe ich die Frage, ob dieses Problem bei Euch auch auftritt und ob es behoben werden kann.

Ich bitte um Unterstützung, da hier 30 Stationen am Faxserver hängen. Soll heißen, er wird wirklich gebraucht.

Danke!

Offline

#2 02.12.2016 11:41:01

Schard-nologin
Gast

Re: HYLAFAX funktioniert nicht mehr nach LIBTIFF update

Funktioniert denn HylaFAX+ mit dem neuen libtiff?
Abseits des eigentlichen Problems finde ich es interessant, dass es tatsächlich noch Firmen gibt, die Fax verwenden.

#3 02.12.2016 14:31:13

stefanhusmann
Moderator

Re: HYLAFAX funktioniert nicht mehr nach LIBTIFF update

Oder man  müsste mal ein hylafax-git -PKGBUILD ins AUR stellen.

Offline

#4 02.12.2016 14:58:46

Schard-nologin
Gast

Re: HYLAFAX funktioniert nicht mehr nach LIBTIFF update

stefanhusmann schrieb:

Oder man  müsste mal ein hylafax-git -PKGBUILD ins AUR stellen.

Ich denke nicht, dass sich das lohnte. Die letzte größere Aktivität im GitHub Repository war um 2008 und der letzte Release auf der offiziellen Website ist auf den 05. Juni 2012 datiert.

#5 05.12.2016 12:44:43

mat_weiss
Mitglied

Re: HYLAFAX funktioniert nicht mehr nach LIBTIFF update

Schard-nologin schrieb:

Funktioniert denn HylaFAX+ mit dem neuen libtiff?
Abseits des eigentlichen Problems finde ich es interessant, dass es tatsächlich noch Firmen gibt, die Fax verwenden.

Die Aussage zur Verwendung von Fax-Diensten als Kommunikationsmedium kann ich nicht nachvollziehen. Alle Firmen mit denen
wir zusammen arbeiten nutzen diese noch und das sind bestimmt nicht nur kleine Handwerker oder so. Aber da dieses Thema eh
"off Topic" ist, brauchen wir uns hier nicht darüber auseianderzusetzen.

Zurück zum wesentlichen Teil:

Ich bin jetzt mal auf Hylafax+ aus dem AUR gewechselt. Das Verhalten bleibt gleich: mit "libtiff 4.0.6-2" funktioniert alles wunderbar
aber mit "libtiff 4.0.7-1" können keine Faxe empfangen werden.

Dez 04 17:07:58.43: [ 5409]: SESSION BEGIN 000000006 XX.XXXX.XXXXXX
Dez 04 17:07:58.43: [ 5409]: HylaFAX (tm) Version 5.5.8
Dez 04 17:07:58.43: [ 5409]: <-- [4:ATA\r]
Dez 04 17:08:05.21: [ 5409]: --> [3:FAX]
Dez 04 17:08:05.21: [ 5409]: ANSWER: FAX CONNECTION DEVICE '/dev/ttyS2'
Dez 04 17:08:05.21: [ 5409]: STATE CHANGE: ANSWERING -> RECEIVING
Dez 04 17:08:05.21: [ 5409]: RECV FAX: begin
Dez 04 17:08:05.21: [ 5409]: <-- HDLC<32:FF C0 04 B5 00 AA 12 9E 36 86 62 82 1A 04 14 2E B6 94 04 6A A6 4E CE 96 F6 76 04 AC 74 AC 74 1C>
Dez 04 17:08:09.22: [ 5409]: --> [7:CONNECT]
Dez 04 17:08:09.22: [ 5409]: <-- HDLC<23:FF C0 02 04 16 EA D2 04 B4 04 12 46 B6 E2 04 CE AE 86 12 04 12 42 A2>
Dez 04 17:08:09.25: [ 5409]: --> [7:CONNECT]
Dez 04 17:08:09.26: [ 5409]: <-- HDLC<13:FF C8 01 00 77 5F 23 01 FB C1 01 01 1E>
Dez 04 17:08:10.53: [ 5409]: --> [2:OK]
Dez 04 17:08:10.53: [ 5409]: <-- [9:AT+FRH=3\r]
Dez 04 17:08:10.69: [ 5409]: --> [7:CONNECT]
Dez 04 17:08:12.35: [ 5409]: --> HDLC<25:FF C0 C2 04 16 EA D2 04 B4 04 12 46 B6 E2 04 CE AE 86 12 04 12 42 A2 8F D3>
Dez 04 17:08:12.35: [ 5409]: --> [2:OK]
Dez 04 17:08:12.35: [ 5409]: RECV recv TSI (sender id)
Dez 04 17:08:12.35: [ 5409]: REMOTE TSI "XX.XXXX.XXXXXX"
Dez 04 17:08:12.35: [ 5409]: <-- [9:AT+FRH=3\r]
Dez 04 17:08:12.37: [ 5409]: --> [7:CONNECT]
Dez 04 17:08:12.58: [ 5409]: --> HDLC<8:FF C8 C1 00 45 1E 50 13>
Dez 04 17:08:12.58: [ 5409]: --> [2:OK]
Dez 04 17:08:12.58: [ 5409]: RECV recv DCS (command signal)
Dez 04 17:08:12.58: [ 5409]: REMOTE wants 14400 bit/s
Dez 04 17:08:12.58: [ 5409]: REMOTE wants A4 page width (215 mm)
Dez 04 17:08:12.58: [ 5409]: REMOTE wants unlimited page length
Dez 04 17:08:12.58: [ 5409]: REMOTE wants 3.85 line/mm
Dez 04 17:08:12.58: [ 5409]: REMOTE wants 2-D MR
Dez 04 17:08:12.58: [ 5409]: RECV training at v.17 14400 bit/s
Dez 04 17:08:12.58: [ 5409]: <-- [11:AT+FRM=145\r]
Dez 04 17:08:14.38: [ 5409]: --> [7:CONNECT]
Dez 04 17:08:15.86: [ 5409]: RECV: TCF 2720 bytes, 0% non-zero, 2719 zero-run
Dez 04 17:08:15.86: [ 5409]: --> [10:NO CARRIER]
Dez 04 17:08:15.86: [ 5409]: <-- [9:AT+FRS=7\r]
Dez 04 17:08:15.97: [ 5409]: --> [2:OK]
Dez 04 17:08:15.97: [ 5409]: TRAINING succeeded
Dez 04 17:08:15.97: [ 5409]: <-- [9:AT+FTH=3\r]
Dez 04 17:08:16.79: [ 5409]: --> [7:CONNECT]
Dez 04 17:08:16.79: [ 5409]: <-- HDLC<3:FF C8 21>
Dez 04 17:08:17.13: [ 5409]: --> [2:OK]
Dez 04 17:08:17.13: [ 5409]: <-- [11:AT+FRM=146\r]
Dez 04 17:08:17.68: [ 5409]: --> [7:CONNECT]
Dez 04 17:08:17.68: [ 5409]: MODEM input buffering enabled
Dez 04 17:08:17.68: [ 5409]: RECV: begin page

Dez 04 17:08:17.68: [ 5409]: RECV/CQ: Bad 1D pixel count, row 0, got 0, expected 1728
Dez 04 17:08:17.68: [ 5409]: RECV/CQ: Bad 1D pixel count, row 1, got 0, expected 1728
Dez 04 17:08:17.68: [ 5409]: RECV/CQ: Bad 1D pixel count, row 2, got 0, expected 1728
Dez 04 17:08:17.68: [ 5409]: RECV/CQ: Bad 1D pixel count, row 3, got 0, expected 1728
Dez 04 17:08:17.68: [ 5409]: RECV/CQ: Adjusting for RTC found at row 0
Dez 04 17:08:17.68: [ 5409]: RECV: 0 total lines, 0 bad lines, 0 consecutive bad lines
Dez 04 17:08:17.68: [ 5409]: RECV: REJECT page quality, too few scanlines: 0
Dez 04 17:08:17.68: [ 5409]: RECV: end page

Dez 04 17:08:17.70: [ 5409]: --> [2:]
Dez 04 17:08:17.70: [ 5409]: --> [10:NO CARRIER]
Dez 04 17:08:17.70: [ 5409]: <-- [9:AT+FRH=3\r]
Dez 04 17:08:17.78: [ 5409]: --> [7:CONNECT]
Dez 04 17:08:18.88: [ 5409]: --> HDLC<5:FF C8 F2 AC A0>
Dez 04 17:08:18.88: [ 5409]: --> [2:OK]
Dez 04 17:08:18.88: [ 5409]: RECV recv MPS (more pages, same document)
Dez 04 17:08:18.88: [ 5409]: <-- [9:AT+FRS=7\r]
Dez 04 17:08:18.99: [ 5409]: --> [2:OK]
Dez 04 17:08:18.99: [ 5409]: <-- [9:AT+FTH=3\r]
Dez 04 17:08:19.82: [ 5409]: --> [7:CONNECT]
Dez 04 17:08:19.82: [ 5409]: <-- HDLC<3:FF C8 5F>
Dez 04 17:08:20.16: [ 5409]: --> [2:OK]
Dez 04 17:08:20.16: [ 5409]: RECV send DCN (disconnect)
Dez 04 17:08:20.16: [ 5409]: RECV FAX: PPM received with no image data. To continue risks receipt confirmation. {E155}
Dez 04 17:08:20.16: [ 5409]: RECV FAX (000000006): session with XX.XXXX.XXXXXX terminated abnormally: PPM received with no image data. To continue risks receipt confirmation. {E155}
Dez 04 17:08:20.16: [ 5409]: RECV FAX: bin/faxrcvd 'recvq/fax000000003.tif' 'ttyS2' '000000006' 'PPM received with no image data. To continue risks receipt confirmation. {E155}'
Dez 04 17:08:20.16: [ 5409]: RECV FAX (000000006): recvq/fax000000003.tif from XX.XXXX.XXXXXX, subaddress <unspecified>, 0 pages in 0:00:15
Dez 04 17:08:20.16: [ 5409]: RECV FAX: end
Dez 04 17:08:20.16: [ 5409]: <-- [5:ATH0\r]

Hardwareumgebung:
Faxserver mit "serial multi-I/O card" und U.S. Robotics Modems an jeder Leitung. Die sind dann mit der nicht ganz so neuen TK-Anlage an mehreren Anlagenanschlüssen verbunden.

Wir müssen hier jetzt auch nicht über den zukünftigen Umstieg auf IP-Telefonie reden, denn das kann bei uns (telekomseitig) noch nicht umgesetzt werden. Natürlich wird das irgendwann passieren,
ist aber für das aktuelle Problem irrelevant.

Ich wollte einfach nur fragen, ob es jemanden mit ähnlicher Konfiguration gibt, ob der dann auch ähnliche Probleme hat oder hatte und ob diese behebbar sind.

Ich bin dankbar für alle Anregungen! Denn als Alternative bleibt mir sonst wohl nur die alte libtiff-Version gesondert zu installieren und Hylafax so umzubiegen, dass es diese nutzt, damit ich für den Rest des
Systems auf die neue Version updaten kann.

Beitrag geändert von mat_weiss (05.12.2016 12:48:09)

Offline

#6 15.12.2016 09:42:21

mat_weiss
Mitglied

Re: HYLAFAX funktioniert nicht mehr nach LIBTIFF update

Fixed with:  libtiff 4.0.7-2

Topic can be closed...

Offline

#7 15.12.2016 10:42:04

Schard-nologin
Gast

Re: HYLAFAX funktioniert nicht mehr nach LIBTIFF update

mat_weiss schrieb:

Fixed with:  libtiff 4.0.7-2

Topic can be closed...

No, but topic can be marked as "solved".
However, german may be a preferred language here.

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums