#1 17.10.2016 13:58:24

The_H4nZ
Mitglied

[SOLVED] Man-Pages zeigt keine Parameter an

Hallo zusammen,

bei mir werden in den man-pages keine Parameter angezeigt, nur ihre Funktion (Siehe Screenshot). Weiß jemand woran das liegen könnte? Ich habe mal was aufgeschnappt, dass es mit den locales zu tun hat, aber ich habe keine Ahnung.

Ich bin noch ein neuling, also wenns geht halbwegs verständlich bitte big_smile


Vielen Dank!

Gruß
The_H4nZ


man-pages

Beitrag geändert von The_H4nZ (17.10.2016 22:14:56)

Offline

#2 17.10.2016 14:12:03

Schard-nologin
Gast

Re: [SOLVED] Man-Pages zeigt keine Parameter an

Was sagt

echo -e "\033[1mFetter Text\033[0m"

?

#3 17.10.2016 14:19:50

The_H4nZ
Mitglied

Re: [SOLVED] Man-Pages zeigt keine Parameter an

Es sagt einfach garnichts...

mmr3hz.png

Offline

#4 17.10.2016 14:33:29

Schard-nologin
Gast

Re: [SOLVED] Man-Pages zeigt keine Parameter an

Wie vermutet, zeigt deine Shell aus irgend einem Grund keinen fetten Text an.
Ich müsste selbst googlen woran das liegen könnte, da ich das Phänomen noch nicht hatte.
Vielleicht weis jemand anderes mehr...
Kannst du denn die (vermeintlich) leere Zeile kopieren und in die Konsole einfügen?
Wenn der Text in Form von Zeichen da ist, was ich vermute, und nur nicht dargestellt wird, denke ich dass es an irgendwelchen Font- oder Shell-Einstellungen liegt.

#5 17.10.2016 14:35:03

Schard-nologin
Gast

Re: [SOLVED] Man-Pages zeigt keine Parameter an

PS: gib auch nochmal bitte

echo $PS1

an.

#6 17.10.2016 14:51:58

The_H4nZ
Mitglied

Re: [SOLVED] Man-Pages zeigt keine Parameter an

Oh schonmal vielen Dank! Das ist zumindest mal ein Hinweis^^

So siehts aus:

xpos90.png

Beitrag geändert von The_H4nZ (17.10.2016 14:52:09)

Offline

#7 17.10.2016 15:45:09

skull-y
Mitglied

Re: [SOLVED] Man-Pages zeigt keine Parameter an

Welches Terminal verwendest du? Unter sakura zum Beispiel, kann man Fettgeschriebenes verbieten.

Offline

#8 17.10.2016 15:48:05

The_H4nZ
Mitglied

Re: [SOLVED] Man-Pages zeigt keine Parameter an

Ich verwende Roxterm, dafür gibt es eine configdatei, da werd ich mich wohl mal rein arbeiten müssen wenn hier niemand eine Spontane Lösung hat.

Bin aber auch offen für andere Terminals... Bin da noch nicht so festgefahren.

Jedenfalls Danke so weit!

Offline

#9 17.10.2016 16:16:03

niemand
Mitglied

Re: [SOLVED] Man-Pages zeigt keine Parameter an

Der Inhalt von TERM wäre von Interesse (›echo $TERM‹) – und bitte als Text, nicht als Bild. Gibt auch Leute, die für Datenvolumen bezahlen *grml*.

Offline

#10 17.10.2016 16:21:52

The_H4nZ
Mitglied

Re: [SOLVED] Man-Pages zeigt keine Parameter an

Sorry^^

Wichtig wäre vielleicht noch, dass ich zsh und OhMyZsh benutze.

➜  ~ echo $TERM 
xterm

Offline

#11 17.10.2016 20:09:16

niemand
Mitglied

Re: [SOLVED] Man-Pages zeigt keine Parameter an

Andere Idee: versuch‘ nochmal das mit echo und dem fetten Text, und copypaste die „Nichtausgabe“ mal. Möglicherweise wird der Text sehr wohl dargestellt, aber aufgrund ungünstiger Sternenkonstellationen interpretiert dein Terminal die Anweisung für fett als „mach’s mir schwarz“?

Edit: hatte das Schard ja auch schon angefragt.

Beitrag geändert von niemand (17.10.2016 20:11:55)

Offline

#12 17.10.2016 22:14:29

The_H4nZ
Mitglied

Re: [SOLVED] Man-Pages zeigt keine Parameter an

SOLVED

Ja copypasten kann ich den fetten Text (Siehe Bild bei #6) also wird er entweder schwarz oder ist fett und wird nicht angezeigt.
Ich habe also mal in den Farbeinstellungen von Roxterm geschaut und dort stand tatsächlich bei set bold color schwarz. Ich habe also ein weiß eingestellt und sehe nun diesen Fetten Text.

Jetzt sehe ich tatsächlich alles in den man-pages (so weit ich das beurteilen kann), also alles top! Was ein dummer fehler big_smile


Vielen Dank an alle smile

Offline

#13 18.10.2016 18:31:11

efreak4u
Mitglied

Re: [SOLVED] Man-Pages zeigt keine Parameter an

Manchmal sind es die kleinen Fehler, hinter denen man am Laengsten her sucht... Ist wohl so gut wie jedem schonmal so gegangen, unabhaengig vom Betriebssystem. wink

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums