Du bist nicht angemeldet.

#1 02.06.2015 19:05:04

stefanhusmann
Moderator

AUR 4.0: Erneutes Hochladen der Pakete notwendig.

Wer Pakete im AUR betreut, hat diese Tage eine E-Mail bekommen, die die Migration des derzeitigen AUR auf eine neue, git-basierte Infrastruktur ankündigt. Die Migration geheht am 8. Juni los. Pakete, die man weiterhin selber betreuen will, müssen bis zum 8. Juli auf aur4.archlinux.org hochgeladen werden. Man hat dafür also einen Monat Zeit.

Ab dem 8. Juli tritt dann ein zweite Phase in Kraft, die wiederum einen Monat, also bis zum 8. August, dauert.   
Pakete, die man bis dahin nicht hochgeladen hat, können von jedermann anders ohne weitere Rückfrage übernommen und hochgeladen werden - das heißt natürlich auch, dass dieser Jemand sie nach seinem Gusto ändern kann.

Ab dann ist das AUR4 das "wahre" AUR. Es wird erwartet, dass dies AUR um einige alte, nicht betreute Pakete/Paketleichen ärmer sein wird. Diese werden jedoch noch nicht entgültig gelöscht, sondern auf anderem Wege verfügbar bleiben.

Ab dem 8.Juni sollte auch nur noch auf die neue Plattform hochgeladen werden. Damit dies möglich ist, muss man noch ein paar Vorkehrungen treffen, die im Wiki beschrieben sind. Alle Pakete, die zwischen dem 8. Juni und dem 8. August auf die alte Plattform hochgeladen werden, gehen verloren.

Fehler zur neuen Version können wie gewohnt im Aurweb-Bugtracker gemeldet werden.

Offline

#2 08.06.2015 23:57:02

stefanhusmann
Moderator

Re: AUR 4.0: Erneutes Hochladen der Pakete notwendig.

Ergänzung: Das Skrip von bbidulock leistet hier für mich sehr gute Dienste.

Offline

#3 09.07.2015 07:04:15

stefanhusmann
Moderator

Re: AUR 4.0: Erneutes Hochladen der Pakete notwendig.

Rememberli: Die noch nicht ins AUR4 verbrachten Pakete können jetzt übernommen werden. Bitte überprüft, was Ihr so benutzt, und ob es schon im AUR 4 ist. Wenn nicht, würde das PKGBUILD in einem Monat verloren gehen.

Kurzer Wiki-Artikel: https://wiki.archlinux.de/title/Aur4

Offline

#4 08.08.2015 12:13:42

stefanhusmann
Moderator

Re: AUR 4.0: Erneutes Hochladen der Pakete notwendig.

Die Transition findet in diesen Minuten statt.

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums