Du bist nicht angemeldet.

#1 07.03.2015 23:12:19

LinusCDE98
Mitglied

[Solved] Wine sound geht nicht

Hallo,
sry, wenn da hier an der falschen Stelle ist, aber ich weiß nicht, wo ich sonnst danach fragen könnte.

Ich habe mir vor kurzem ein Arch-System erstellt und nach der Deutschen Beginner Guide aufgebaut.
Ich habe mir KDE installiert und kdm als Loginmanager gesetzt.

Ich bin damit voll zufrieden obwohl ich frühere KDE unpraktisch fand, was sich aber durch einige Einstellungen (wie Doppelklick) beheben ließ.

Mich stört momentan nur eine Sache sehr.
Wenn ich League of Legends mittels Wine/PlayOnLinux spielen möchte habe ich entweder keinen Sound oder nur auf meinen Laptoplautsprechern (ich nutze normal ein Headset).
Mir ist schon bekannt geworden, dass Wine nur einen Treiber für alsa hat und, dass er nur die Lautsprecher nutzen kann, weil mein Headset z.B. durch einen Skypeanruf oder Teamspeak blockiert wird.
Nur war mein letztes Linux-System mit dem ich erst richtig Linux kennen lernte LinuxMint 17 Mate.
Dort lief der Sound ohne Probleme und war für mich nie ein Thema.
Ich habe mich auch schon mit der "~/.asoundrc" Datei und den Modulen auseinandergesetzt. Leider habe ich es nicht hinbekommen, dass ich eine Output-Option in Wine habe, die auf PulseAudio verweißt. (Ich gehe seit einer Weile davon aus, dass Phonon/Gstreamer auch nur auf Pulseaudio zugreift, was ich gut finde)

Kann mir da bitte jemand helfen?

Screenshot, wo ich versucht habe eine Option für Pulseaudio mittels .asoundrc oder Modulen reinzubekommen:
qxmm7rj7ri8i.png

EDIT: Der Sound funktioniert Plötzlich! Allerdings stottert er stark, ist etwas schneller und lässt auch Sound von anderen Anwendungen genauso Stottern. Bei Phonon sehe ich dabei einen Wiedergabestream, der die ganze Zeit kommt und  geht min. 5 mal pro Sekunde rein und raus. Ich kann das schon verstehen dass dann PulseAudio verwirrt ist. Der Wiedergabestream heißt "[Alsa-Plugin] Wine-Preloader" oder so ähnlich. Ist villeicht eine Konfiguration in Wine falsch, wesshalb der Sound immer "abstürtzt" und reconnected?

Beitrag geändert von LinusCDE98 (19.03.2015 15:05:09)

Offline

#2 19.03.2015 15:02:55

LinusCDE98
Mitglied

Re: [Solved] Wine sound geht nicht

Habs gelöst. Der Sound geht jetzt!
Ich musste nur das zur "/etc/pulse/daemon.conf" hinzufügen:

 default-fragments = 5
default-fragment-size-msec = 2 

Das hatte mit einer Fehlermeldung von libpcm(Wine-Alsa) zu tun nach der der Buffer wohl zu groß war:

ALSA lib pcm.c:7905:(snd_pcm_recover) underrun occurred

Ist jetzt auf jeden Fall erledigt und ich kann Arch jetzt mehl als LinuxMint genießen. smile smile smile

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums