Du bist nicht angemeldet.

#1 22.01.2014 13:13:20

Arche
Mitglied

Buchstaben mit Umlauten im Terminal und anderen Programmen

Hey,

ich habe Probleme mit Umlauten (ö, ä, etc.). Im Terminal kann ich sie zwar schreiben, wenn jedoch, z. B. beim updaten Nachrichten im Terminal erscheinen, werden diese Zeichen nur mit "??" dargestellt. Weiterhin kann ich beispielsweise mit Libre Office keine Dateien öffnen die Sonderzeichen enthalten. Mit Nemo kann ich jedoch Ordner öffnen, die Sonderzeichen enthalten. Wiederum mit Krusader klappt das auch nicht. Wenn ich einen Ordner oder eine Datei mit Sonderzeichen im Namen öffnen will, kommt die Meldung, dass die Datei nicht gefunden wurde.

Das bekomme ich, wenn ich "locale" eingebe:

LANG=DE.UTF-8
LC_CTYPE="de_DE.UTF-8"
LC_NUMERIC="de_DE.UTF-8"
LC_TIME="de_DE.UTF-8"
LC_COLLATE="de_DE.UTF-8"
LC_MONETARY="de_DE.UTF-8"
LC_MESSAGES="de_DE.UTF-8"
LC_PAPER="de_DE.UTF-8"
LC_NAME="de_DE.UTF-8"
LC_ADDRESS="de_DE.UTF-8"
LC_TELEPHONE="de_DE.UTF-8"
LC_MEASUREMENT="de_DE.UTF-8"
LC_IDENTIFICATION="de_DE.UTF-8"
LC_ALL=de_DE.UTF-8

Das sieht doch eigentlich richtig aus?
Weiß jemand Rat, wo hier der Fehler liegt?

MfG

Beitrag geändert von Arche (22.01.2014 13:15:10)

Offline

#2 22.01.2014 13:31:22

Greg
Mitglied

Re: Buchstaben mit Umlauten im Terminal und anderen Programmen

Sieh mal hier:
https://wiki.archlinux.de/title/Anleitu … #.2Fetc.2F....
es reicht wenn du  nur in die
/etc/locale.conf

Die Spracheinstellung (Locale) festlegen:

echo LANG=de_DE.UTF-8 > /etc/locale.conf
echo LC_COLLATE=C >> /etc/locale.conf

machst und die locale.gen wie folgt erzeugst:
/etc/locale.gen

Konfiguration von /etc/locale.gen

nano /etc/locale.gen

Suchen und das # am anfang folgender Zeilen entfernen:

#de_DE.UTF-8 UTF-8
#de_DE ISO-8859-1
#de_DE@euro ISO-8859-15

Hinweis: Suchen im Editor nano: <STRG>+<W>SUCHBEGRIFF<ENTER> Weitersuchen mit gleichem Suchbegriff erneut <STRG>+<W><ENTER>

Anschließend Speichern.

Locale generierien:

locale-gen

Generating locales...
  de_DE.UTF-8... done
  de_DE.ISO-8859-1... done
  de_DE.ISO-8859-15@euro... done
Generation complete.

Alles was mit grafischer Oberfläche zu run hat, wird mit der
Deutschen Tastaturbelegung eingestellt.

Eine Datei erzeugen /etc/X11/xorg.conf.d/20-keyboard.conf und folgendes hinzufügen:
Section "InputClass"
      Identifier "keyboard"
      MatchIsKeyboard "yes"
      Option "XkbLayout" "de"
      Option "XkbVariant" "nodeadkeys"
EndSection

Offline

#3 22.01.2014 15:07:30

Arche
Mitglied

Re: Buchstaben mit Umlauten im Terminal und anderen Programmen

Vielen Dank. Eigentlich bin ich auch immer so vorgegangen. Die Eintragungen waren auch noch überall vorhanden. Muss wohl irgendwo immer ein Fehler drin gewesen sein. Eventuell ein fehlendes de_....
Jetzt klappt jedenfalls alles. Danke nochmal!

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums