Du bist nicht angemeldet.

#26 05.04.2013 13:28:14

nik
Mitglied

Re: Pacman 4.1 Vorankündigung am 1.April

https://aur.archlinux.org/packages/package-query/ hier wurden inzwischen die Abhängigkeiten angepasst, so dass man nun auch package-query mit der aktuellen Version von pacman installieren kann.

Offline

#27 05.04.2013 13:42:22

stefanhusmann
Moderator

Re: Pacman 4.1 Vorankündigung am 1.April

qui schrieb:

> Wurde inzwischen aktualisiert.
Wo siehst Du das? Das müßte dann ja dementsprechend pacman 4.1.0-3 sein, davon ist aber afaict bis dato nix zu sehen…

Du erwartest, dass pacman angepasst wird, damit ein nicht unterstütztes Stück Software wie yaourt funktioniert? Nie! Yaourt und andere pacman-Wrapper existieren für die pacman-Entwickler nicht.

Offline

#28 05.04.2013 15:07:07

qui
Mitglied

Re: Pacman 4.1 Vorankündigung am 1.April

Alles klar, danke für die Aufklärung.

Offline

#29 06.04.2013 05:41:20

Dirk
Moderator

Re: Pacman 4.1 Vorankündigung am 1.April

Die Farbennutzung könnte gerade bei der (De-)Installation noch etwas ausführlicher ausfallen, als blaue Punkte vor fetten Überschriften/Abfragen smile Ansonsten schon sehr schick!

Offline

#30 06.04.2013 13:14:48

Army
Mitglied

Re: Pacman 4.1 Vorankündigung am 1.April

Welche pkgver-Funktion aus https://wiki.archlinux.org/index.php/VC … elines#Git soll man eigentlich bevorzugt benutzen? Die dritte ist über Nacht dazugekommen, die wäre eigentlich recht praktisch, weil sie halt das alte Format benutzt.

Offline

#31 06.04.2013 14:21:36

Dirk
Moderator

Re: Pacman 4.1 Vorankündigung am 1.April

Army schrieb:

Welche pkgver-Funktion aus https://wiki.archlinux.org/index.php/VC … elines#Git soll man eigentlich bevorzugt benutzen? Die dritte ist über Nacht dazugekommen, die wäre eigentlich recht praktisch, weil sie halt das alte Format benutzt.

„Whatever rustles your Jimmies“, wie der geneigte Internetnutzer sagt smile Ich habe in meinen Programmen die Versionsnummer in eine eigene Variable ausgelagert, und Parse sie hiermit zur Paket-Versionsnummer:

pkgver() {
	cd "$srcdir/$_gitname"
	echo $(sed -n "s/^progversion = '\(.*\)'/\1/p" PROGRAMMDATEI)
}

Wobei PROGRAMMDATEI eben jene Datei ist, in der die Versionsnummer in der Form progversion = 'X' steht, wobei X eben die Versionsnummer ist. Das hat für mich den Vorteil, dass die Versionsnummer in meinem Programm, und die Versionsnummer im AUR übereinstimmen, aber trotzdem das Programm auch ohne AUR mit „richtiger“ Versionsnummer geladen werden kann.

Der Weg andersrum (die Git-„Versionsnummer“ ins Programm zu bekommen) stelle ich mir wesentlich fummeliger vor – und vor allem funktioniert das dann NUR noch mit dem Arch-Paket und nicht mehr unabhängig, dass das Programm eine vernünftige Versionsnummer hat.

Offline

#32 06.04.2013 15:14:49

Army
Mitglied

Re: Pacman 4.1 Vorankündigung am 1.April

Das führt doch eher zu Verwirrung, wenn da jeder macht was er will, oder? Jedenfalls funktioniert jetzt ein Update mit AUR-Helfern nicht mehr so gut. Ein Grund mehr, sich davon wieder zu lösen wink

Offline

#33 06.04.2013 15:23:59

Dirk
Moderator

Re: Pacman 4.1 Vorankündigung am 1.April

Army schrieb:

Das führt doch eher zu Verwirrung, wenn da jeder macht was er will, oder? Jedenfalls funktioniert jetzt ein Update mit AUR-Helfern nicht mehr so gut. Ein Grund mehr, sich davon wieder zu lösen wink

Das funktioniert mit allem, das sich an die Regeln hält smile

Offline

#34 06.04.2013 15:59:07

Army
Mitglied

Re: Pacman 4.1 Vorankündigung am 1.April

Und was denkt ihr über die Verwendung von epoch in AUR-PKGBUILDs? In der Mailingliste wird da ja schon rumdiskutiert, da geht die Meinung eher dahin, dass man fürs AUR kein epoch benutzen sollte.

Offline

#35 06.04.2013 16:09:29

Dirk
Moderator

Re: Pacman 4.1 Vorankündigung am 1.April

Warum sollte man das wollen?

Offline

#36 06.04.2013 17:20:44

danbruegge
Mitglied

Re: Pacman 4.1 Vorankündigung am 1.April

Mein "packer" läuft noch tadellos. smile

Bin sehr zufrieden mit dem neuen Pacman und den Farben, sparsam und passend.

Offline

#37 06.04.2013 18:20:14

Ovion
Mitglied

Re: Pacman 4.1 Vorankündigung am 1.April

Die Farbgebung gefällt mir ebenfalls gut, war das einzige, dass ich damals, als ich mal yaourt ausprobiert und wieder verworfen habe, bei pacman vermisste.

Offline

#38 07.04.2013 10:24:33

totschka
Mitglied

Re: Pacman 4.1 Vorankündigung am 1.April

"Mein" pacman sagt schon gleich zu Beginn, dass er sich nicht aktualisieren lassen will. Das ist natürlich suboptimal, weil er alle anderen Aktionen davon abhängig macht. Ich schätze, das wars dann wohl...

Offline

#39 07.04.2013 11:32:21

Army
Mitglied

Re: Pacman 4.1 Vorankündigung am 1.April

totschka schrieb:

"Mein" pacman sagt schon gleich zu Beginn, dass er sich nicht aktualisieren lassen will. Das ist natürlich suboptimal, weil er alle anderen Aktionen davon abhängig macht. Ich schätze, das wars dann wohl...

Neuen Thread starten und bitte die genauen Ausgaben zeigen, die Pacman erzeugt. Dir kann garantiert geholfen werden!

Offline

#40 07.04.2013 13:01:03

stefanhusmann
Moderator

Re: Pacman 4.1 Vorankündigung am 1.April

Beherzige bitte "In der pacman.conf wird die Direktive 'SyncFirst' weder erkannt noch unterstützt." aus dem Eingangspost.

Offline

#41 07.04.2013 13:22:28

stefanhusmann
Moderator

Re: Pacman 4.1 Vorankündigung am 1.April

Army schrieb:

Welche pkgver-Funktion aus https://wiki.archlinux.org/index.php/VC … elines#Git soll man eigentlich bevorzugt benutzen? Die dritte ist über Nacht dazugekommen, die wäre eigentlich recht praktisch, weil sie halt das alte Format benutzt.

Da das sehr stark davon abhängt, was das jeweilige Upstream-Repo als Antwort zurückliefert, ist es schwierig bis unmöglich, hier eine generelle Empfehlung abzugeben.

Manche geben nur ein Hash zurück, manche eine vernünftige Versionsnummer.

Offline

#42 07.04.2013 14:43:45

Army
Mitglied

Re: Pacman 4.1 Vorankündigung am 1.April

Danke Stefan. Ich werde das dann eben für jedes Paket individuell entscheiden.

Offline

#43 07.04.2013 18:15:42

Dirk
Moderator

Re: Pacman 4.1 Vorankündigung am 1.April

stefanhusmann schrieb:

Beherzige bitte "In der pacman.conf wird die Direktive 'SyncFirst' weder erkannt noch unterstützt." aus dem Eingangspost.

Was wird stattdessen verwendet? Erkennt Pacman nun das automatisch?

Offline

#44 07.04.2013 21:17:38

Ovion
Mitglied

Re: Pacman 4.1 Vorankündigung am 1.April

Wird, wenn ich den Post auf der Mailingliste richtig verstanden habe, schlicht nicht mehr gebraucht, weil sich auch pacman nun regulär mitupdaten lässt, ohne dass Probleme zu befürchten wären.

Offline

#45 07.04.2013 22:34:11

stefanhusmann
Moderator

Re: Pacman 4.1 Vorankündigung am 1.April

Offline

#46 09.04.2013 08:52:36

wbs
Mitglied

Re: Pacman 4.1 Vorankündigung am 1.April

Army schrieb:

Ein Grund mehr, sich davon wieder zu lösen wink

Also ich find AUR-Helfer praktisch. Ich hab' nicht die Motivation, Sachen aus dem AUR ohne zu installieren, da nehm' ich das Risiko gern in kauf...

Offline

#47 09.04.2013 09:16:49

gridcol
Mitglied

Re: Pacman 4.1 Vorankündigung am 1.April

Ich würde gerne auf einen Helfer verzichten, aber ich habe noch keinen effizienten Weg gefunden, meine Pakete dann im Überblick zu behalten/zu managen. Vielleicht hat da ja jemand tolle Methoden entwickelt, ich habe für mich bisher keinen goldenen Weg gefunden.

Offline

#48 09.04.2013 10:05:39

Army
Mitglied

Re: Pacman 4.1 Vorankündigung am 1.April

Bin doch nicht weg von AUR-Helfern, aber hab mich mal umgesehen, was es so gibt. Eventuell schreib ich mal selbst einen big_smile

Offline

#49 09.04.2013 10:14:32

skull-y
Mitglied

Re: Pacman 4.1 Vorankündigung am 1.April

Kann das sein, das im Moment keiner der Helfer in der Lage ist im AUR nach aktualisierten Paketen zu schauen?

Offline

#50 09.04.2013 10:20:49

Pjotr
Mitglied

Re: Pacman 4.1 Vorankündigung am 1.April

cower-git kanns!

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums