Du bist nicht angemeldet.

#1 14.01.2013 10:38:10

Aeon Tux
Mitglied

Frage zu "Xorg autoconfigured Driver"

Hallo.

Ich nutze xf86-video-intel als Grafiktreiber. In der mkinitcpio.conf ist demnach auch i915 als Modul eingetragen.

Nun hat das Xorg.0.log aber mehrere Fehler, weil offenbar zusätzlich versucht wird, vesa, modesetting  und fbdev zu laden.

Ein Ausschnitt meiner Xorg.0.log sieht so aus:

[    17.330] (==) Matched intel as autoconfigured driver 0
[    17.330] (==) Matched intel as autoconfigured driver 1
[    17.330] (==) Matched vesa as autoconfigured driver 2
[    17.330] (==) Matched modesetting as autoconfigured driver 3
[    17.330] (==) Matched fbdev as autoconfigured driver 4
[    17.330] (==) Assigned the driver to the xf86ConfigLayout
[    17.330] (II) LoadModule: "intel"
[    17.390] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[    17.542] (II) Module intel: vendor="X.Org Foundation"
[    17.542] 	compiled for 1.13.1, module version = 2.20.17
[    17.542] 	Module class: X.Org Video Driver
[    17.542] 	ABI class: X.Org Video Driver, version 13.1
[    17.542] (II) LoadModule: "vesa"
[    17.579] (WW) Warning, couldn't open module vesa
[    17.579] (II) UnloadModule: "vesa"
[    17.579] (II) Unloading vesa
[    17.579] (EE) Failed to load module "vesa" (module does not exist, 0)
[    17.579] (II) LoadModule: "modesetting"
[    17.579] (WW) Warning, couldn't open module modesetting
[  [    17.330] (==) Matched intel as autoconfigured driver 0
[    17.330] (==) Matched intel as autoconfigured driver 1
[    17.330] (==) Matched vesa as autoconfigured driver 2
[    17.330] (==) Matched modesetting as autoconfigured driver 3
[    17.330] (==) Matched fbdev as autoconfigured driver 4
[    17.330] (==) Assigned the driver to the xf86ConfigLayout
[    17.330] (II) LoadModule: "intel"
[    17.390] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[    17.542] (II) Module intel: vendor="X.Org Foundation"
[    17.542] 	compiled for 1.13.1, module version = 2.20.17
[    17.542] 	Module class: X.Org Video Driver
[    17.542] 	ABI class: X.Org Video Driver, version 13.1
[    17.542] (II) LoadModule: "vesa"
[    17.579] (WW) Warning, couldn't open module vesa
[    17.579] (II) UnloadModule: "vesa"
[    17.579] (II) Unloading vesa
[    17.579] (EE) Failed to load module "vesa" (module does not exist, 0)
[    17.579] (II) LoadModule: "modesetting"
[    17.579] (WW) Warning, couldn't open module modesetting
[    17.579] (II) UnloadModule: "modesetting"
[    17.579] (II) Unloading modesetting
[    17.579] (EE) Failed to load module "modesetting" (module does not exist, 0)
[    17.579] (II) LoadModule: "fbdev"
[    17.579] (WW) Warning, couldn't open module fbdev
[    17.579] (II) UnloadModule: "fbdev"
[    17.579] (II) Unloading fbdev
[    17.579] (EE) Failed to load module "fbdev" (module does not exist, 0)  17.579] (II) UnloadModule: "modesetting"
[    17.579] (II) Unloading modesetting
[    17.579] (EE) Failed to load module "modesetting" (module does not exist, 0)
[    17.579] (II) LoadModule: "fbdev"
[    17.579] (WW) Warning, couldn't open module fbdev
[    17.579] (II) UnloadModule: "fbdev"
[    17.579] (II) Unloading fbdev
[    17.579] (EE) Failed to load module "fbdev" (module does not exist, 0)

Kann ich diese "autoconfigured driver irgendwie" deaktivieren? Eigentlich sollte es doch reichen, wenn der Intel-Treiber geladen wird - oder?
Oder sollte ich einfach die fehlenden Pakete xf86-video-vesa, xf86-video-fbdev und xf86-video-modesetting installieren?
Und wieso steht intel zwei Mal da (driver 0 und driver 1)?

Danke!

Offline

#2 14.01.2013 15:23:33

hydro
Mitglied

Re: Frage zu "Xorg autoconfigured Driver"

Gib doch einfach den zu verwendenden Treiber vor.

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
EndSection

Speichern als z.B. /etc/X11/xorg.conf.d/20-intel.conf .

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums