Du bist nicht angemeldet.

#1 03.08.2012 13:22:08

hcjl
Mitglied

[GELÖST] [WORKAROUND] x2go: Keine deutsche Session

Hallo zusammen,

ich habe mir auf meinem Raspberry PI x2goserver aus dem AUR installiert. Lief problemlos, ich musste nur die arch Flags in den Pgkbuilds auf arch=("any") ändern.

Ich kann Xfce4 problemlos starten. Im x2goclient habe ich als Sitzungsart "Andere Desktopumgebung" und als Befehl "startxfce4" angegeben.

Leider ist die Xfce4 Session auf Englisch und nicht auf Deutsch. Ich habe bereits wie im englischen Wiki beschrieben in der sshd_config folgenden Eintrag ergänzt und sshd neugestartet.

# Allow client to pass locale environment variables
AcceptEnv LANG LC_*

Hat nur nix gebracht;-)

Hat jemand eine Idee, wie ich die Sprache umstellen kann?

Danke & Gruß
hcjl

Beitrag geändert von hcjl (11.03.2013 17:15:31)

Offline

#2 03.08.2012 13:35:48

Creshal
Mitglied

Re: [GELÖST] [WORKAROUND] x2go: Keine deutsche Session

Hat Xfce keine eigenen Spracheinstellungen?

Offline

#3 03.08.2012 14:01:07

hcjl
Mitglied

Re: [GELÖST] [WORKAROUND] x2go: Keine deutsche Session

Nicht, dass ich wüsste. Wenn ich Xfce4 lokal starte, ist alles auf Deutsch, nur halt nicht über x2go.

Offline

#4 07.11.2012 17:01:46

hcjl
Mitglied

Re: [GELÖST] [WORKAROUND] x2go: Keine deutsche Session

@GerBra

hast du vielleicht noch eine idee? ich habe gesehen, dass sowohl der deutsche als auch der englische wiki beitrag von dir stammen, was dich in meinen augen als x2go-guru ausweist;-)

hab das problem im übrigen mit unterschiedlichen des / wms (openbox, fluxbox, gnome) und auch auf einem x86_64 rechner. es ist also nicht raspberry pi oder arm spezifisch.

danke & beste grüsse
hcjl

Beitrag geändert von hcjl (07.11.2012 17:15:53)

Offline

#5 09.11.2012 14:43:58

hcjl
Mitglied

Re: [GELÖST] [WORKAROUND] x2go: Keine deutsche Session

noch ein kleiner nachtrag, keine ahnung, ob die info irgendwie hilfreich ist:

unter gnome > system settings > region & language wird die display language "Unspecified [ANSI_X3.4-1968]" angezeigt. eine änderung auf z.b. german hat keinerlei auswirkungen. nach log out / login und reboot steht dort wieder unspecified.

Offline

#6 09.11.2012 15:06:19

hcjl
Mitglied

Re: [GELÖST] [WORKAROUND] x2go: Keine deutsche Session

hab noch etwas herausgefunden:

auf dem server in /var/log/auth.log erscheint folgender eintrag:

Nov  9 13:44:56 SERVER polkitd[574]: Registered Authentication Agent for unix-session:22 (system bus name :1.190 [/usr/lib/polkit-gnome/polkit-gnome-authentication-agent-1], object path /org/gnome/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8)

scheinbar wird beim login per x2goclient von policykit die locale en_US.UTF-8 gesetzt. ich habe allerdings nicht den hauch einer ahnung, wie ich dieses verhalten beeinflussen kann.

Beitrag geändert von hcjl (09.11.2012 15:07:04)

Offline

#7 11.03.2013 17:14:57

hcjl
Mitglied

Re: [GELÖST] [WORKAROUND] x2go: Keine deutsche Session

nach endlosem erfolglosen googlen und rumprobieren bin ich auf einen recht einfachen workaround gestossen:

auf dem server ein startskript für den / die gewünschte WM / DE anlegen und ausführbar machen, in diesem beispiel gnome.

/opt/x2go/x2goserver_gnome.sh

mit folgendem inhalt

#!/bin/bash
export LANG=de_DE.UTF-8
exec gnome-session

im client in der entsprechenden session bei sitzung "andere sitzungsart" auswählen und den absoluten pfad und dateinamen des skrips auf dem server angeben.
LÄUFT!

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums