Du bist nicht angemeldet.

#1 25.06.2012 23:19:42

Martin_Berlin
Gast

Fehler beim Booten / Absturz bei suspend

Seit einiger Zeit funktioniert die Suspendfunktion meines Thinkpads nicht mehr einwandfrei. Wenn ich den laptop zuklappe, begibt sich der Rechner nicht mehr ordnungsgemäß in den suspend-modus. Er scheint sich vielmerh während des Prozesses aufzuhängen. Wenn ich den Bildschirm dann wieder öffne, funktioniert X nicht mehr, ich kann keine Konsole aufrufen außer die erste wo folgende Fehlermeldung erscheint

tpm_tis 00:0b: A TPM error (6) occurred attempting to read a pcr value
watchdog: INTCAMT: cannot register miscdev on minor=130 (err=-16)
watchdog: error registering /dev/watchdog (err=-16)
mei 0000:00:16.0: unable to register watchdog device.

Wenn ich den Laptop dann per Hardrst neustarte, wird diese Fehlermeldung beim Booten angezeigt, direkt nachdem udev geladen wurde.

Hat jemand Idee wie ich dieses problem beheben kann?

#2 25.06.2012 23:45:12

GerBra
Mitglied

Re: Fehler beim Booten / Absturz bei suspend

1. Treffer bei Google Suche nach "watchdog: INTCAMT: cannot register miscdev on minor=130 (err=-16)"
https://bbs.archlinux.org/viewtopic.php?id=133083

Schau mal ob der Post #23 hilft.
//Edit den ich gefunden habe in dem ich für dich den halben Thread gelesen habe ;-) Solche Fehlermeldungen einfach mal in Suchmaschinen eingeben, evtl. mit dem Zusatz archlinux und Anzeige < 1 Jahr/Monat.

Beitrag geändert von GerBra (25.06.2012 23:47:47)

Offline

#3 26.06.2012 20:02:08

Martin_Berlin
Gast

Re: Fehler beim Booten / Absturz bei suspend

Vielen Dank für die Hilfe!

ein Großteil der Fehlermeldung ist nun weggefallen. Übriggeblieben ist folgender Fehler:

tpm_tis 00:0b: A TPM error (6) occurred attempting to read a pcr value

...ich durchsuche mal das Web und wenn ich eine Lösung gefunden habe, poste ich sie hier. Falls jemand schon einen Tipp hat, wäre es schön, wenn er ihn posten könnte!

#4 27.06.2012 18:16:29

Martin_Berlin
Gast

Re: Fehler beim Booten / Absturz bei suspend

Die Fehlermeldung, die von mir am Anfang gepostet wurde, wird zwar nicht mehr angezeigt, aber leider tritt immer noch der Fehler auf, dass der Laptop nicht in den Suspendmode geht, wenn ich die Klappe schließe. Er bleibt weiterhin im Prozess hängen und stürzt ab.

Hat vielleicht jemand noch eine Idee woran das liegen könnte?

#5 28.06.2012 10:33:07

fuwafuwa
Mitglied

Re: Fehler beim Booten / Absturz bei suspend

Benutzt du pm-utils? Wenn ja, dann wirf doch auch mal einen Blick in die /var/log/pm-suspend.log

Offline

#6 28.06.2012 17:49:28

Martin_Berlin
Gast

Re: Fehler beim Booten / Absturz bei suspend

Hallo fuwafuwa,

ich benutze pm-utils. Meine pm-suspend.log sieht wie folgt aus:

disabled, not active

/usr/lib/pm-utils/sleep.d/01laptop-mode resume suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/01grub resume suspend:

/usr/lib/pm-utils/sleep.d/01grub resume suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/00powersave resume suspend:

/usr/lib/pm-utils/sleep.d/00powersave resume suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/00logging resume suspend:

/usr/lib/pm-utils/sleep.d/00logging resume suspend: success.
Thu Jun 28 17:42:45 CEST 2012: Finished.

Die Informationen sehen eigentlich ganz gute aus, allerdings beinhaltet die pm-powersave.log einige Fehler. Die Datei ist aber zu groß um sie hier zu posten. Ich kann natürlich Auszüge posten, nur muss ich vorher wissen, welche Art von Fehler ungefähr gesucht wird....

Vielen Dank schonmal im Voraus

Martin

#7 29.06.2012 00:14:48

fuwafuwa
Mitglied

Re: Fehler beim Booten / Absturz bei suspend

Längere Auszüge kann man auf Paste-Diensten, wie z.B. http://pastebin.com/ hochladen und dann hier verlinken.
In meiner pm-powersave.log sind immer die Hooks die Sachen, die ein "false" ausgeben, also Sachen die nicht geladen werden, weil ich es nicht explizit angegeben habe, oder es das nicht soll am Netz, vermute ich mal.
Jetzt wären noch der acpid.log und andere die mit Fehlern zu tun haben, Anhaltspunkte. Sonst hab ich leider auch keine Idee.

Offline

#8 30.06.2012 10:42:57

Martin_Berlin
Gast

Re: Fehler beim Booten / Absturz bei suspend

Also gestern ist mir wieder der Rechner beim Zuklappen abgeschmiert.

Hier mal die pm-suspend.log: http://pastebin.com/XBv47uPu
...und die acpid.log: http://pastebin.com/nGX48FTa

Vielleicht weiss ja jemand einen Rat?

#9 01.07.2012 12:31:08

Martin_Berlin
Gast

Re: Fehler beim Booten / Absturz bei suspend

Ich habe folgenden Eintrag in /etc/modprobe.d/blacklist.conf vorgenommen:

blacklist tpm_tis
blacklist mei

Beim Booten werden nun keine Fehler mehr angezeigt, allerdings hängt sich der rechner dennoch regelmäßig auf. Interessant dabei ist die Tatsache, dass ich den Laptop ca. 2-3 mal zuklappen kann, ohne das er hängen bleibt. Beim vierten mal Zuklappen bleibt er dann aber hängen.

Alles sehr mysteriös. Der Fehler besteht also immernoch, obwohl keine Fehlermeldung mehr beim Booten angezeigt wird.

#10 01.07.2012 12:42:07

GerBra
Mitglied

Re: Fehler beim Booten / Absturz bei suspend

Ist aus der Ferne so schwer zu diagnostizieren…
a) Welcher Laptop/Modell ist es denn?
b) Gäbe es ein neueres BIOS für das Modell? (heißt nicht, daß es auch sofort eingspielt werden müßte)
c) "Wer" kümmert sich um das Suspend bei Deckel zu? Welchen Windowmaager/Desktop (der ggf. sein eigenes Powermamangement hat) nutzt du? Bei meinem Thinpad regele ich die verarbeitung des LID-CLOSE Events z.B über den acpid welcher dann pm-suspend startet.
d) Würde das Hängenbleiben nach dem ~vierten versuch auch passieren wenn du statt Deckel zu den supspend über pm-suspend aus dem terminal (oder Fn-taste sofern vorhanden) auslösen würdest?

Offline

#11 01.07.2012 13:14:49

Martin_Berlin
Gast

Re: Fehler beim Booten / Absturz bei suspend

Hallo GerBra!

Zu...

1.) Ich benutze einen Lenovo T410i
2.) Ja, laut der Lenovoseite gibt es ein BIOS-Update für Windows
3.) Ich benutze XFCE 4.10. Acpid und pm-suspend wird bei mir auch genutzt
4.) Das habe ich auch schon probiert. Selbst wenn ich über das XFCE-Menü die Suspendfunktion anwähle, bleibt er hängen.

...vielen Dank schonmal im Vorfeld für die Mühen. Das Problem scheint wohl etwas komplexer zu sein. In folgendem Thread wurde beschrieben, dass durch das Blacklisten von tpm_tis der Fehler wohl behoben werden kann.

https://bugs.archlinux.org/task/29839?project=1&cat[0]=31&string=vi

#12 02.07.2012 12:31:24

oenone
Mitglied

Re: Fehler beim Booten / Absturz bei suspend

Martin_Berlin schrieb:

2.) Ja, laut der Lenovoseite gibt es ein BIOS-Update für Windows

Bei der Download-Seite gibt es bestimmt auch ein "BIOS Update Bootable CD for Windows 7 (32-bit, 64-bit), Vista (32-bit, 64-bit), XP - ThinkPad" (so heißt es für mein T420s).

Das ist ein gewöhnliches iso-image und sollte auch unter Linux brennbar sein. Windows braucht man dafür nicht.

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums