Du bist nicht angemeldet.

#1 13.04.2009 02:02:45

omee
Mitglied

xorg-server 1.6.0 wandert nach [extra]

Nach der Veröffentlichung Ende Februar und einer ausgiebigen Zeit im [testing]-Repo, wandern nun der xorg-server 1.6.0 samt der dazugehörigen Treiber nach [extra].

Die neue Version des xorg-server bietet eine Reihe von Verbesserungen unter anderem, das neue Protokoll X Input 1.5. Zu seinen Aufgaben zählen, Abfragen und Konfigurieren von Geräte-Eigenschaften, sowie Verbesserung der Mauszeiger-Steuerung (Predictable Pointer Acceleration). Als weitere Neuerung für den xorg-server, sei DRI2 (Direct Rendering Infrastruktur) und KMS (Kernel Mode Setting) genannt, KMS wird ab dem Kernel 2.6.29 unterstützt. Allerdings muss dazu gesagt werden, dass DRI2 und KMS im Moment nur vom Intel-Treiber unterstützt wird.

Wie zu vermuten, welcher Treiber beim xorg-server 1.6.0 in einer neuen Auflage dabei ist, der xf86-video-intel. Sollten Probleme mit dem xf86-video-intel Treiber auftreten, so kann der xf86-video-intel-legacy verwenden werden.

Für diejenigen, die noch xorg-server in der Version 1.4.2 einsetzen ++wird empfohlen++, eine Aktualisierung durchzuführen oder den Intel i810/i830/i915/945G/G965+ legacy video drivers zunutzen.

Beim Update des xorg-server auf die Version 1.6.0 können evtl. Fehler auftreten.

Fehler: Konnte den Vorgang nicht vorbereiten
Fehler: Konnte den Vorgang (In Konflikt stehende Dateien) nicht durchführen
xorg-server: /usr/lib/xorg/modules/extensions/libdri.so existiert im Dateisystem
xorg-server: /usr/lib/xorg/modules/libwfb.so existiert im Dateisystem
Fehler sind aufgetreten, keine Pakete wurden aktualisiert.
####
error: could not prepare transaction
error: failed to commit transaction (conflicting files)
xorg-server: /usr/lib/xorg/modules/extensions/libdri.so exists in filesystem
xorg-server: /usr/lib/xorg/modules/libwfb.so exists in filesystem
Errors occurred, no packages were upgraded.

In diesem Fall

"pacman -Sf xorg-server", after which you can upgrade the rest of your system. http://www.archlinux.org/news/436/

Sollten Fehler und/oder Probleme auftreten, so meldet dies bitte im Bug-Tracker.

Update: Seit gestern (15.04.) liegt xorg-server in der Version 1.6.1 vor. [ANNOUNCE] xserver 1.6.1

----

Beitrag geändert von omee (16.04.2009 16:55:02)

Offline

#2 13.04.2009 12:22:10

SiD
Mitglied

Re: xorg-server 1.6.0 wandert nach [extra]

Sollte man statt der -force Option nicht lieber erst den alten Xserver deinstallieren und dann den neuen installieren?

also

pacman -Rd xorg-server
pacman -S xorg-server

Offline

#3 13.04.2009 13:37:33

bernarcher
Mitglied

Re: xorg-server 1.6.0 wandert nach [extra]

SiD schrieb:

Sollte man statt der -force Option nicht lieber erst den alten Xserver deinstallieren und dann den neuen installieren?

also

pacman -Rd xorg-server
pacman -S xorg-server

Das scheint bei den meisten zu funktionieren (es könnte Abhängigkeitsprobleme geben). Aber es ist mit Kanonen nach Spatzen geschossen, geht es doch nur um zwei Files, die "außer der Reihe" aktualisert werden müssen, was der neue xorg-server gleich mit erledigt. Man muss nur aufpassen, dass man nicht den ganzen Upgrade forciert (ja nicht pacman -Syuf), nur den xorg-server, also:

pacman -Sy
pacman -Sf xorg-server
und dann den ganzen Rest normal upgraden
pacman -Su

Beitrag geändert von bernarcher (13.04.2009 13:38:14)

Offline

#4 13.04.2009 15:38:31

clinx
Mitglied

Re: xorg-server 1.6.0 wandert nach [extra]

Es sind nichtmal Dateien, sondern nur Symlinks. Sollte also absolut ungefährlich sein hier -force zu verwenden.

Offline

#5 16.04.2009 07:45:46

moe
Mitglied

Re: xorg-server 1.6.0 wandert nach [extra]

Müsste es nicht "wandert nach [Extra]" heißen? Irgendwie ist mir das auf der Startseite gerade ins Auge gefallen und ich find dass es komisch aussieht.

Offline

#6 16.04.2009 16:48:11

omee
Mitglied

Re: xorg-server 1.6.0 wandert nach [extra]

Danke moe für den Hinweis, war schon recht spät bei der Veröffentlichung smile

----

Update: Seit gestern (15.04.) liegt xorg-server in der Version 1.6.1 vor. [ANNOUNCE] xserver 1.6.1

Offline

#7 23.04.2009 15:44:59

wbs
Mitglied

Re: xorg-server 1.6.0 wandert nach [extra]

Hm ich habe einfach die beiden Dateien verschoben und das Update hat danach (relativ Problemlos, Inteltreiber haben halt nicht funktioniert) geklappt.

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums