Du bist nicht angemeldet.

Eine Antwort schreiben

Schreibe deinen Beitrag und versende ihn
Beitragsoptionen
Deine Antwort

Zurück

Themen-Übersicht (Neuester Beitrag zuerst)

Pierre
08.07.2007 13:27:27
Spot schrieb:

Kann ich Arch oder generell ein Linux nur bis zu Ebene vom Grub herunterfahren, sodass er da wieder startet ohne das ich die ganze BIOS-Prozedur wieder durchlaufen muss ?

Ja, das geht mit kexec. Damit kann der Kernel zur Laufzeit ersetzt werden. Arch unterstützt dies. Das lohnt aber eigentlich nur bei Maschinen, die eine Ewigkeit zum Initialisieren brauchen.

florian
08.07.2007 13:02:57
Spot schrieb:

Kann ich Arch oder generell ein Linux nur bis zu Ebene vom Grub herunterfahren, sodass er da wieder startet ohne das ich die ganze BIOS-Prozedur wieder durchlaufen muss ?

Das geht meines Wissens nicht. Wenn der Linux-Kernel started, wird Grub überschrieben, das heißt es bleibt nichts mehr von ihm übrig. Man müsste ihn kurz vor dem Neustart wieder neu laden. Ob und wie das geht weiß ich nicht.

Spot schrieb:

Kann ich wichtige System-Dateien auch im laufendem Betrieb neuladen ohne den PC komplett zuzustarten ?

Kommt drauf an was für eine Datei. Bei manchen Dateien reicht es den zugehörigen Deamon neuzustarten. Bei Dateien, die von /etc/rc.sysinit ausgewertet werden, kann man versuchen die entsprechenden Teile aus der rc.sysinit auszuführen. Das hätte bei deinem Problem bestimmt funktioniert.
Allgemein gilt: Die Aussage "GNU/Linux muss man nie neustarten" gilt theoretisch. Praktisch ist der Neustart aber immer das bequemste.

Spot
07.07.2007 22:59:33

Nur die Graphische Oberfläche (also xfce4)

Ich probiere mal einen "kompletten" neustart

Kleine Frage:

Kann ich Arch oder generell ein Linux nur bis zu Ebene vom Grub herunterfahren, sodass er da wieder startet ohne das ich die ganze BIOS-Prozedur wieder durchlaufen muss ?

€ Neustart und es ist deutsch, warum bin ich da nicht früher drauf gekommen ?

Kann ich wichtige System-Dateien auch im laufendem Betrieb neuladen ohne den PC komplett zuzustarten ?

florian
07.07.2007 22:50:13

Hast du den Computer neugestartet?

jean-paul
07.07.2007 22:48:17

Hi,

es deutet darauf hin dass du nach bearbeiten der /etc/locale.gen kein #logale-gen
gemacht hast. Ein Neustart hilft manchmal auch.

Hier mal ein Link: http://bbs.archlinux.org/viewtopic.php?id=25991

Jean-Paul

matthias
07.07.2007 22:18:24
BurnOver schrieb:

in der rc.conf muss es
LOCALE="de_DE.UTF-8"
heissen

Nee - ich habe auch "de_DE.utf8", und funktioniert einwandfrei.

Spot
07.07.2007 22:01:57

Ist folgende:

[root@ich ich]# locale -a
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
C
POSIX
de_DE
de_DE.iso88591
de_DE.iso885915@euro
de_DE.utf8
de_DE@euro
deutsch
german

florian
07.07.2007 21:25:34
Spot schrieb:

locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory

Das ist sehr verdächtig, ich weiß bloß nicht woher das Problem kommt.

Poste mal die Ausgabe von "locale -a"

Spot
07.07.2007 21:06:56

Habe ich geändert, immer noch Englisch......

BurnOver
07.07.2007 20:55:22

in der rc.conf muss es
LOCALE="de_DE.UTF-8"
heissen

Spot
07.07.2007 19:29:49

locale gibt folgendes aus:

[root@ich ich]# locale
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=en_US
LC_CTYPE="en_US"
LC_NUMERIC="en_US"
LC_TIME="en_US"
LC_COLLATE=C
LC_MONETARY="en_US"
LC_MESSAGES="en_US"
LC_PAPER="en_US"
LC_NAME="en_US"
LC_ADDRESS="en_US"
LC_TELEPHONE="en_US"
LC_MEASUREMENT="en_US"
LC_IDENTIFICATION="en_US"
LC_ALL=
[root@ich ich]#

Pierre
07.07.2007 18:45:13
Spot schrieb:

export LANG="de_DE.utf8"
export LC_COLLATE="C"

Das brauchst Du nicht. Was gibt denn "locale" auf der Konsole aus? Nicht alle Anwendungen sind übersetzt. Für Firefox z.B. musst Du noch "firefox-i18n" installieren.

Spot
07.07.2007 18:38:00

Hallo !

Versuche zurzeit Arch auf deutsch umzustellen, doch es will und will nicht klappen. Die Suche im Forum und die Wiki helfen da nicht weiter.

Ich habe diesen Eintrag in der rc.conf:

LOCALE=de_DE.utf8

So sieht die locale-gen aus:

de_DE.UTF-8 UTF-8
de_DE ISO-8859-1
de_DE@euro ISO-8859-15

Selbstverständlich wurde nach dem editieren dieser datei der Befehl "locale-gen" als root ausgeführt.

In der Xorg.conf ist der entsprechende EIntrag für die deutsche Tastatur auch vorhanden (und funktioniert auch):

Option "XkbLayout" "de"
Option "XkbVariant" "nodeadkeys"
Option "XkbModel" "pc105"

In der profile steht dieses:

export LANG="de_DE.utf8"

export LC_COLLATE="C"

Nun keine Frage: Was mache ich falsch sodass immer noch alles in Englisch ist ? (xfce, thunar, mousepad, xmms, streamtuner, firefox....:)

Fußzeile des Forums

Powered by FluxBB