Du bist nicht angemeldet.

Eine Antwort schreiben

Schreibe deinen Beitrag und versende ihn
Beitragsoptionen
Deine Antwort

Zurück

Themen-Übersicht (Neuester Beitrag zuerst)

joey cape
07.07.2007 19:00:49

Also hab alles hin gebracht! Vielen dank

Gnulle
06.07.2007 13:33:21

You've saved my neck smile) Danke für die schnelle Antwort. Zwar hat ifconfig -a noch andere Schnittstellen hervorgebracht (eth1 , eth 2 etc), das Kabel hängt aber schon an der eth0.

Ich habe einfach Deine Befehle auf die eth0 angewandt (also ifconfig eth0 up etc.) und jetzt funzt es. Jetzt muß ich ihm nur noch beibringen, das auch nach dem Booten zu tun.

Besten Dank erstmal!
Thomas

GerBra
06.07.2007 12:01:37

Du hast höchstwahrscheinlich noch andere Geräte, die als Netzwerk-Device
erkannt werden und so verschiebt sich evtl. die Reihenfolge der Devices.

Schau doch mal nach einem Boot mit:
ifconfig -a
welche eth|wlan|ath|... Devices neben dem loopback (lo) Device noch gefunden
werden.

Wenn da z.B. noch eth1 wäre liegt es nahe, daß das deine richtige Netzkarte ist.
Um sich darüber mit dem DSL-Router per DHCP eine Adresse zuweisen zu lassen:
ifconfig eth1 up
dhcpcd eth1

Gnulle
06.07.2007 11:45:24

Jungs,

habe ein ähnliches Problem.

Ich gehe über Ethernet ganz normal mit einem DSL-Router über eth0 ins Netz. Während der Installation wird die eth0 sauber erkannt und mit dhcp konfiguriert. Er lädt sauber die Base-Packages während der Installation vom FTP-Server. Ich editiere brav meine rc.conf mit eth0="dhcp", die Installation läuft klaglos durch.

Nach dem Reboot kennt er auf einmal meine eth0-Schnittstelle nicht mehr. Gleiches ist mir auch bei einer Gentoo-Installation passiert.

Was mache ich falsch? Wie kann ich Euch meine rc.conf posten, wenn ich auf dem installierten System weder links noch Netzzugang habe (schreibe diesen Post gerade von einem anderen Rechner) Die mir bekannten Netzconfig-Tools findet er nicht, bzw. ich weiß halt nicht, wie ich sie ohne Internetzugang installieren kann.

Danke für Eure Hilfe/Hinweise zur Fehlereingrenzung

Thomas

Schrauber
05.07.2007 16:39:21

Jepp, so isses.

Erklärung:
Die rc.conf ist eigentlich auch nur ein Bash-Script. Die Bash mag bei der Zuweisung von Variablen (eth0 ist eine) einfach keine Leerzeichen.

Pierre
05.07.2007 16:20:51

Ändere

eth0 ="eth0  192.168.0.11 netmask 255.255.255.0 broadcast 192.168.0.255"

in

eth0="eth0 192.168.0.11 netmask 255.255.255.0 broadcast 192.168.0.255"
joey cape
05.07.2007 16:12:11

Dass ging aber schnell wink

ok hat etwas gedauert, hab ja nur die Konsole und wirklich gut kenn ich mich ja noch nicht aus...
aber hier die rc.conf

#
# /etc/rc.conf - Main Configuration for Arch Linux
#

#
# -----------------------------------------------------------------------
# LOCALIZATION
# -----------------------------------------------------------------------
#
# LOCALE: available languages can be listed with the 'locale -a' command
# HARDWARECLOCK: set to "UTC" or "localtime"
# TIMEZONE: timezones are found in /usr/share/zoneinfo
# KEYMAP: keymaps are found in /usr/share/kbd/keymaps
# CONSOLEFONT: found in /usr/share/kbd/consolefonts (only needed for non-US)
# CONSOLEMAP: found in /usr/share/kbd/consoletrans
# USECOLOR: use ANSI color sequences in startup messages
#
LOCALE="en_US.utf8"
HARDWARECLOCK="localtime"
TIMEZONE="Canada/Pacific"
KEYMAP=de-latin1-nodeadkeys
CONSOLEFONT=
CONSOLEMAP=
USECOLOR="yes"

#
# -----------------------------------------------------------------------
# HARDWARE
# -----------------------------------------------------------------------
#
# Scan hardware and load required modules at bootup
MOD_AUTOLOAD="yes"
# Module Blacklist - modules in this list will never be loaded by udev
MOD_BLACKLIST=()
#
# Modules to load at boot-up (in this order)
#   - prefix a module with a ! to blacklist it
#
MODULES=(3c574_cs slhc 3c574_cs)
# Scan for LVM volume groups at startup, required if you use LVM
USELVM="no"

#
# -----------------------------------------------------------------------
# NETWORKING
# -----------------------------------------------------------------------
#
HOSTNAME="myhost"
#
# Use 'ifconfig -a' or 'ls /sys/class/net/' to see all available
# interfaces.
#
# Interfaces to start at boot-up (in this order)
# Declare each interface then list in INTERFACES
#   - prefix an entry in INTERFACES with a ! to disable it
#   - no hyphens in your interface names - Bash doesn't like it
#
# Note: to use DHCP, set your interface to be "dhcp" (eth0="dhcp")
#
lo="lo 127.0.0.1"
eth0 ="eth0  192.168.0.11 netmask 255.255.255.0 broadcast 192.168.0.255"
INTERFACES=(lo eth0)
#
# Routes to start at boot-up (in this order)
# Declare each route then list in ROUTES
#   - prefix an entry in ROUTES with a ! to disable it
#
gateway="default gw 192.168.0.254"
ROUTES=(gateway)
#
# Enable these network profiles at boot-up.  These are only useful
# if you happen to need multiple network configurations (ie, laptop users)
#   - set to 'menu' to present a menu during boot-up (dialog package required)
#   - prefix an entry with a ! to disable it
#
# Network profiles are found in /etc/network-profiles
#
#NET_PROFILES=(main)

#
# -----------------------------------------------------------------------
# DAEMONS
# -----------------------------------------------------------------------
#
# Daemons to start at boot-up (in this order)
#   - prefix a daemon with a ! to disable it
#   - prefix a daemon with a @ to start it up in the background
#
DAEMONS=(syslog-ng network netfs crond)


# End of file

Dankeschön

Schrauber
05.07.2007 15:51:06

Hilfreich wäre, wenn Du mal Deine rc.conf anhängst. Ich vermute dort einen Schreibfehler.

Befehle als root:
Indem Du Dich als root anmeldest. Du hast bei der Installation ein Passwort für root vergeben. Also Benutzer root und dieses Passwort.
Sudo wird standardmäßig nicht installiert.

joey cape
05.07.2007 15:47:26

Hi,
ich hab auf meinem Laptop Arch Linux installiert. Soweit hat auch alles geklappt, die Pakete habe ich vom ftp geladen. Doch seit dem Neustart nach der erfolgreichen Installation geht das Netzwerk nicht mehr.

lsmod gibt volgendes aus:

3c574_cs             11912  1

lspcmcia:

Socket 0 Device 0:     [3c574_cs]        (bus ID: 0.0)

und /etc/rc.d/network restart:

/etc/rc.conf: line 61: eth0: command not found
/etc/rc.conf: line 61: eth0: command not found
/etc/rc.conf: line 61: eth0: command not found
:: Stoping Network                                                           [BUSY]
SIOCDELERT: No such process
down: error fetching interface information: Device not found
                                                                             [FAIL]
/etc/rc.conf: line 61: eth0: command not found
:: Starting Network                                                          [BUSY]
lo         Link encap: Local Loopback
            inet addr:127.0.0.1  Mask:255.0.0.0
            UP LOOPBACK RUNNING MTU: 16436 Metric:1
            RX alles 0
            TC auch 0 usw.

SIOCADDRT: No such process
                                                                              [FAIL]

Die /etc/rc.conf sieht eigentlich völlig normal aus soweit ich das erkennen kann smile

Eine Frage noch wie führe ich Befehle als root aus?
Ich komme von Ubuntu und sudo gibt es nicht...
Im Wiki steht leider immer nur "Und dann als root #..."

Auf jeden Fall schonmal vielen Dank für die Hilfe!

Fußzeile des Forums

Powered by FluxBB