Du bist nicht angemeldet.

Eine Antwort schreiben

Schreibe deinen Beitrag und versende ihn
Beitragsoptionen
Deine Antwort

Zurück

Themen-Übersicht (Neuester Beitrag zuerst)

florian
25.01.2007 19:06:44

Die Fehlermeldung hatte ich auch schon.
Das lag daran, dass das neue Kernel installiert wurde. Ich glaub, ich hab das gelößt in dem ich

mkinitcpio -g /boot/kernel26.img

nach der Installation des Kernels ausgeführt habe.
Dein Archlinux sollte auch mit dem Fallback-kernel starten:
Im Grub startbefehle für Archlinux mit 'e' editieren:
Die Zeile mit initrd nach

initrd /boot/kernel26-fallback.img

ändern. Dann mit 'b' booten.

Du kannst auch versuchen direkt 0.8 zu installieren.

dongiovanni
25.01.2007 18:11:45

Von welchen ISOs installierst du? Ist die initrd auf kernel26.img geändert? Nutzt du eine sata Platte oder IDE?

Für die xorg.conf kannst du auch hwd benutzen, um dir eine generieren zu lassen, wobei ja gerade bei Arch das gute ist, dass du alles manuell editieren kannst!

Smilie
25.01.2007 15:41:10
jean-paul schrieb:

Hi,

hast du arch-0.7.2 installiert?

In deiner menu.lst sollte der Eintrag ungefähr so aussehen:

# (0) Arch Linux
title Arch Linux
root (hd0,3)
kernel /boot/vmlinuz26 root=/dev/hda4 vga=791 ro
initrd /boot/kernel26.img

Wichtig ist der Eintrag: kernel26.img (letzte Zeile)

Jean-Paul

Danke, aber ich habe es noch 2x probiert und es kam immer derselbe Fehler.

Mal meine Vorgehensweise:
1. CD einlegen, enter, Schrift + Tastatur Layout auswählen.
2. Partionieren (50 GB, 500MB swap, 100MB, 100GB)
3. Moutpoints setzen (500MB swap -> 100MB root raiserfs -> 100GB raiserfs (genannt /home)
4. Base Paket auswählen und alle bis auf lilo ankreuzen.
5. Pakete, Kernel + Bootloader installieren -> Neustart
6. root eingeben, Passwort ändern und mit adduser einen Nutzer hinzufügen (ist das überhaupt nötig?)
7. nano /etc/rc.conf -> auf eth0="dhcp" abändern -> speichern
8. /etc/rc.d/network restart
9. pacman -Sy
10. pacman -Sy pacman
11.pacman -Syu
12. pacman -S xorg -> xorgconfig (wobei ich da nicht wirklich durchsehe; wüsste nichtmal, dass ich eine Videokarte besitze | gibt es keine automatische Hardwareerkennung?)

Und nach Schritt 12 trat immer der Fehler auf. Weiß jemand was genau falsch an meinen Schritten ist, habe ich noch was anderes vergessen zu tun?

Meine weiteren Schritte wären gewesen:

13. pacman -S alsa-driver
14. pacman -S alsa-lib
15. pacman -S alsa-utils
16. pacman -S alsa-oss
17. alsaconf
18. pacman -S kde

Und weiter steht in meiner Anleitung nichts beschrieben.

jean-paul
24.01.2007 20:42:26

Hi,

hast du arch-0.7.2 installiert?

In deiner menu.lst sollte der Eintrag ungefähr so aussehen:

# (0) Arch Linux
title Arch Linux
root (hd0,3)
kernel /boot/vmlinuz26 root=/dev/hda4 vga=791 ro
initrd /boot/kernel26.img

Wichtig ist der Eintrag: kernel26.img (letzte Zeile)

Jean-Paul

Smilie
24.01.2007 19:41:45
Pierre schrieb:

Wenn Du an einem Netz mit DHCP-Server angeschlossen bist (z.B. Router) dann ändere die Datei (etc/rc.conf so ab, daß dort eth0="dhcp" steht. Hiernach mit "/etc/rc.d/network restart" den Netzwerkdienst neu starten.

Danke. Hat gut funktioniert. Danach hab ich erstmal pacman -Syu gemacht und dann Xorg (http://wiki.archlinux.de/?title=Xorg) installiert. Hat soweit auch gut geklaott und danach habe ich ich gleich KDE installiert (pacman -S kde). Soweit so gut. Keine mir aufgefallenen Fehler. Danach neugestartet, aber er lief so wie immer, bis der folgendende Fehler kam (die letzten 3 Zeilen):

RAMDISK: compressed image found at block 0
No filesystem could mount root, tried:
Kernel panic - not szncing: VFS: Unable to mount root fs on unknown - block (0,0)

Ich kann damit jetzt nichts anfangen. Kann mir bitte jemand helfen?

Pierre
24.01.2007 17:27:07

Wenn Du an einem Netz mit DHCP-Server angeschlossen bist (z.B. Router) dann ändere die Datei (etc/rc.conf so ab, daß dort eth0="dhcp" steht. Hiernach mit "/etc/rc.d/network restart" den Netzwerkdienst neu starten.

Smilie
24.01.2007 17:21:55
Pierre schrieb:

Nach der Installation und nachdem eine Verbindung zum Netz hergestellt ist, sollte man immer mit "pacman -Syu" das System aktualisieren.

Danke aber:

get hostbyname: resource temporarilz unavailable
error: cannot connect to (Datei)

Und das erscheint ein paar Mal untereinander. Liege ich richtig, wenn ich sage, dass es daran liegt, dass keine Internetverbindung hergestellt ist? Wie kann ich die herstellen? Habe dazu nichts im Wiki unter Internet gefunden. sad

Pierre
24.01.2007 17:08:12

Nach der Installation und nachdem eine Verbindung zum Netz hergestellt ist, sollte man immer mit "pacman -Syu" das System aktualisieren. Wenn Du die Paket-DB aktualisieren möchtest, hängt einfach den Parameter y an: "pacman -Sy xorg".

Smilie
24.01.2007 16:56:40
Pierre schrieb:

Suche doch mal im Wiki nach KDE.

Danke. Dort steht

Nachdem Xorg eingerichtet und konfiguriert wurde kann KDE mit Pacman installiert werden

Also muss ich folglich Xorg installieren.

pacman -S xorg

error. could not open sync database. extra

Was habe ich jetzt zu tun?

Pierre
24.01.2007 16:34:24

Suche doch mal im Wiki nach KDE.

Smilie
24.01.2007 16:22:49

Hallo,
Also Archlinux hab ich soweit zum Laufen gebracht. Nur wenn ich es jetzt starte, muss ich mich immer erst einloggen (root). Habe auch schon ein Passwort für root gesetzt. Nur kann mir jetzt jemand sagen, wie ich es schaffe KDE (o.Ä.) zu installieren, damit ich einen grafischen Bildschirm habe? Danke im voraus. smile

Gruß Smilie

Fußzeile des Forums

Powered by FluxBB