Du bist nicht angemeldet.

Eine Antwort schreiben

Schreibe deinen Beitrag und versende ihn
Beitragsoptionen
Deine Antwort

Zurück

Themen-Übersicht (Neuester Beitrag zuerst)

Dirk
14.05.2021 08:59:05

Nachtrag zu Audacity, wurde mir zufällig unabhängig von dem Thread hier gestern in den Empfehlungen auf YouTube gezeigt:

https://www.youtube.com/watch?v=aeBhYMCEui0

Was man davon halten kann, ist jedem selbst überlassen. Aber ganz so arglos wie der Author sehe ich das nicht.

Edit: jetzt nimmt die Sache fahrt auf ...

https://hackaday.com/2021/05/17/telemet … zi582IHaL0

vahB3aiy
13.05.2021 16:52:32
Dirk schrieb:

Ich habe das Gefühl, dass Audacity ziemlich im Arsch ist, wenn es um modernere Systeme geht

Wenn es um modernere Systeme geht, sollte man vor allem auch mal die modernere Version verteilen. Das Paket ist hier seit dem 2020-06-27 als veraltet gekennzeichnet und wird noch in der Version 2.4.1 angeboten, während die Entwickler bereits eine Version 3.0.2 freigegeben haben.

Ein aktualisiertes Paket lässt sich wegen Fehlern

autoreconf: error: 'configure.ac' is required

auch nicht mehr erstellen, wahrscheinlich weil sie mittlerweile auf 'cmake' umgestiegen sind, was Korrekturen am PKGBUILD erfordert. Offene Bugreports gibt es zwischenzeitlich auch, eigentlich gehört das in dem Zustand nicht mehr in ein offizielles Repo.

HansHiasl
13.05.2021 15:46:34

Hallo Dirk
Manchmal helfen einfach nur Zufälle.
Habe vorhin meinen Schreibtisch etwas "umorganisiert". Dabei hab ich dann auch die USB-Verkabelung entwirrt und das Micro ganz ohne Hintergedanken an einen anderen USB-Port angesteckt.
Und siehe da. Plötzlich funktioniert alles (bis auf Starleaf, da hatte ich noch keine Testmöglichkeit, bin aber zuversichtlich).
Das von Dir erwähnte Ocenaudio hab ich auch installiert. Und es gefällt mir auf den ersten Blick sehr gut. Danke für den Tipp.
Ich werde mir das jetzt mal genauer ansehen und ein wenig "üben".
Wenn sich der erste Eindruck bestätigt, dann fliegt Audacity raus. Auch vor dem Hintergrund, dass da bald Google Analytics eingebaut werden soll (https://www.golem.de/news/open-source-c … 56354.html).

Beste Grüße

Dirk
13.05.2021 14:22:28

Ich habe das Gefühl, dass Audacity ziemlich im Arsch ist, wenn es um modernere Systeme geht (asusschließlich PulseAudio ohne ALSA-Geraffel drumherum). Ich habe es seit Jahren nicht vernünftig benutzen können. Entweder viel zu laut (ausschließlich „gekreische“ durchs übersteuern), oder es wird erst gar kein Signal erkannt, oder es wird nicht mal ein Gerät erkannt.

n letzter Konsequenz bin ich auf Ocenaudio umgestiegen. VST-Plugins werden unterstützt, und ansonsten habe ich noch nichts gefunden, was ich mit Audacity früher gemacht habe, das Ocenaudio nicht genau so kann.

HansHiasl
13.05.2021 13:30:36

Hallo Gemeinde

Ich versuche seit einiger Zeit, mit Audacity über ein USB-Microfon etwas aufzunehmen.
Leider gelingt mir das nicht.
Das Problem dabei scheint in den richtigen Audio-Aufnahmeeinstellungen zu liegen.
Ich vermag im Audacity nicht herauszufinden, welche Einstellungen richtig sind.

Hier mal ein paar Systemdetails:
lsusb:

Bus 001 Device 003: ID 0d8c:0132 C-Media Electronics, Inc. USB PnP Audio Device

lshw:

*-usb:0
                      description: Audio device
                      product: USB PnP Audio Device
                      vendor: C-Media Electronics Inc.
                      physical id: 1
                      bus info: usb@1:1.1
                      version: 1.00
                      capabilities: usb-1.10 audio-control
                      configuration: driver=snd-usb-audio maxpower=100mA speed=12Mbit/s

lsmod | grep audio

snd_usb_audio         331776  1
ledtrig_audio          16384  1 snd_hda_codec_generic
snd_usbmidi_lib        40960  1 snd_usb_audio
mc                     65536  5 videodev,snd_usb_audio,videobuf2_v4l2,uvcvideo,videobuf2_common
snd_hwdep              16384  2 snd_usb_audio,snd_hda_codec
snd_pcm               147456  5 snd_hda_codec_hdmi,snd_hda_intel,snd_usb_audio,snd_hda_codec,snd_hda_core
snd                   114688  22 snd_hda_codec_generic,snd_seq_device,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_usb_audio,snd_usbmidi_lib,snd_hda_codec,snd_hda_codec_realtek,snd_timer,snd_pcm,snd_rawmidi

usb-devices

T:  Bus=01 Lev=02 Prnt=02 Port=00 Cnt=01 Dev#=  3 Spd=12  MxCh= 0
D:  Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=16 #Cfgs=  1
P:  Vendor=0d8c ProdID=0132 Rev=01.00
S:  Manufacturer=C-Media Electronics Inc.
S:  Product=USB PnP Audio Device
C:  #Ifs= 2 Cfg#= 1 Atr=80 MxPwr=100mA
I:  If#=0x0 Alt= 0 #EPs= 0 Cls=01(audio) Sub=01 Prot=00 Driver=snd-usb-audio
I:  If#=0x1 Alt= 0 #EPs= 0 Cls=01(audio) Sub=02 Prot=00 Driver=snd-usb-audio

In Pavucontrol ist bei Eingabegeräte ein "USB PnP Audio Device Analog Stereo" am Port: "Microfon" eingestellt.

Und in Audacity kann ich bei Aufnahmegeräten auswählen zwischen:

USB PnP Audio Device: Audio (hw:0,0)
HDA ATI SB: ALC662 rev1 Analog (hw:1,0)
HDA ATI SB: ALC662 rev1 Alt Analog (hw:1,2)
1080 P Webcam: USB Audio (hw:3,0)
sysdefault
spdif
samplerate
pulse
speex
upmix
vdownmix
default

Wobei das aber komischerweise nur ein paar Möglichkeiten sind. Ich habe den Rechner gerade neu gestartet. Und vor dem Neustart waren in dem Auswahlmenü von Audacity noch viel mehr solcher Möglichkeiten enthalten. Die Unterschiede waren alle in dieser Sequenz: (hw:x,y) zu finden.
Neuerlicher Neustart und die Liste ist wieder endlos lang.

Ich habe jetzt so lange herumgestellt, dass der Ton (Microfon) auch bei Starleaf-Videokonferenz nicht mehr geht.
Zumindest das hat bisher immer funktioniert.
Es ist zum Mäusemelken. Linux (Arch) und Audio-Eingabegeräte scheinen sich irgendwie gegenseitig weitgehend auszuschließen :-(

Mein System ist aktuell. Linux arch 5.12.3-arch1-1.
Und in Windows 10 (Dualboot) funktioniert sowohl Microfon und Audacity als auch Starleaf einwandfrei.

Kann mir hier jemand helfen?
Ich weiß mir keinen Rat mehr.
Ich würde auch einen anderen Audiorecorder verwenden.
Aber der Gnome-Audio-Recorder aus den Paketquellen nimmt nichts auf.
Und der audio-recorder aus dem AUR geht überhaupt nicht. Der lässt sich zwar starten. Aber außer einer kurzen "Sanduhr" passiert da gar nichts. Beim Start aus dem Terminal keinerlei Ausgabe dort. Auch auch im journalctl -f  keinerlei Meldung über dieses Programm.

Fußzeile des Forums

Powered by FluxBB