Du bist nicht angemeldet.

Eine Antwort schreiben

Schreibe deinen Beitrag und versende ihn
Beitragsoptionen
Deine Antwort

Zurück

Themen-Übersicht (Neuester Beitrag zuerst)

cokejunkee
09.11.2020 17:10:50

Ich hatte gestern ein bisschen Zeit und Speicherplatz übrig.
Konnte den Bug auf fast allen von mir getesteten Distris nachstellen.
Hier die Ergebnisse:

Bug vorhanden:

Manjaro 20.2 (Arch): Kernel 5.9.3-1-MANJARO, KDE 5.75.0, Plasma 5.20.2, VirtualBox 6.1.16
EndeavourOS (Arch): Kernel 5.9.6-arch1-1, KDE 5.75.0, Plasma 5.20.2, VirtualBox 6.1.16
KDE neon (Ubuntu): Kernel 5.4.0-52-generic, KDE 5.75.0, Plasma 5.20.2, VirtualBox 6.1.10
openSUSE: Kernel 5.9.1-1-default, KDE 5.75.0, Plasma 5.20.2, VirtualBox 6.1.14


Bug nicht vorhanden:

MX Linux (Debian): Kernel 5.6.0-2-amd64, KDE 5.54.0, Plasma 5.14.5, VirtualBox 6.1.14
ParrotOS (Debian): Kernel 5.7.0-2parrot2-amd64, KDE 5.70.0, Plasma 5.17.5, VirtualBox 6.1.14


Ich hab an der Stelle aufgehört, da die Sache ziemlich klar ist. Der Bug scheint auf KDE Seite zu liegen.
Vor Plasma 5.20 tritt er nicht auf und scheint unabhängig vom genutzten Kernel.
Vielleicht hilft das jemandem weiter smile

Edit:
Bug wurde im KDE bugtracker eingetragen
https://bugs.kde.org/show_bug.cgi?id=428929

WeirdTactiX
04.11.2020 20:15:02

Ja, mit einem Downgrade auf 6.1.14 hatte ich es schon versucht. Dort tritt das Problem ebenfalls auf. Ich schätze mal du liegst da mit deiner Vermutung bzgl. des unglücklichen Zusammenspiels richtig. Bis vor 2-3 Wochen hatte ich mit VirtualBox unter Arch definitv noch keine Probleme und es hat alles funktioniert wie es sollte. Ich denke ich werde morgen mal noch eine Arch VM mit einer anderen GUI installieren und testen wie sich VirtualBox dann dort verhält.

Aw4Lee7b
04.11.2020 14:33:55

Dann sollte aber trotzdem jemand einen Bugreport einwerfen, denn von alleine wird da nichts passieren ...

Das Problem betrifft übrigens auch andere Dateidialoge innerhalb der Einstellungen, beispielsweise an der Stelle, wo man den Ordner für die Sicherungspunkte setzen kann, da ist der Dialog mit der Maus auch nicht mehr bedienbar. Hast du es auch mal mit einem Downgrade auf VirtualBox-6.1.4 versucht? Nur um einzugrenzen, dass es wirklich an VirtualBox und nicht an Plasma oder dem KDE-Frameworks liegt. Ich kann mir kaum vorstellen, dass der Packager etwas falsch gemacht hat, und nur dann macht ein Bugreport hier wirklich Sinn. Ich glaube eher an ein unglückliches Zusammenspiel zwischen VirtualBox und der KDE-Komponenten. Trotzdem seltsam, dass es mit Debian läuft.

WeirdTactiX
04.11.2020 14:23:23

Hey, danke für die Antwort und deine Mühe!

Habe es jetzt auch nochmal unter Debian (auch mit KDE) probiert und natürlich auch mit der selben Version. Dort funktioniert alles ohne Probleme! Scheint also ein Problem unter Arch zu sein. Kann man also nur hoffen, dass der Bug bald gefixxt wird, zumindest gibt es mit deiner Methode über die Tastatur oder meiner über das Auslösen des Suchfehlers eine Art "Workaround".

Gruß

Aw4Lee7b
04.11.2020 12:51:58

Ich habe mir das mal angesehen: ein richtiger Freeze ist es nicht, aber die Maussteuerung scheint in dem Dialog nicht zu funktionieren, und der Fokus liegt auf dem Eingabefeld für den Namen. Mit TAB kann man aber zwischen den Feldern wechseln, und nach mehrfachem TAB kommt man dann auch in das Auswahlfenster der Dateinamen, in dem man sich mit den Cursortasten weiterbewegen kann. So kommt man auch in das Feld für den Ordner und kann ihn dort wechseln.

Ein Bug ist das auf jeden Fall, ich bin mir nur nicht sicher ob Upstream oder bei Arch. Dazu müsste man das mal mit einer anderen Distribution und gleichem Versionsstand testen, oder hier https://www.virtualbox.org/wiki/Bugtracker recherchieren

WeirdTactiX
03.11.2020 23:35:49

Hallo zusammen,

mir ist heute aufgefallen, dass ich unter der aktuellen VirtualBox Version 6.1.16 nachdem ich eine VM angelegt habe und anschließend unter den VM Settings > Storage > Optical Drive > Choose a Disk File einen Freeze bekomme (manchmal lässt sich noch ins Überverzeichnis wechseln) und kein ISO auswählen kann, geschweige denn den Ordner wechseln kann. Ist das ein Fehler auf meinem System oder hat jemand ähnliches Verhalten bei sich beobachten können und es handelt sich hier möglicherweise um einen Bug?

Ich nutze den aktuellen Linux Kernel 5.9.3-arch1-1 und als GUI KDE.

Vielen Dank für eure Hilfe!

LG



Edit:

Habe das Ganze jetzt auch nochmal in einer Arch VM unter VirtualBox unter Windows getestet und dort selbiges Problem feststellen können. Deswegen vermute ich hier sehr stark einen Bug. Das Problem lässt sich allerdings "umgehen", indem man unten in das Suchfeld im Auswahlfenster etwas eintippt und Enter drückt. Bestätigt man anschließend die Fehlermeldung, kann man sich wieder im Auswahlfenster durch das Filesystem klicken.

Fußzeile des Forums

Powered by FluxBB