Du bist nicht angemeldet.

Eine Antwort schreiben

Schreibe deinen Beitrag und versende ihn
Beitragsoptionen
Deine Antwort

Zurück

Themen-Übersicht (Neuester Beitrag zuerst)

jolexin
03.02.2021 22:13:52

Ich hab das gleiche Problem, d.h. hab mit wpa_supplicant usw das WLAN gestartet, nur nach dem reboot startet das Wlan NICHT so wie vorher. Ich kann der langen Diskussion leider keine Lösung entnehmen. Lässt sich das in einem zusammenfassenden Satz sagen?

Dirk
22.08.2020 23:34:49
Pazuzu schrieb:

Was hab ich übersehen? Ist mit dialog generell ein Programm wie Gmrun gemeint?

Mit dialog ist, nun ja, dialog gemeint.

jaaS5sei
22.08.2020 17:32:26
Pazuzu schrieb:

Was hab ich übersehen? Ist mit dialog generell ein Programm wie Gmrun gemeint?

Das ist eine ncurses-Erweiterung, um Dialog-Boxen anzegen zu können. Wird als optionales Paket von netctl benötigt.

Pazuzu
22.08.2020 17:17:08
jaaS5sei schrieb:

Ich würde gerade bei WLAN zu netctl raten, über das wifi-menu kann man die Verbindung einfach konfigurieren und danach mit netctl aktivieren.

Ich bekomme diese Meldung

[pazuzu@laptop ~]$ sudo wifi-menu -o
Please install 'dialog' to use wifi-menu

Was hab ich übersehen? Ist mit dialog generell ein Programm wie Gmrun gemeint?

Photor
22.08.2020 12:57:41
Pazuzu schrieb:
Photor schrieb:

Huch! Ich schrieb nur einen "."?

PS: wollte nur sagen, dass es je nach DE, die du verwendest schon eine Lösung gibt, mit der man lösen kann (warum das Rad nochmal erfinden bzw. besser: warum jedes mal ein neuer Rad zimmern, wenn es schon eins von der Stange gibt).

Ciao,
Photor

Der "." diente nur als Füller, damit der Quoteblock funktioniert. Ich geh einfach davon aus, dass jeder weiss was er geschrieben hat, so bleibt das Thema insgesamt übersichtlicher.
Networkmanager hatte ich bereits vorher schon probiert.

 nm-connection-editor

führte aber nur zum bash error weil das Kommando nicht gefunden wurde. (Eventuell das Gnome Applet mitinstallieren? pacman -S networkmanager allein brachte keine Ergebnisse)

ad 1: I know big_smile

ad 2:  hm. So genau weiß ich das jetzt gar nicht. Installiert aus dem Bereich "gnome" ist folgendes:

[photor@Picard ~]$ pacman -Ss gnome- | grep Installiert
extra/accerciser 3.36.3-1 (gnome-extra) [Installiert]
extra/dconf-editor 3.36.4-1 (gnome-extra) [Installiert]
extra/devhelp 3.36.2-1 (gnome-extra) [Installiert]
extra/evolution 3.36.5-1 (gnome-extra) [Installiert]
extra/five-or-more 3.32.2-1 (gnome-extra) [Installiert]
extra/four-in-a-row 3.36.4-1 (gnome-extra) [Installiert]
extra/ghex 3.18.4-2 (gnome-extra) [Installiert]
extra/glade 3.36.0+1+g3907987d-1 (gnome-extra) [Installiert]
extra/gnome-2048 3.36.4-1 [Installiert]
extra/gnome-autoar 0.2.4-2 [Installiert]
extra/gnome-bluetooth 3.34.1-1 [Installiert]
extra/gnome-calculator 3.36.0-1 (gnome) [Installiert]
extra/gnome-color-manager 3.36.0-1 (gnome) [Installiert]
extra/gnome-control-center 3.36.4-1 (gnome) [Installiert]
extra/gnome-desktop 1:3.36.5-1 [Installiert]
extra/gnome-icon-theme-symbolic 3.12.0-6 [Installiert]
extra/gnome-keyring 1:3.36.0-1 (gnome) [Installiert]
extra/gnome-klotski 3.36.3-1 (gnome-extra) [Installiert]
extra/gnome-mahjongg 3.36.2-1 (gnome-extra) [Installiert]
extra/gnome-menus 3.36.0-1 (gnome) [Installiert]
extra/gnome-mines 3.36.0-1 (gnome-extra) [Installiert]
extra/gnome-nibbles 3.36.1-1 (gnome-extra) [Installiert]
extra/gnome-online-accounts 3.36.0-1 [Installiert]
extra/gnome-power-manager 3.32.0-2 [Installiert]
extra/gnome-robots 3.36.1-1 (gnome-extra) [Installiert]
extra/gnome-settings-daemon 3.36.1-1 (gnome) [Installiert]
extra/gnome-sound-recorder 3.34.0+10+gc4bdfa0-1 (gnome-extra) [Installiert]
extra/gnome-sudoku 3.36.0-1 (gnome-extra) [Installiert]
extra/gnome-tetravex 3.36.4-1 (gnome-extra) [Installiert]
extra/gnome-themes-extra 3.28-2 (gnome) [Installiert]
extra/gnome-video-effects 0.5.0+4+g9554041-2 (gnome) [Installiert]
extra/hitori 3.36.0-1 (gnome-extra) [Installiert]
extra/iagno 3.36.3-1 (gnome-extra) [Installiert]
extra/libgnome-games-support 1.6.1-1 [Installiert]
extra/libsoup 2.70.0-1 [Installiert]
extra/lightsoff 3.36.0-1 (gnome-extra) [Installiert]
extra/polari 3.36.3-1 (gnome-extra) [Installiert]
extra/quadrapassel 3.36.05-1 (gnome-extra) [Installiert]
extra/swell-foop 3.34.1-2 (gnome-extra) [Installiert]
community/gnome-icon-theme 3.12.0-6 [Installiert]
community/gnome-icon-theme-extras 3.12.0-5 [Installiert]
community/gnome-latex 3.36.0-1 [Installiert]
community/gnome-passwordsafe 3.99.2-1 [Installiert]

und zum Network-Manager das hier:

[photor@Picard ~]$ pacman -Ss network- |grep Installiert
extra/network-manager-applet 1.18.0-1 [Installiert]

Ciao,
Photor

PS: da kann ich auch nochmal ausmisten

Pazuzu
22.08.2020 12:57:08

@ Mods: ich kann als Gast leider nicht editieren, aber ihr dürft meine Beiträge zusammenführen!

A start job is running for /sys/subsystem/net/devices/wlp4s0.conf (0s / 1min 30s)

über find /etc/systemd konnte ich den entsprechenden Dienst ausmachen und deaktivieren.

Das Thema kann als gelöst markiert werden. Vielen Dank an alle die mir geholfen haben, ihr seid supper smile

Pazuzu
22.08.2020 12:44:11
Photor schrieb:

Huch! Ich schrieb nur einen "."?

PS: wollte nur sagen, dass es je nach DE, die du verwendest schon eine Lösung gibt, mit der man lösen kann (warum das Rad nochmal erfinden bzw. besser: warum jedes mal ein neuer Rad zimmern, wenn es schon eins von der Stange gibt).

Ciao,
Photor

Der "." diente nur als Füller, damit der Quoteblock funktioniert. Ich geh einfach davon aus, dass jeder weiss was er geschrieben hat, so bleibt das Thema insgesamt übersichtlicher.
Networkmanager hatte ich bereits vorher schon probiert.

 nm-connection-editor

führte aber nur zum bash error weil das Kommando nicht gefunden wurde. (Eventuell das Gnome Applet mitinstallieren? pacman -S networkmanager allein brachte keine Ergebnisse)

jaaS5sei schrieb:

Nimm netctl und gut ist.

Danke für den Tipp. Tatsächlich funktioniert jetzt alles so wie es soll.
(Im Wiki gibt es in der Sektion Wlan keinen Hinweis auf netctl, stattdessen gibt es noch die Anleitung führt netcfg (wenn auch als veraltet markiert)).

Pazuzu schrieb:

Ich hab in der Datei

/usr/lib/systemd/system/wpa_supplicant@.service

den Pfad zur config angepasst.

Das hab ich wieder rückgängig gemacht und den Dienst ensprechend wieder deaktiviert.
A start job is running ... hab ich leider trotzdem noch sad

A start job is running for /sys/subsystem/net/devices/wlp4s0.conf (0s / 1min 30s)

Da muss ich wohl nochmal ran..

jaaS5sei
21.08.2020 16:45:51
Pazuzu schrieb:

Ich hab in der Datei

/usr/lib/systemd/system/wpa_supplicant@.service

den Pfad zur config angepasst.

Das macht man nicht! Wenn Änderungen an den Dateien vorgenommen werden müssen, dann an einer Kopie in /etc  oder einem Dropfile mit "systemctl edit wpa_supplicant.service@".

Beim nächsten Paketupdate werden nämlich die Änderungen an den Dateien wieder mit den Dateien des Paketbetreuers überschrieben, bzw. pacman erkennt eine unzulässige Änderung an der Datei, weil sie nicht mehr mit der protokollierten Checksumme und dem Zeitstempel übereinstimmt.

Beim booten kommt jetzt aber die Meldung "A start job is running" mit der vordefinierten Standardzeit von 1:30.

Nimm netctl und gut ist.

Photor
21.08.2020 16:42:49
Pazuzu schrieb:
brikler schrieb:

.

Jup das hab ich so gemacht und nach Neustart auch nochmal überprüft - der daemon läuft - aber es baut sich keine Verbindung auf. Ich werd morgen bei dem weiter machen was jas5Sei mir empfohlen hat.
Bis dahin starte ich nach dem booten von X erstmal noch manuell mit

wpa_supplicant -B -i wlp4s0 -c /etc/wpa_supplicant.conf
Photor schrieb:

.

Danke für den Tipp, probier ich später! Unter Linux führen halt seeehr viele Wege nach Rom.

Huch! Ich schrieb nur einen "."?

PS: wollte nur sagen, dass es je nach DE, die du verwendest schon eine Lösung gibt, mit der man lösen kann (warum das Rad nochmal erfinden bzw. besser: warum jedes mal ein neuer Rad zimmern, wenn es schon eins von der Stange gibt).

Ciao,
Photor

Pazuzu
21.08.2020 10:40:53

Puh okay, mittlerweile hab ich ganz schön den Überblick verloren.
Ich hab jetzt einen Weg gefunden, aber zufrieden bin ich nicht.

Ich hab in der Datei

/usr/lib/systemd/system/wpa_supplicant@.service

den Pfad zur config angepasst.

Danach

/etc/wpa_supplicant-wlp4s0.conf

erstellt,
und mit

systemctl enable wpa_supplicant@wlp4s0.service

den daemon gestartet.



Beim booten kommt jetzt aber die Meldung "A start job is running" mit der vordefinierten Standardzeit von 1:30.
Sobald der Desktop dann da ist, läuft der daemon (systemctl status ~) und das Wlan läuft.

Die Lösung ist sicher nicht ganz "sauber"(?) Die Meldung beim booten muss noch weg :B

Pazuzu
21.08.2020 00:36:44
brikler schrieb:

.

Jup das hab ich so gemacht und nach Neustart auch nochmal überprüft - der daemon läuft - aber es baut sich keine Verbindung auf. Ich werd morgen bei dem weiter machen was jas5Sei mir empfohlen hat.
Bis dahin starte ich nach dem booten von X erstmal noch manuell mit

wpa_supplicant -B -i wlp4s0 -c /etc/wpa_supplicant.conf
Photor schrieb:

.

Danke für den Tipp, probier ich später! Unter Linux führen halt seeehr viele Wege nach Rom.

brikler
20.08.2020 19:13:06
Pazuzu schrieb:
systemctl enable wpa_supplicant

klingt logisch, hat aber so nicht funktioniert. Eventuell greift der daemon per default auf die falsche Config zurück?

hast du den dämon gestartet? das geht so:

systemctl start wpa_supplicant

sonst mußt du neu starten, damit der dämon gestartet wird.

prüfen kannst dus mit:

systemctl status wpa_supplicant
Photor
20.08.2020 16:35:01

Moin,

habe gerade nachschauen müssen, ob bei mir wpa_supplicant läuft. Läuft als systemd-Dienst! Kann mich aber nicht erinnern, den eingerichtet zu haben (kann aber auch sein, dass das der Demenz geschuldet ist). Müsste glatt mal nachsehen, ob der überhaupt nötig wäre.

Zum Starten von WLAN (und LAN und VPNs und ...) läuft bei mir das Netzwerk-Manager-Applet (ich denke, das kommt vom Gnome mit rüber) im XFCE und das schmerzlos in der oberen Leiste. Darin lassen sich WLAN, LAN und eventuell VPNs definieren/configurieren und bei Bedarf an- und ausschalten, was ich für meinen Lappy als recht komfortable empfinde.

Ciao,
Photor

jaaS5sei
20.08.2020 12:10:09

Versuche mal, bei Aufruf den Adapter zu übergeben:
https://wiki.archlinux.org/index.php/Wp … _(systemd)

oder die Konfigurationsdatei:
https://bbs.archlinux.org/viewtopic.php … 9#p1393759

Ich würde gerade bei WLAN zu netctl raten, über das wifi-menu kann man die Verbindung einfach konfigurieren und danach mit netctl aktivieren.

Pazuzu
20.08.2020 11:40:32

Jup das Wiki sollte bezgl. Wlan/Netzwerk dringend überarbeitet werden.

systemctl enable wpa_supplicant

klingt logisch, hat aber so nicht funktioniert. Eventuell greift der daemon per default auf die falsche Config zurück?

Fußzeile des Forums

Powered by FluxBB