Du bist nicht angemeldet.

Eine Antwort schreiben

Schreibe deinen Beitrag und versende ihn
Beitragsoptionen
Deine Antwort

Zurück

Themen-Übersicht (Neuester Beitrag zuerst)

PaulchenPlump
07.07.2020 20:55:32

Die Anleitung mag alt sein, ich habe die Konstellation aber erst gestern in Reallife und einem Debian Buster gesehen. Leider kann ich die Konfig dort nicht einfach kopieren, aber es ist wohl "nicht viel mehr"...
Und Logdateien finde ich auch (noch) keine: in den Cups-Logfiles schreibt er nur, wenn ich cups als Server installiere und dann nur auch nur mit "localhost". hmm

Wenn ihr eine Idee habt wie ich mehr sehen kann, dann immer raus damit!

Dirk
07.07.2020 19:19:46
PaulchenPlump schrieb:

Jetzt habe ich gesehen (z.B.)

Die Frage ist halt, wie aktuell eine 5 Jahre alte Anleitung noch ist.

Und „Funktioniert nicht“ ist keine Fehlermeldung, sondern eine Zustandsbeschreibung, mit der niemand was anfangen kann smile

PaulchenPlump
07.07.2020 18:45:04

Hallo in die Runde,

ich habe einen Netzwerk-Drucker, welcher auf jedem meiner Clients mit einer einzelnen CUPS-Instanz eingebunden ist. Jetzt habe ich gesehen (z.B.), dass es auch möglich ist, CUPS nur einmal auf dem Server einzurichten und dann für die Clients freizugeben. Clientseitig ist dann nix weiter notwendig, als eine client.conf anzulegen, mit dem Verweis auf den Server. Dies habe ich probiert einzurichten, aber irgendwie findet er die Drucker nicht und ich frage mich, wo mein Fehler liegt.

Dazu benötigt es auf der Client-Seite unter Debian das Paket cups-client welches ich jedoch unter ArchLinux nicht finde. Deshalb habe ich als Ersatz(?) clientseitig noch das Paket libcups installiert (bzw. es war schon installiert) und dann eine /etc/cups/client.conf mit dem Inhalt ServerName servername erstellt. Auf der Server-Seite habe ich in der cupsd.conf nur den Parameter Listen 192.168.1.0:631 und in der Section "Location" Allow localhost\nAllow 192.168.1.* ergänzt. Abschließend wurde in der CUPS-Weboberfläche des Druckservers noch das Recht "Mit diesem System verbundene Drucker freigeben" gesetzt und dem installierten Drucker ebenfalls die Netzwerkfreigabe erlaubt. Zu guter Letzt wurden die Dienste neugestartet und gehofft, dass mein freigegebener Drucker auf den Clients angezeigt werden - leider ist dem nicht so.

Habt ihre eine Idee, was noch fehlt?

PS: Im ArchLinux-Wiki gibt es eine andere Anleitung: dazu ist die Installation von libcups notwendig und dann der Servername als Umgebungsvariable. Leider funktioniert diese ebenfalls nicht. sad

Ich danke euch im Voraus!
PaulchenPlump

Fußzeile des Forums

Powered by FluxBB