Du bist nicht angemeldet.

Eine Antwort schreiben

Schreibe deinen Beitrag und versende ihn
Beitragsoptionen
Deine Antwort

Zurück

Themen-Übersicht (Neuester Beitrag zuerst)

schard
11.06.2020 14:25:06

Schön, dass wir helfen konnten. Bitte markiere diesen Thread doch noch als gelöst, indem du deinen ersten Beitrag in diesem bearbeitest und dem Titel ein [GELÖST] voranstellst.

holmstroem
11.06.2020 14:16:00

Perfekt. Es hat geklappt smile
Ich danke dir, schard. Dann kann ich ja nun mein neues System weiter einrichten.

Eigentlich logisch mit dem Überschreiben von /mnt/boot.
Manchmal liegt der Teufel halt im Detail big_smile

Gruß holmstroem

schard
11.06.2020 13:07:42
holmstroem schrieb:

Einbinden der Partitionen

mkdir /mnt/boot
mount /dev/sda1 /mnt/boot
mount /dev/sda2 /mnt
mkdir /mnt/home
mount /dev/sda3 /mnt/home

Ein sehr schöner, ausführlicher Beitrag, dank dessen man auch direkt den ersten Fehler findet.
Wenn du erst /dev/sda1 nach /mnt/boot mountest und dann "darüber" /dev/sda2 nach /mnt, bekommt sda1 keine Daten ab.
Du musst zuerst /dev/sda2 nach /mnt mounten, dann dort /boot anlegen und danach dorthin /dev/sda1 mounten.
Ansonsten gibt es Probleme mit der Bootloader- und KernelInstallation.

Auch fehlt ergo ein Eintrag in deiner /etc/fstab für boot, da diese aus der Sicht von genfstab nicht unter /mnt gemountet war.

Zum beheben des Problems am besten live booten, /dev/sda1 nach /mnt2 mounten (vorher erstellen) und /dev/sda2 nach /mnt.
Dann alles von /mnt/boot/* nach /mnt2/ verschieben.
Danach /mnt2 unmounten und /dev/sda1 nach /mnt/boot mounten.
Die anderen Dateisysteme unter /mnt entsprechend einhängen (/home, swap) und dann die fstab neu generieren.
Danach kannst du mit der Einrichtung der Bootloaderkonfiguration weitermachen.

Merke: Das root-Dateisystem (/) immer zuerst mounten!

holmstroem
11.06.2020 12:59:01

Guten Tag, liebe Arch-Community.

ich bin neu hier im Forum und möchte mich für die Aufnahme bedanken.
Ich benutze schon länger Distributionen wie Linux Mint und Ubuntu. Dann bin ich irgendwann mal auf Manjaro gestoßen und dachte mir, wieso nicht gleich Arch installieren? big_smile hat mich wohl irgendwie gereizt, komplette Kontrolle über sein System zu haben.
Also habe ich angefangen mich zu informieren.

https://wiki.archlinux.de/title/Anleitu … Einsteiger
https://wiki.archlinux.org/index.php/Installation_guide
https://wiki.archlinux.de/title/Systemd-boot
https://wiki.archlinux.org/index.php/Systemd-boot
https://wiki.archlinux.org/index.php/Microcode

Nun zu meinem Problem..

Nach der Installation, die ich gleich noch genauer beschreiben werden, schaffe ich es nicht systemd-boot zu konfigurieren, sodass mir der Eintrag zum Booten von ArchLinux fehlt. Es wird mir nur "Reboot Into Firmware Interface" angeboten.

Ich bemühe mich mal, alle Informationen zusammenzutragen und wie ich im einzelnen vorgegangen bin.

Ändern der Tastaturbelegung

loadkeys de-latin1

Updaten der Systemuhr

timedatectl set-ntp true

Kommen wir zum Partitionieren der Festplatte

gdisk /dev/sda
1 	2048            1050623       512.0MiB       EF00    EFI system partition
2 	1050624      42993663	 20.0GiB         8304	Linux x86-64 root (/)
3	42993664     475813887   206.4GiB       8302    Linux /home
4	475813888   488397134   6.0GiB           8200    Linux swap

Anlegen der Dateisysteme

mkfs.vfat -F 32 /dev/sda1
mkfs.ext4 /dev/sda2
mkfs.ext4 /dev/sda3
mkswap /dev/sda4
swapon /dev/sda4

Einbinden der Partitionen

mkdir /mnt/boot
mount /dev/sda1 /mnt/boot
mount /dev/sda2 /mnt
mkdir /mnt/home
mount /dev/sda3 /mnt/home

Spiegelserver auswählen

cp /etc/pacman.d/mirrorlist /etc/pacman.d/mirrorlist.bak
grep -E -A 1 ".*Germany.*$" /etc/pacman.d/mirrorlist.bak | sed '/--/d' > /etc/pacman.d/mirrorlist
pacman -Sy
pacman -S reflector
reflector --latest 5 --protocol http --protocol https --sort rate --save /etc/pacman.d/mirrorlist

Installation der Basispakete

pacstrap /mnt base base-devel linux linux-firmware vim man-db man-pages inetutils netctl dhcpcd bash-completion amd-ucode wpa_supplicant dialog dosfstools gptfdisk efibootmgr

Fstab erzeugen

genfstab -Up /mnt >> /mnt/etc/fstab
cat /mnt/etc/fstab
# Static information about the filesystems.
# See fstab(5) for details.

# <file system>  <dir>  <type>  <options>  <dump>  <pass>
# /dev/sda2
UUID=988b02e6-923e-49a2-8bc6-b944f7e6b723     /     ext4     rw,relatime     0  1

# /dev/sda3
UUID=42292336-af88-4eec-84e9-2b1a89edf908     /home     ext4     rw,relatime     0   2

# /dev/sda4
UUID=ca752c18-726d-43a1-a775-2b517d4bc788     none     swap     defaults     0   0

In das installierte System wechseln

arch-chroot /mnt

Konfiguration lasse ich mal aus.


Initramfs erzeugen

mkinitcpio -p linux

Installation des Bootloaders

mount /dev/sda1 /boot
bootctl install

Anschließend:

vim /boot/loader/entries/arch-uefi.conf

title    Arch Linux
linux    /vmlinuz-linux
initrd   /initramfs-linux.img
initrd   /amd-ucode.img
options  root=UUID=988b02e6-923e-49a2-8bc6-b944f7e6b723 rw resume=UUID=ca752c18-726d-43a1-a775-2b517d4bc788
vim /boot/loader/entries/arch-uefi-fallback.conf

title    Arch Linux Fallback
linux    /vmlinuz-linux
initrd   /initramfs-linux-fallback.img
initrd   /amd-ucode.img
options  root=UUID=988b02e6-923e-49a2-8bc6-b944f7e6b723 rw resume=UUID=ca752c18-726d-43a1-a775-2b517d4bc788
vim /boot/loader/loader.conf

default   arch-uefi
timeout   1
bootctl update
exit
umount -R /mnt
reboot

Anschließend ändere ich die Bootreihenfolge im UEFI und möchte booten.
Dann wird mir aber nur die oben genannte Schaltfläche angezeigt.
Ich hoffe ihr könnt mir helfen.

Gruß

P.S. falls was fehlt, eben sagen. Danke.

Fußzeile des Forums

Powered by FluxBB