Du bist nicht angemeldet.

Eine Antwort schreiben

Schreibe deinen Beitrag und versende ihn
Beitragsoptionen
Deine Antwort

Zurück

Themen-Übersicht (Neuester Beitrag zuerst)

blub
25.05.2020 19:51:14
stefanhusmann schrieb:

Das mag sein, ändert aber nichts daran, dass es anscheinend in den Repos ein Paket gibt (java-openjfx), das nicht zusammen mit einem anderen (jre-openjdk) installiert werden kann, weil es eine kaputte versionierte Abhängigkeit gibt, die aus den Repos nicht auflösbar ist.

... gab, nicht gibt!
Trotzdem ein bisschen komisch, der Maintainer beider Pakete ist ja der gleiche, dem hätte der Versionskonflikt doch auffallen können?! Und als makedep von java-openjfx ist jdk11-openjdk nötig? Das ist auch komisch und widerspricht den Upstream Build-Anforderungen.

stefanhusmann
25.05.2020 13:11:05

Das mag sein, ändert aber nichts daran, dass es anscheinend in den Repos ein Paket gibt (java-openjfx), das nicht zusammen mit einem anderen (jre-openjdk) installiert werden kann, weil es eine kaputte versionierte Abhängigkeit gibt, die aus den Repos nicht auflösbar ist.

Gerry_Ghetto
25.05.2020 09:24:40

Ich weiss natürlich nicht, warum du Java 13/14 brauchst, aber eventuell lohnt es sich auch, wenn du zum Beispiel Java 11 (LTS) als Standard nutzt und die neueren Versionen nur dort, wo du sie auch tatsächlich brauchst.
In den meisten Fällen ist Java 11 (oder auch Java 8) völlig ausreichend.

stefanhusmann
24.05.2020 17:40:39

Das es kein Java 13 mehr in den Repos gibt, würde ich dies für einen Bug halten.

jessie
24.05.2020 15:46:55

Hallo,

ich wollte heute mein System aktualieren, was wegen:

Installation von jre-openjdk (14.0.1.u7-1) verletzt Abhängigkeit 'java-runtime-openjdk=13', benötigt von java-openjfx

fehlschlug.
Ich habe java-openjfx 13.u14-1 installiert, welches offenbar für diese Meldung ursächlich ist.
Weiß jemand, ob es sich hierbei nur um eine temporäre Angelegenheit handelt und es eine neue Version von java-openjfx geben wird? Oder muss man sich von openjfx verabschieden?

VG
Jessie

Fußzeile des Forums

Powered by FluxBB