Du bist nicht angemeldet.

Eine Antwort schreiben

Schreibe deinen Beitrag und versende ihn
Beitragsoptionen
Deine Antwort

Zurück

Themen-Übersicht (Neuester Beitrag zuerst)

HansHiasl
14.03.2020 16:03:17

Das wars. Danke :-)

aeX2gooG
14.03.2020 14:43:19

Erzeuge doch mal eine neue und zum System passende initramfs. Wenn das root-device nicht  eingehängt werden kann (was ja die nachfolgenden Meldungen belegen) dann ist in der Regel auch /usr nicht zugänglich, deswegen kann libp11-kit nicht gefunden und geladen werden.

HansHiasl
14.03.2020 13:57:37

Hallo Gemeinde

Ich habe heute bei  meinem alten Rechner wieder mal ein Update gemacht (das letzte war vor fünf bis sechs Wochen etwa).
Da ich hierbei immer wieder Probleme mit dem Netzwerk hatte (Verbindungsunterbrechnungen) und das Update ungewöhnlich langsam ging, hab ich den Updatevorgang mit Strg+C abgebrochen.
Und jetzt fährt der Rechner nicht mehr hoch. Es gibt nur noch diese Fehlermeldung:

:: running early hook [udev]
systemd-tmpfiles: error while loading shared libraries: libp11-kit.so.0: cannot
/usr/lib/systemd/systemd-udevd: error while loading shared libraries: libp11-kit
:: running hook [udev]
:: Triggering uevents...
udevadm: error while loading shared libraries: libp11-kit.so.0: cannot open shared object file: No such file or directory
udevadm: error while loading shared libraries: libp11-kit.so.0: cannot open shared object file: No such file or directory
udevadm: error while loading shared libraries: libp11-kit.so.0: cannot open shared object file: No such file or directory
Waiting 10 seconds for device 'UUID=fa126020-2869-460a-8a0e-bc008111c11e ...
Error: device 'UUID=fa126020-2869-460a-8a0e-bc008111c11e' not found. Skipping fsck.
:: mounting 'UUID=fa126020-2869-460a-8a0e-bc008111c11e' on real root
mount: /new_root: can't find UUID=fa126020-2869-460a-8a0e-bc008111c11e.
You are now being dropped into an emergency shell.
sh: can't access tty; job control turned off
[rootfs ]#_

Was hab ich bisher versucht?
Start mit Arch-Bootmedium und in chroot-Umgebung Update abgeschlossen. Lief fehlerfrei durch. Es gibt nichts zu tun.
Paket, das diesen libp11-kit.so.0 zur Verfügung stellt, neu installiert.
Grub aktualisiert.
sda an anderen sata-Port angeschlossen.
Hilft alles nichts.
Ich habe festgestellt, dass dieses Paket "libp11-kit" neu auf meinem Rechner ist (keine ältere Version im Cache, auch im Arch-Paketarchiv nur "meine" Version). Was wird damit ersetzt?
Das Paket "libp11" hat gefehlt (bzw.war nicht da), ich hab´s mal im chroot installiert. Hat nichts gebracht.
In gestarteten Bootmedium sind alle Datenpträger und Partitionen da. Auch diese 'UUID=fa126020-2869-460a-8a0e-bc008111c11e'. Ist die Root-Partition.
Irgendwie wird hier die Root-Partition beim Systemstart nicht gefunden. Aber warum?
Mein Rechner ist etwa 10 Jahre alt, es sind zwei HDD verbaut und ich bin mit meinem Latein am Ende :-(
Kann mir hier jemand einen Tipp geben, woran es hakt?

Fußzeile des Forums

Powered by FluxBB