Du bist nicht angemeldet.

Eine Antwort schreiben

Schreibe deinen Beitrag und versende ihn
Beitragsoptionen
Deine Antwort

Zurück

Themen-Übersicht (Neuester Beitrag zuerst)

DieKleene
31.03.2020 18:48:36
BiTSHiFT91
15.03.2020 20:20:51
skull-y schrieb:

Sicher, dass pulseaudio-alsa installiert ist? In deiner Liste taucht es jedenfalls nicht auf.

Im Moment kann ich dir erstmal nur raten dich durch das englische Wiki zu arbeiten. Einmal den Artikel(-Abschnitt) Pulseaudio/Troubleshooting/Only Dummy Output ausprobieren.

Ah sorry, habe nicht alle Pakete von Pacman listen lassen. Hier die komplette Liste in der auch pulseaudio-alsa drin ist: https://pastebin.com/9tSDcV5R
Durchs englische Wiki habe ich mich durchgearbeitet, allerdings ohne zu einem Ergebnis zu kommen. Die Schritte im Troubleshooting Abschnitt habe ich bereits gecheckt. Die Session Permissions passen soweit und

fuser -v /dev/snd/*

meldet, dass nur pulseaudio zugreift.

DieKleene schrieb:

Es gibt ja auch noch ein anderes Treiberpaket für die Soundkarten (Daily Build).

Magst du mir dazu ein paar mehr Details geben wie einen Namen oder eine Repo URL? Habe kein AUR dazu gefunden.

DieKleene
14.03.2020 20:51:36

Es gibt ja auch noch ein anderes Treiberpaket für die Soundkarten (Daily Build).

skull-y
14.03.2020 14:24:48

Sicher, dass pulseaudio-alsa installiert ist? In deiner Liste taucht es jedenfalls nicht auf.

Im Moment kann ich dir erstmal nur raten dich durch das englische Wiki zu arbeiten. Einmal den Artikel(-Abschnitt) Pulseaudio/Troubleshooting/Only Dummy Output ausprobieren.

BiTSHiFT91
14.03.2020 13:19:48
skull-y schrieb:

Welche DE verwendest du? Unter Xfce war noch das Paket pulseaudio-alsa notwendig.

Als DE hab ich Fluxbox im Einsatz. pulseaudio-alsa ist auch installiert.
Falls es hilft hier alle explizit installierten Pakete: https://pastebin.com/sqfNdwBt

Ich probiere mich gerade mit der Liste hier durch, in der Hoffnung, dass davon was funktioniert.

skull-y
14.03.2020 12:56:48

Welche DE verwendest du? Unter Xfce war noch das Paket pulseaudio-alsa notwendig.

BiTSHiFT91
14.03.2020 12:54:22
Greg schrieb:

Versuche mal den aktuellen linux Kernel also nicht LTS. Zusätzlich linux-firmware installieren.

linux-firmware war bereits installiert. Bin jetzt wieder auf Kernel 5.5.8, allerdings keine Veränderung.

Habe zwischendurch nochmal Windows gebootet, wo der Ton funktioniert. Unter Windows wird als Codec Realtek ALC892 verwendet.

speaker-test habe ich bereits laufen lassen - kein Ton.

Hier das Ergebnis von alsa-info.sh: http://alsa-project.org/db/?f=f7146732a … 910c0db2b5

cat /proc/asound/cards

 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0x604b100000 irq 165

cat /proc/asound/card0/codec*

Codec: Intel Kabylake HDMI
Address: 2
AFG Function Id: 0x1 (unsol 0)
Vendor Id: 0x8086280b
Subsystem Id: 0x80860101
Revision Id: 0x100000
No Modem Function Group found
Default PCM:
    rates [0x0]:
    bits [0x0]:
    formats [0x0]:
Default Amp-In caps: N/A
Default Amp-Out caps: N/A
State of AFG node 0x01:
  Power states:  D0 D3 CLKSTOP EPSS
  Power: setting=D0, actual=D0, Clock-stop-OK
GPIO: io=0, o=0, i=0, unsolicited=0, wake=0
Node 0x02 [Audio Output] wcaps 0x6611: 8-Channels Digital
  Converter: stream=0, channel=0
  Digital: Enabled KAE
  Digital category: 0x0
  IEC Coding Type: 0x0
  PCM:
    rates [0x7f0]: 32000 44100 48000 88200 96000 176400 192000
    bits [0x1a]: 16 24 32
    formats [0x5]: PCM AC3
  Power states:  D0 D3 EPSS
  Power: setting=D0, actual=D0
Node 0x03 [Audio Output] wcaps 0x6611: 8-Channels Digital
  Converter: stream=0, channel=0
  Digital: Enabled KAE
  Digital category: 0x0
  IEC Coding Type: 0x0
  PCM:
    rates [0x7f0]: 32000 44100 48000 88200 96000 176400 192000
    bits [0x1a]: 16 24 32
    formats [0x5]: PCM AC3
  Power states:  D0 D3 EPSS
  Power: setting=D0, actual=D0
Node 0x04 [Audio Output] wcaps 0x6611: 8-Channels Digital
  Converter: stream=0, channel=0
  Digital: Enabled KAE
  Digital category: 0x0
  IEC Coding Type: 0x0
  PCM:
    rates [0x7f0]: 32000 44100 48000 88200 96000 176400 192000
    bits [0x1a]: 16 24 32
    formats [0x5]: PCM AC3
  Power states:  D0 D3 EPSS
  Power: setting=D0, actual=D0
Node 0x05 [Pin Complex] wcaps 0x40778d: 8-Channels Digital Amp-Out CP
  Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
  Amp-Out vals:  [0x00 0x00]
  Pincap 0x0b000094: OUT Detect HBR HDMI DP
  Pin Default 0x18560010: [Jack] Digital Out at Int HDMI
    Conn = Digital, Color = Unknown
    DefAssociation = 0x1, Sequence = 0x0
  Pin-ctls: 0x00:
  Unsolicited: tag=00, enabled=0
  Power states:  D0 D3 EPSS
  Power: setting=D0, actual=D0
  Devices: 0
  Connection: 0
Node 0x06 [Pin Complex] wcaps 0x40778d: 8-Channels Digital Amp-Out CP
  Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
  Amp-Out vals:  [0x00 0x00]
  Pincap 0x0b000094: OUT Detect HBR HDMI DP
  Pin Default 0x18560010: [Jack] Digital Out at Int HDMI
    Conn = Digital, Color = Unknown
    DefAssociation = 0x1, Sequence = 0x0
  Pin-ctls: 0x00:
  Unsolicited: tag=00, enabled=0
  Power states:  D0 D3 EPSS
  Power: setting=D0, actual=D0
  Devices: 0
  Connection: 0
Node 0x07 [Pin Complex] wcaps 0x40778d: 8-Channels Digital Amp-Out CP
  Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
  Amp-Out vals:  [0x00 0x00]
  Pincap 0x0b000094: OUT Detect HBR HDMI DP
  Pin Default 0x18560010: [Jack] Digital Out at Int HDMI
    Conn = Digital, Color = Unknown
    DefAssociation = 0x1, Sequence = 0x0
  Pin-ctls: 0x00:
  Unsolicited: tag=00, enabled=0
  Power states:  D0 D3 EPSS
  Power: setting=D0, actual=D0
  Devices: 0
  Connection: 0
Node 0x08 [Vendor Defined Widget] wcaps 0xf00000: Mono
Greg
14.03.2020 11:23:16

Versuche mal den aktuellen linux Kernel also nicht LTS. Zusätzlich linux-firmware installieren.

BiTSHiFT91
14.03.2020 00:05:03

Hallo zusammen,

ich bin erst vor kurzem auf Arch Linux gewechselt und bin auch super happy soweit. Das einzige was bisher absolut nicht funktionieren will sind die Lautsprecher meines Notebooks.
In pavucontrol bekomme ich bei den Ausgabegeräten nur einen "Dummy Output" angezeigt. In dmesg sind keine Fehler im Bezug auf Audio zu finden. Als Kernel wird der aktuelle LTS-Kernel (5.4.24-1-lts) verwendet.
Ich habe testweise mal den Kernelparameter "snd_hda_intel.dmic_detect=0" gesetzt, was aber auch nicht geholfen hat.  Bin echt am Ende mit meinem Latein und würde mich total freuen, wenn jemand noch die ein oder andere Idee hätte hmm


aplay -l liefert:

**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

lspci -nn | grep -i audio

00:1f.3 Audio device [0403]: Intel Corporation Cannon Lake PCH cAVS [8086:a348] (rev 10)

pactl list sinks

Sink #0
	State: SUSPENDED
	Name: auto_null
	Description: Dummy Output
	Driver: module-null-sink.c
	Sample Specification: s16le 2ch 44100Hz
	Channel Map: front-left,front-right
	Owner Module: 16
	Mute: no
	Volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
	        balance 0.00
	Base Volume: 65536 / 100% / 0.00 dB
	Monitor Source: auto_null.monitor
	Latency: 0 usec, configured 0 usec
	Flags: DECIBEL_VOLUME LATENCY 
	Properties:
		device.description = "Dummy Output"
		device.class = "abstract"
		device.icon_name = "audio-card"
	Formats:
		pcm

Fußzeile des Forums

Powered by FluxBB