Du bist nicht angemeldet.

Eine Antwort schreiben

Schreibe deinen Beitrag und versende ihn
Beitragsoptionen
Deine Antwort

Zurück

Themen-Übersicht (Neuester Beitrag zuerst)

tachtler
29.01.2020 09:15:49

Hallo schard,
hallo Forum,

nachfolgende Änderungen an systemd funktionieren für mich. Der Server lief heute morgen noch genau so, wie direkt nach der Änderung:

[root@archlinux-host ~]# systemctl mask sleep.target suspend.target hibernate.target hybrid-sleep.target

Danke und Grüße
Klaus.

tachtler
28.01.2020 17:53:32

Hallo schard,

wow, super, Danke für die Mühe und die Fundstellen!


Grüße
Klaus.

schard
28.01.2020 17:52:43

Auch ein Workaround wird in o.g. Bug angeboten:

sudo -u gdm dbus-launch gsettings set org.gnome.settings-daemon.plugins.power sleep-inactive-ac-type 'nothing'

D.h. du müsstest die ganzen Energieeinstellungen für den Benutzer gdm prüfen / setzen, in dessen Benutzerkontext gdm ja läuft.

tachtler
28.01.2020 17:50:10

Hallo schard,

danke trotzdem schon mal für Deine schnelle Antwort und für Deine Hilfe.


Grüße
Klaus.

schard
28.01.2020 17:48:17

Hm. Das sieht auch i.O. aus. Muss ich nochmal drüber sinnieren.
Vielleicht hat noch jemand anderes eine Idee...
Update: Das scheint ein ungelöster Bug zu sein:
https://gitlab.gnome.org/GNOME/gnome-co … /issues/22
Daher würde ich an deiner Stelle dann auch mit der mask-Krücke arbeiten.

tachtler
28.01.2020 17:45:44

Hallo schard,

es scheint zwar aktuell zu funktionieren, aber ich würde es gerne "richtig" machen. Ich denke aber, das das "Maskieren" der entsprechenden systemd Dienste evtl. auch die Ursache war.

Hast Du eine andere Idee, was könnte ich noch überprüfen?

root@archlinux-host ~]# gsettings get org.gnome.settings-daemon.plugins.power sleep-inactive-ac-type
'nothing'
[root@archlinux-host ~]#

Danke und Grüße
Klaus.

schard
28.01.2020 17:43:15

Naja, das ist eine Krücke die funktionieren kann.
Damit maskierst du halt die entsprechenden Units und verhinderst so deren Start.
Wodurch diese denn aber nach ca. 20 Minuten Inaktivität versucht gestartet zu werden, wissen wir dadurch immer noch nicht.
Was sagt

gsettings get org.gnome.settings-daemon.plugins.power sleep-inactive-ac-type
tachtler
28.01.2020 17:32:54

Hallo schard,

danke für Deinen Hinweis, aber ich habe wirklich nur gnome-shell und gdm installiert, um mit virt-manager zu experimentieren.

der Inhalt von:

[root@archlinux-host ~]# egrep -v '(^#|^$)' /etc/systemd/logind.conf
[Login]
[root@archlinux-host ~]#

und

[root@archlinux-host ~]# gsettings get org.gnome.desktop.session idle-delay
uint32 0
[root@archlinux-host ~]# 

Mittlerweile habe ich aber nachfolgende Änderungen an systemd durchgeführt - wie siehst Du diese Änderungen?

[root@archlinux-host ~]# systemctl mask sleep.target suspend.target hibernate.target hybrid-sleep.target

Danke für Deine Hilfe!


Grüße
Klaus.

schard
28.01.2020 17:13:59

Das offensichtliche vorweg: Eine komplette DE auf einem Server zu installieren ist nicht nur aus Sicherheitsgründen, sondern auch wegen solcher Probleme keine gute Idee.
Gib bitte den Inhalt der Datei /etc/systemd/logind.conf an, sowie als root:

# gsettings get org.gnome.desktop.session idle-delay
tachtler
28.01.2020 16:39:15

Hallo Zusammen,

ich habe nach der Installation von ArchLinux und gnome-shell inkl. gdm bei einem SERVER das Problem, das diese nach X-Minuten ( ca. 20 Minuten ) einfach in den "suspend" Modus geht.

Es ist kein ACPI installiert und bei allen Benutzern (root, user1 und user2) habe ich die Einstellungen im GNOME deaktiviert.

Ihr könnt Euch vorstellen, dass wenn sich ein Server nach 20 Minuten in den suspend Modus begibt, das das eher ungünstig ist.

Für Hilfe oder einen Tipp woran es liegen könnte wäre ich sehr dankbar.


Grüße
Klaus.

p.s. Wenn ich Konfigurationen etc. liefern soll, bitte einfach sagen, Danke!

Fußzeile des Forums

Powered by FluxBB