Du bist nicht angemeldet.

Eine Antwort schreiben

Schreibe deinen Beitrag und versende ihn
Beitragsoptionen
Deine Antwort

Zurück

Themen-Übersicht (Neuester Beitrag zuerst)

Erl
11.01.2020 18:20:27

Es sieht so aus als sei die Version

arduino-1:1.8.9-2-x86_64.pkg.tar.xz 

nicht vorhanden.
Wo finde ich eine ältere Version für pacman?
Auf der mirrorseite

mirror.mikrogravitation.org/archlinux/

ist nur die

arch-1.3.5-12-x86_64.pkg.tar.xz 

EDIT:
hier habe ich die gesuchte Version gefunden.

http://mirror.mikrogravitation.org/archlinux/community/os/x86_64/

jetzt kann ich mit

pacman -U /var/cache/pacman/pkg/arduino-1_1.8.9-1-x86_64.pkg.tar.xz

downgraden.

Erl
11.01.2020 17:31:18

Fehler

Lade Pakete...
Fehler: '/var/cache/pacman/pkg/arduino-1:1.8.9-1-x86_64.pkg.tar.xz': Konnte Paket nicht finden oder lesen
niemand
11.01.2020 17:15:24

funktioniert bei mir nicht.

Keine Fehlermeldung/Ausgabe, keine Hilfe.

Erl
11.01.2020 16:53:21

Die IDE arduino-1.8.9 ist installiert.
sudo pacman -Qi arduino
[sudo] Passwort für uwe:

Name                     : arduino
Version                  : 1:1.8.9-3
Beschreibung             : Arduino prototyping platform SDK
Architektur              : x86_64
URL                      : https://github.com/arduino/Arduino
Lizenzen                 : GPL  LGPL
Gruppen                  : Nichts
Stellt bereit            : Nichts
Hängt ab von             : gtk2  desktop-file-utils  shared-mime-info
                           java-runtime>=8  arduino-builder
Optionale Abhängigkeiten : arduino-docs: Offline documentation for arduino
                           arduino-avr-core: AVR core with upstream avr-gcc and
                           avrdude [Installiert]
                           python2: Intel Galileo Board installation
                           [Installiert]
Benötigt von             : Nichts
Optional für             : Nichts
In Konflikt mit          : Nichts
Ersetzt                  : Nichts
Installationsgröße       : 28,54 MiB
Packer                   : NicoHood <nicohood@archlinux.org>
Erstellt am              : Mo 20 Mai 2019 22:55:52 CEST
Installiert am           : Sa 11 Jan 2020 15:00:19 CET
Installationsgrund       : Ausdrücklich installiert
Installations-Skript     : Ja
Verifiziert durch        : Signatur

ich würde gerne auf die Version 1.8.9-2 downgraden.
Ein Vorschlag zu meinem Thema

pacman -U /var/cache/pacman/pkg/arduino-1\:1.8.9-1-x86_64.pkg.tar.xz

funktioniert bei mir nicht.
[uwe@DellArch ~]$ ls /var/cache/pacman/pkg/arduino-*

/var/cache/pacman/pkg/arduino-1:1.8.9-3-x86_64.pkg.tar.xz
/var/cache/pacman/pkg/arduino-avr-core-1.6.23-1-any.pkg.tar.xz
/var/cache/pacman/pkg/arduino-builder-1.4.4-2-x86_64.pkg.tar.xz
/var/cache/pacman/pkg/arduino-ctags-5.8_arduino11-3-x86_64.pkg.tar.xz

Also habe ich mir eine alte und auch eine neuere Version von der Arduino Seite geholt und mittels ./install installiert.
Dann fehlt mir in der GUI von Arduino die Leiste (Datei, Bearbeiten, Sketch, Werkzeug, Hilfe)


Wie bekomme ich eine alte lauffähige IDE ??

Fußzeile des Forums

Powered by FluxBB