Du bist nicht angemeldet.

Eine Antwort schreiben

Schreibe deinen Beitrag und versende ihn
Beitragsoptionen
Deine Antwort

Zurück

Themen-Übersicht (Neuester Beitrag zuerst)

Andreas N.
28.10.2019 17:24:32
Andreas N. schrieb:

Beitrag geändert von Andreas N. (24.10.2019 19:45:58)

Ich war schneller als Du! wink

Baldr
24.10.2019 19:46:24

Gerne.... Dann das Thema noch als "Gelöst" markieren.
Gruß, Dirk

Andreas N.
24.10.2019 19:45:15

Ich meine das "kleine" Problem hat sich von selbst gelöst.

Es war anscheinend wie Du oben geschrieben hast, der Kernel.

Danke für Deine Hilfe

Gruß Andreas

Andreas N.
24.10.2019 19:40:17

Ok, ich glaube das Problem war der Linux Kernel der gefehlt hatte.

Nun bekomme ich mit

lsmod | grep vbox
vboxnetflt             32768  0
vboxnetadp             28672  0
vboxpci                28672  0
vboxdrv               503808  3 vboxpci,vboxnetadp,vboxnetflt

angezeigt.

Mache nochmals einen reboot und melde mich danach.

Andreas N.
24.10.2019 19:37:11

uname -r
5.3.7-arch1-1-ARCH

Baldr
24.10.2019 19:22:45

Du bist auf dem Kernel 5.3.6, aktuell ist 5.3.7. Führe mal eine Systemaktualisierung aus.

Andreas N.
24.10.2019 19:18:51

uname -a
Linux arch 5.3.6-arch1-1-ARCH #1 SMP PREEMPT Fri Oct 11 18:28:05 UTC 2019 x86_64 GNU/Linux

Andreas N.
24.10.2019 19:12:11
Andreas N. schrieb:

nach der Installation von Virtualbox und einem Neustart habe ich....

Also Neustart durchgeführt.

systemctl start systemd-modules-load.service
Job for systemd-modules-load.service failed because the control process exited with error code.
See "systemctl status systemd-modules-load.service" and "journalctl -xe" for details.

Baldr
24.10.2019 19:09:57

Noch ne Frage: Welchen Kernel bootest du?

Baldr
24.10.2019 19:04:58

Ok, der Service lädt nicht. Hast du nach der Installation neu gestartet?
Ansonsten mal:

# systemctl start systemd-modules-load.service

versuchen und in die vorherige Ausgabe schauen.

Andreas N.
24.10.2019 18:54:19

systemctl status systemd-modules-load.service
● systemd-modules-load.service - Load Kernel Modules
   Loaded: loaded (/usr/lib/systemd/system/systemd-modules-load.service; static; vendor preset: disabled)
   Active: failed (Result: exit-code) since Thu 2019-10-24 17:32:40 CEST; 1h 20min ago
     Docs: man:systemd-modules-load.service(8)
           man:modules-load.d(5)
  Process: 385 ExecStart=/usr/lib/systemd/systemd-modules-load (code=exited, status=1/FAILURE)
Main PID: 385 (code=exited, status=1/FAILURE)

Okt 24 17:32:40 arch systemd[1]: Starting Load Kernel Modules...
Okt 24 17:32:40 arch systemd[1]: systemd-modules-load.service: Main process exited, code=exited, status=1/FAILURE
Okt 24 17:32:40 arch systemd[1]: systemd-modules-load.service: Failed with result 'exit-code'.
Okt 24 17:32:40 arch systemd[1]: Failed to start Load Kernel Modules.

Baldr
24.10.2019 18:50:15

Zeig mal

$ systemctl status systemd-modules-load.service
Andreas N.
24.10.2019 17:56:32

Hallo Community,

nach der Installation von Virtualbox und einem Neustart habe ich probleme mit den vboxdrv kernel modules:

Was habe ich bisher gemacht:

sudo pacman -S virtualbox virtualbox-host-modules-arch
installiert.
sudo gpasswd -a USERNAME vboxusers
den Benutzer selbst hinzugefügt.
Ein id zeigt mir, dass ich in der Gruppe vboxusers bin.

Und nun zu meinem Problem:
ein lsmod | grep vbox zeigt mir nichts.

Wenn ich nach dem Arch Wiki Virtualbox vorgehe, muss ich nun aber vorher die VirtualBox kernel modules laden:
systemd-modules-load.service bekomme ich die Fehlermeldung: bash: systemd-modules-load.service: Kommando nicht gefunden.

Ein Aufruf von sudo nano /usr/lib/modules-load.d/virtualbox-host-modules-arch.conf zeigt mir:
vboxdrv
vboxpci
vboxnetadp
vboxnetflt

Beim Booten fällt mir auf das er die Kernel Module nicht starten kann.

Was habe ich hier falsch gemacht, bzw. was fehlt mir?

Gruß Andreas

Fußzeile des Forums

Powered by FluxBB