Du bist nicht angemeldet.

Eine Antwort schreiben

Schreibe deinen Beitrag und versende ihn
Beitragsoptionen
Deine Antwort

Zurück

Themen-Übersicht (Neuester Beitrag zuerst)

jan_r
24.10.2019 13:32:30
schard schrieb:

Was sagt die Konsolenausgabe, wenn du die Zeile unter Exec= unter Ersetzung der entsprechenden Platzhalter in einem Terminal ausführst?

Guter Hinweis. Hatte ich Depp bislang nur über Nautilus gestartet, um zu gucken, ob das Programm an sich noch läuft.
Aber so wird jetzt 'ne DLL aus dem Programmverzeichnis nicht mehr gefunden:

0009:err:module:import_dll Library libsidplay2.dll (which is needed by L"Z:\\home\\spider\\C64\\tools\\sidplay26w\\sidplay2w.exe") not found

Sieht so aus, als wäre WINE vorher von selbst auf die Idee gekommen in dem Verzeichnis der EXE nach der DLL zu suchen.
Zumindest klappt auch dies mit WINE 4.17 vom Terminal aus.

Naja, jetzt habe ich zumindest 'n Ansatz. Mal gucken, wie man das jetzt am schlauesten löst. Jetzt bei sidplay2w ging es den Programmpfad bei Path= einzutragen, aber irgendwie habe ich in Erinnerung, dass ich mir nicht ohne Grund angewöhnt hatte Path=/ zu setzen. Mal schauen...

Danke!

schard
24.10.2019 12:43:00

Was sagt die Konsolenausgabe, wenn du die Zeile unter Exec= unter Ersetzung der entsprechenden Platzhalter in einem Terminal ausführst?

jan_r
24.10.2019 12:26:42

Moin,

ich habe das Problem, dass nach dem Update von WINE (4.17. auf 4.18.) meine GNOME 3 Desktop Shortcuts, die per WINE Windows Programme starten, nicht mehr richtig funktionieren. Sprich: wenn ich in Nautilus 'ne Datei mit dem entsprechenden MimeType öffnen will, startet das Windows Programm nicht.

Hier ein Beispiel für so eine .desktop Datei:

[Desktop Entry]
Name=sidplay2w
Exec=wine /home/spider/C64/tools/sidplay26w/sidplay2w.exe %U
Type=Application
MimeType=audio/prs.sid
StartupNotify=true
Path=/
Icon=sound-juicer

Ist sowohl an meinem Desktop PC, als auch an meinem Notebook der Fall.
Habe ein bisschen an den Parametern herumgespielt, aber bislang keine Lösung gefunden.
Wenn ich WINE zurück auf 4.17 downgrade klappt es wieder.

Hat jemand eine Ahnung, was sich da geändert haben könnte?

Lieben Dank!
Jan

Fußzeile des Forums

Powered by FluxBB