Du bist nicht angemeldet.

Eine Antwort schreiben

Schreibe deinen Beitrag und versende ihn
Beitragsoptionen
Deine Antwort

Zurück

Themen-Übersicht (Neuester Beitrag zuerst)

inco12345
19.10.2019 17:31:55

Thema erledigt. Meine aktuelle Lösung:
https://gist.github.com/incoggnito/da0a … bbfce8e8c5

Danke für die Hinweise,
Freue mich über konstruktive Kritik.

inco12345
19.10.2019 07:07:32

Du hast meine Frage scheinbar falsch interpretiert.
Habe mich gefragt ob das "p" im aktuellen device Namen bei der Auflösung der Partition stört.

Bin aber mittlerweile auf die Antwort gestoßen:

dev/<disk_name>p<decimal> - same as the above, that form is
 *	   used when disk name of partitioned disk ends on a digit.
apocalyptycus
19.10.2019 05:10:02

nvme0n1p1
Das ist die m2, die Du da eingebaut hast.

inco12345
18.10.2019 20:01:43
niemand schrieb:

Salamitaktik? Bringt selten Vorteile.

Wieauchimmer: du kannst an der Stelle die Partition entschlüsseln, auf new_root einhängen und weiterbooten. Anschließend kannst du die initrd richtig erstellen.

Mag vielleicht so wirken, ist aber wirklich ohne Vorsatz wink
Ich probiere gerade einfach viele Möglichkeiten aus.

Danke für eine Hilfe, hab's hinbekommen,
Bin aktuell beim Bootloader hängen geblieben.

Hier würde ich nun gerne EFISTUB ohne einen Bootloader wie grub verwenden.
Ist das in Kombination mit LVM und dm_crypt überhaupt sinnvoll / möglich?
Kennt jemand ein paar aktuelle Beispiele für eine solche Installation?

Nutze relativ aktuelle Hardware:
Mainboard: AsRock Z170
Cpu: Intel 6700k
Grafikkarte: NVIDIA RTX 2060

Habs gerade eben mit folgendem Befehl probiert:

efibootmgr -c -d /dev/nvme0n1 -p 1 -l \vimlinuz-linux -L "Arch efistub" -u "initrd=/intel-ucode.img initrd=/initramfs-linux.img root=UUID=309639d2-f6ba-4644-99ce-4f3820ba8ab9 rw"

Ich habe eine Intel CPU, daher habe ich das ucode hinzugefügt.
Beim device bin ich mir nicht sicher ob das richtig erkannt wird.
Normal heißt eine Partition sda1 und in meinem Fall heißt sie nvme0n1p1.
Muss man mit LVM bei der root partition etwas spezielles beachten?
Hab leider nicht geprüft ob vimlinuz-linux in der boot partition vorhanden war, muss das morgen nochmal wiederholen und dokumentieren wie die Installationsschritte im Detail waren.

Viele Grüße
Andreas

niemand
17.10.2019 21:27:02

Salamitaktik? Bringt selten Vorteile.

Wieauchimmer: du kannst an der Stelle die Partition entschlüsseln, auf new_root einhängen und weiterbooten. Anschließend kannst du die initrd richtig erstellen.

inco12345
17.10.2019 21:07:19

Hab beim mounten scheinbar einen Fehler gemacht.
Hier die vollständige Vorgehensweise bei der Installation

https://pastebin.com/kLxTb9u6

Hier die Fehlermeldung im Anschluss an den Bootloader.

Starting version 243.51-1-arch
ERROR: /dev/mapper/main-root not found. Skipping fsck.
mount /new_root: no filesystem specified.

Lande in einer Emergency Shell.
Kann ich da noch was retten?
Oder sollte ich direkt neu installieren?

inco12345
17.10.2019 19:35:24

Die deutsche Anleitung hat sich in den letzten Jahren erheblich verbessert.

Passt das soweit? (Markdown, falls notwendig)
https://pastebin.com/iNKtCeN2

Viele Grüße
Andreas

inco12345
16.10.2019 21:40:31

Danke für den Hinweis. Kennst du eine neuere, gute Anleitung?
Lese sowieso immer im wiki quer wink

Es wurde das aktuelle Image archlinux-2019.10.01-x86_64.iso verwendet.

Der Stick wurde so erstellt:

dd bs=4M if=~/dwn/archlinux-2019.10.01-x86_64.iso of=/dev/sdb status=progress oflag=sync

Zum Booten stehen mir zwei Partitionen am Stick zur Verfügung.
Eine beinhaltet UEFI und diese habe ich gestartet.

Viele Grüße
Andreas

niemand
16.10.2019 20:55:51

Finde diese Anleitung recht treffend für das was ich machen möchte:

Ich nicht. Die’s alt. Zur Fehlersuche wäre auch eher interessant, was du bis dahin gemacht hast, nicht, was du machen möchtest. So Fragen, wie: welches Image wurde genommen, und wie wurde der Stick erstellt? Auch nicht ganz unwichtig: wurde auch mit EFI gebootet? Manche Firmwares bieten nämlich die Möglichkeit, einen entsprechenden Stick sowohl mit EFI, als auch mit Legacy-Kram zu booten – wenn da Letzteres gewählt wurde (oder Ersteres gar nicht erst zur Auswahl steht, weil eben der Stick falsch erstellt wurde – deswegen die Frage oben), ist auch nix mit EFI-Funktionalität.

inco12345
16.10.2019 19:44:21

Finde diese Anleitung recht treffend für das was ich machen möchte:
https://webby.land/2017/02/10/arch-linu … me-drives/

Schon beim Laden des USB-Sticks kommt es zu dem Fehler:

 Failed to start Store a System Token in an EFI variable

Wenn ich anschließend, wie empfohlen prüfe:

ls /sys/var/firmware/efi/efivars

Kann ich kein Verzeichnis finden.
Habe bereits das Mainboard geupdateted und es ein paar mal erneut versucht.
Online findet man einige Hinweise, dass das Verhalten nach der Installation verschwindet.
Hat hier schon jemand Erfahrung damit gemacht und kann mir einen Tipp geben?

Viele Grüße
Andreas

Fußzeile des Forums

Powered by FluxBB