Du bist nicht angemeldet.

Eine Antwort schreiben

Schreibe deinen Beitrag und versende ihn
Beitragsoptionen
Deine Antwort

Zurück

Themen-Übersicht (Neuester Beitrag zuerst)

Greg
26.07.2019 11:44:33
schard schrieb:

Versuch mal

-boot menu=on,strict=on

Mensch Schard bist du schnell!!
Leider klappt das auch nicht.
Gleicher Effekt.
Uuuuund danke für die Antwort!!
Gruß aus DN
Greg

schard
26.07.2019 11:26:14

Versuch mal

-boot menu=on,strict=on
Greg
26.07.2019 11:18:19

Hallo Leute,
da hat doch hier Jemand gefragt, wie dass mit Gummiboot bzw systemd-boot und Windoof geht. Ob da ein Eintrag für Windows gemacht werden kann und wie.
Ich weiß es nicht und deshalb wollte ich das mal mit Qemu probieren.
Qemu habe ich wie folgt gestartet und Win10 installiert.
Erzeugen des Images für 2 Festplatten:

qemu-img create -f qcow2 $name.img 25000M
qemu-img create -f qcow2 $name_2.img 25000M

Windoof installieren (das dauert ja ewig) zuvor wird ein UEFI ins qemu bereitgestellt übrigens so wie es im englischen Arch Wiki beschrieben steht wurde per Shellscript gemacht, daher die Variablen:

cp /usr/share/ovmf/x64/OVMF_VARS.fd $name.bin
qemu-system-x86_64 -k de \
-drive if=pflash,format=raw,readonly,file=/usr/share/ovmf/x64/OVMF_CODE.fd \
-drive if=pflash,format=raw,file=$name.bin \
-enable-kvm -cpu host -smp 1 -m 2048 \
-hda $name.img \
-hdb $name_2.img \
-net nic,model=i82551 -net user \
-cdrom /mnt/vbox2/$cdisowin10 -boot d 

Win10 wurde gleich auf die 2. Festplatte installiert.
Soweit ging alles gut und Win10 läßt sich ohne Probleme starten.
Jetzt soll Arch-Linux auf der Ersten Platte installiert werden.

qemu-system-x86_64 -k de\
-drive if=pflash,format=raw,readonly,file=/usr/share/ovmf/x64/OVMF_CODE.fd \
-drive if=pflash,format=raw,file=$name.bin \
-enable-kvm -cpu host -smp 1 -m 2048 \
-hda $name.img \
-hdb $name_2.img \
-net nic,model=i82551 -net user \
-cdrom /mnt/vbox2/$cdiso -boot order=d

Eigentlich sollte jetzt qemu direkt über das Arch-Linux sprich von CDrom starten. Aber qemu bootet immer direkt zu Win10.
Die Zeile -cdrom /mnt/vbox2/$cdiso -boot order=d
habe ich mal geändert auf -boot d
oder auch mal -boot order=d,menu=on wie es in den Manpages steht.
Klappt aber leider immer noch nicht.
Jetzt weiß ich nicht wie man den qemu klar machen soll, dass der nicht Win10 sondern das Arch-image starten soll.
In qemu wird angezeigt TianoCore BdsDxe: loading Boot0007 "Windows Boot Manager" from HD....
und unten ist ein weisser Balken der zeigt noch an Start boot option wenn ich menu=on mit angebe.
Nur mit welchen Tastenkombinationen komm ich da rein um das anzuwählen?
Könnte es sein, dass der Uefikram TianoCore das nicht unterstützt?
Gibt es hier einen qemukenner der mir da einen Tip geben kann?

Besten Dank im Vorraus!!
Gruß aus DN
Greg

Fußzeile des Forums

Powered by FluxBB