Du bist nicht angemeldet.

Eine Antwort schreiben

Schreibe deinen Beitrag und versende ihn
Beitragsoptionen
Deine Antwort

Zurück

Themen-Übersicht (Neuester Beitrag zuerst)

trono
23.07.2019 20:26:02

....bis Update 23.7. das wlan ist wieder da...alles ist wieder gut....ohne Notlösung...und eine Erfahrung reicher...

trono
19.07.2019 16:18:12

Also, die iwlwifi.conf hatte ich mit den genannten options, wie unter dem Link beschrieben, im Verzeichnis modprobe.d angelegt.
Die iwlwifi.conf ist dort mit den Einträgen vorhanden.
Ein Neustart brachte leider nichts. Hoffnungslos...

brikler
19.07.2019 12:43:39
trono schrieb:

options iwlwifi 11n_disable=1 swcrypto=1

Ansonsten war das modprobe.d Verzeichnis als auch modules-load.d leer.

leg dir eine iwlwifi.conf an füge die zeile ein, starte neu und hoffe, daß es funktioniert.

zum testen kannst du vielleicht die `swcrypto` so umschalten… als root

echo 1 > /sys/module/iwlwifi/parameters/swcrypto
trono
19.07.2019 11:23:05
waldbaer59 schrieb:

Es wäre nett wenn der TO noch schreiben würde, warum das Problem nun gelöst ist....

Das Problem ist, wie die Überschrift hergibt

Nach heutigen Update Wlan keine Verbindung mehr...

Wie man merkt und meine Anwesenheit zeigt, ist die Wlanverbindung wieder hergestellt. Das Problem mit der Verbindung ist somit gelöst.

Zu dem Zeitpunkt bin ich davon ausgegangen, dass das nächste linux-firmware Update (20190712.d52556e-1) die Notlösung mit der pacman.conf  wieder erübrigt. Tut es aber nicht.
Außerdem war zum Zeitpunkt der Threaderstellung auch die linux-firmwaren als Ursache des Problems nicht bekannt.

Nun geht es darum, ob der Zustand mit der Warnmeldung bei Updates über die veraltete linux-firmware Version so bleibt oder eine dauerhafte Lösung möglich ist.
Wenn man nun pingelig ist, kann man aus dem Thema zwei Teile machen oder einen neuen Thread erstellen. Ich habe es zum besseren Verständnis für sinnvoller gehalten den Zusammenhang zu belassen und nicht zu trennen.
Ich gebe aber zu, das es etwas irritieren kann und habe "gelöst" erst mal wieder entfernt.


TBone schrieb:

Zeig mal den Inhalt deiner Datei.

Hier ist er

options iwlwifi 11n_disable=1 swcrypto=1


Archlinux habe ich unter Mate mit NetworkManager und network-manager-applet eingerichtet.
Den Eintrag für die iwlwifi.conf  habe ich von hier übernommen:

https://wiki.archlinux.org/index.php/Wi … on#iwlwifi

Zuvor war das modprobe.d Verzeichnis leer. Im Verzeichnis modules-load.d ist keine Datei.
Könnte da vielleicht etwas über die NetworkManager.conf zu machen sein?

gruß trono

waldbaer59
19.07.2019 07:22:59

Es wäre nett wenn der TO noch schreiben würde, warum das Problem nun gelöst ist....

Galde75
18.07.2019 22:30:06
trono schrieb:

aber unter Linux brauchst du keine Treiber usw...

Eine Firmware ist ja auch kein Treiber... ;-)

Der Treiber braucht die Firmware um das Gerät ansprechen zu können.

Meist ist es:

A) Das Gerät selber hat keine Firmware, und wird normal mit dem Windowstreiber mitgeliefert (zB um den Speicherchip auf dem Gerät zu sparen, oder aus Update Gründen)

B) Die Firmware ist nur auf Windows ausgelegt und es muss deshalb eine alternative geladen werden.

C) Funktionen erweitert bzw verändert

trono
18.07.2019 21:55:57

Hi,

ah,ja, wie hieß es noch anfangs in alten Linuxzeiten- aber unter Linux brauchst du keine Treiber usw...

Sorry hat etwas lange gedauert, aber ich hab mir nen Wolf im Netz gesucht und versuche zu verstehen. Wenn ich das richtig ermittelt habe
wird die linux-firmware ja nicht nur in Archlinux installiert sondern ebenso bei Debian, Ubuntu, Linuxmint und wie sie alle heissen, sofern
sie zum Update zur Verfügung gestellt wird Also gibt es ebensolche Probleme. Auch Manjaro ist betroffen. Also nutzt es auch nichts die Distri zu wechseln.

Bei der Karte handelt es sich um Intel® Wireless-AC 9560, die beworben wird mit 6x schneller als n-Wlan. Firmware ist iwlwifi-9000-pu-b0-jf-b0-34.618819.0.tgz.
Die Firmware ist unter Arch vorhanden aber wird offenbar aufgrund der linux-firmware Updates nicht mehr geladen.


Nach dem Link habe ich dort als möglichen "Workaround" lediglich dies gefunden (übersetzt):


Es gibt jedoch gute Neuigkeiten: Ich habe festgestellt, dass die Einstellung der iwlwifi-Moduloption swcrypto = 1 das Problem
zu vermeiden scheint. Die Verwendung dieser Option scheint ebenfalls keine merklichen Auswirkungen auf die Leistung zu haben.


Aber unter einem Workaround versteh ich allerdings etwas Konkreteres. Die Anlegung einer iwlwifi.conf mit dieser Option bringt mir kein wlan wieder.
Und im Prinzip wäre es ja auch wieder nur eine Notlösung. Dann könnte man bei --ingnore bleiben.

gruß trono

schard
17.07.2019 17:19:39

Ja, mit NoExtract in der /etc/pacman.conf

Galde75
17.07.2019 17:08:48

Wie schaut das eigentlich bei Archlinux aus...

Bei Gentoo konnte ich damals in einer Datei definieren welche Firmware durch das Paket installiert wurde, bzw "excluden" (Ich glaube in einer Datei unter /etc/conf.d/).
Sehr praktisch wenn man zB wie in diesem Fall einzelne Firmware durch ein anderes Paket ersetzen will.

Geht sowas auch unter Archlinux?

sekret
17.07.2019 11:14:55

Das kann natürlich eine temporäre Lösung sein, aber sicherlich keine dauerhafte! Ich möchte dir einen Bugreport empfehlen mit genauer Angabe, welche Karte du denn hast (benutze lspci dafür), die Ausgaben von dmesg mit der alten, funktionierenden und der neuen, nicht funktionierenden linux-firmware (und wichtigen Angaben, die ich gerade nicht bedenke).

trono
17.07.2019 09:59:17

Hi,

jetzt melde ich mich doch noch mal, da ich verunsichert bin, auch wenn das bestimmte Archspezies vielleicht als "stark" empfinden. Aber man lernt ja nie aus und so leicht will ich nicht aufgeben. Leider ist die Akzeptanz des brandneuen Asus-Laptops auf bootbare installierbare Linux Betriebssysteme arg begrenzt (egal ob CD oder USB) und das Archlinux-Installationsmedium, das einzige, was sofort problemlos durchstartete .

Also kurz und gut, nun habe ich, weil ich mit diesem brandneuen Asus-Laptop nach den linux-firmware-20190628 update keine wlan-Verbindung mehr bekomme und damit keine Internetverbindung herstellen kann, in der pacman.conf das update der linux-firmware unterbunden.
Da ich, vertrauenswürdig, vielleicht auch leichtgläubig gewesen bin, mir gedacht, mit dem neuen Update auf linux-firmware20190712.d52556e-1 wird wieder alles gut und das ignorieren aus der pacman.conf wieder entfernt. Nein, es wurde aber nicht wieder alles gut. Mein Pech oder meine Unkenntnis bestrafte mich zusätzlich, da ich zuvor den Cache geleert hatte und  deshalb nicht mehr über die linux-firmware-20190618 auf dem Rechner zugreifen konnte. Das war, was die Internetverbindung mit Archlinux angeht, natürlich ein Eigentor. Meine Bemühungen die Updates Rückgängig zu machen (Kernel, Nvidia usw.) endeten im Schreddern des Systems

Ich hatte aber noch eine Sicherheitskopie meiner Installation vom Mai, die ich neu aufspielte. Damit konnte ich Archlinux wieder starten und auf den derzeitgen Stand mit Updates bringen, Ausnahme die linux-firmware die nun das Datum vom 20190424 trägt. Nun erhalte ich aber bei Updates die Meldung

warning: linux-firmware: ignoring package upgrade (20190424.4b6cf2b-1 => 20190712.d52556e-1)

Kann ich die weiter ignorieren, denn sonst habe ich ja wieder keine Internetverbindung habe und damit keine Updates? Kann das ansonsten langfristig Probleme geben? Wie ist Eure Erfahrung?

gruß trono

trono
12.07.2019 19:56:14

Hätte zu der Wlan-Firmware mal eine Frage. Wie sind denn die Erfahrungen, wann solch ein Fehler gefixt wird?

Das kann ja stauartige Updateprobleme  für das ganze System nach sich ziehen, zumal man auf ein funktionierendes  Wlan generell angewiesen ist. Oder kann man ala Pacman, ähnlich wie in Debian, die firmware20190628.70e4394-1 vom Update ausschließen und den Ausschluss ggf. bis zur Fehlerkorrektur überwachen? Ich habe da etwas über

--ignore <package>

in der pacman.conf gelesen.

trono
09.07.2019 21:06:01

Tatsächlich liegt es am update der linux-firmware-20190628, welches die Wlan-Karte nicht mehr erkennt und die Netzverbindung nicht mehr zulässt.

Ein Downgrade auf die vorherige Version behebt den Fehler:

sudo pacman -U /var/cache/pacman/pkg/linux-firmware-20190618.acb56f2-1-any.pkg.tar.xz

Die Lösung war hier https://www.reddit.com/r/archlinux/comm … fi_cannon/

zu finden.

niemand
09.07.2019 19:14:17

Achso, NM-Problem. Damit kenne ich mich nicht aus. Ich würde jetzt versuchen, manuell ’ne Verbindung aufzubauen. Wenn’s geht, ist das Problem zumindest nicht bei der Hardware, bzw. deren Firmware oder Treiber, zu suchen.

Edit: und wenn’s nicht geht, hat man zumindest ’ne Fehlermeldung, die im Idealfall direkt auf’s Problem zeigt.

trono
09.07.2019 19:09:45

Unter Mate bekomme ich vom Networkmanagerapplet die Meldung:

"Keine Netzwerkverbindung" und "Gerät ist nicht betriebsbereit".

Pacman erklärt mir draufhin "Fehler beim synchronisieren aller Datenbanken". Findet natürlichen keine Verbindung.

Systemctl? Networkmanager?

Fußzeile des Forums

Powered by FluxBB