Eine Antwort schreiben

Schreibe deinen Beitrag und versende ihn
Beitragsoptionen
Deine Antwort

Zurück

Themen-Übersicht (Neuester Beitrag zuerst)

alex2244
05.05.2019 17:21:56

Hallo zusammen,

Ich habe hier ein Acer Aspire S7 auf dem ich Arch Linux installieren will.

In diesem Notebook steckt eine 256GB SSD welche aus 2x128GB SSD's im RAID0-Verbund besteht.
Allerdings sind diese 2 SSD's auf einem mSATA-Modul also habe ich keine Möglichkeit diese zu trennen.

Die Festplatte(n) wird/werden wenn ich das Arch Live Medium boote und lsblk eingebe werden als md126 dargestellt:

sda           8:0    0 119.2G  0 disk  
└─md126       9:126  0 238.5G  0 raid0 
  ├─md126p1 259:0    0   500M  0 part  /mnt/boot
  ├─md126p2 259:1    0    38G  0 part  /mnt
  ├─md126p3 259:2    0   196G  0 part  /mnt/home
  └─md126p4 259:3    0     4G  0 part  [SWAP]
sdb           8:16   0 119.2G  0 disk  
└─md126       9:126  0 238.5G  0 raid0 
  ├─md126p1 259:0    0   500M  0 part  /mnt/boot
  ├─md126p2 259:1    0    38G  0 part  /mnt
  ├─md126p3 259:2    0   196G  0 part  /mnt/home
  └─md126p4 259:3    0     4G  0 part  [SWAP]

Das Basissystem konnte ich installieren, syslinux habe ich auch drauf bekommen.
Syslinux startet auch, aber dann kommt "Waiting 10 seconds for device /dev/disk/by..."
und dann dieser Notfallmodus.

Ich habe in der syslinux.cfg schon folgendes in der "APPEND"-Zeile getestet:

- root=/dev/md126p2
- root=LABEL=arch_sys
- root=UUID= ...
- root=PARTUUID= ...

Aber es kommt beim starten immer wieder der selbe Fehler weil die root-Partition nicht gefunden wird.

Wie bekomme ich das System dazu dass es die root-Partition findet?

Das Laptop bootet im "Legacy"-Modus. Die Festplatte wurde normal mit mbr formatiert. (fdisk)
Ich habe (nur zum testen) mal mit UEFI gebootet (und die platte mit gdisk und gpt formatiert, und die selben partitionen angelegt) aber da kam das selbe Problem.
EFISTUB wie aus dem Wiki. Booten ging aber dann wieder das mit den 10 Sekunden und dieser Notfallmodus.

Ich habe im Netz ein paar Sachen gefunden zum testen wie z. B. die EFI-Partition in /boot/efi mounten anstatt in /boot.
Hat auch nicht geholfen. Außerdem möchte das Gerät normal im "Legacy"-Modus mit syslinux booten und nicht mit UEFI.
Und viele der Lösungen aus dem Internet bezogen sich auf "LVM, Verschlüsselungs, BTRFS"-Zeug...
Brauche und will ich alles garnicht. Ich möchte nur Arch auf dieser RAID0-SSD installieren und starten können.

Hat jemand noch Vorschläge? Die SSD auszutauschen ist keine wirkliche Option. Es muss doch auch mit dieser RAID0-SSD möglich sein?

Fußzeile des Forums

Powered by FluxBB