Eine Antwort schreiben

Schreibe deinen Beitrag und versende ihn
Beitragsoptionen
Deine Antwort

Zurück

Themen-Übersicht (Neuester Beitrag zuerst)

Galde75
10.02.2019 18:58:37

https://www.archlinux.org/packages/extr … on-editor/

Replaces:	libnm-gtk<1.8.18-1

Sieht für mich so aus als wenn der Paketersteller ein neueres Paket nicht pauschal ersetzen wollte (weil die evtl neure Funktionen haben könnten). Oder so ähnlich...

Zudem gibt es das noch im AUR, allerdings als Git Version

https://aur.archlinux.org/packages/libnm-gtk-git/

HansHiasl
10.02.2019 14:07:34

Danke

Weg isses.
Keine nagativen Folgen erkennbar.

stefanhusmann
10.02.2019 11:59:53

Ja.

Installationsgrund       : Installiert als Abhängigkeit für ein anderes Paket

und

Benötigt von             : Nichts

Kann also weg.

HansHiasl
10.02.2019 11:32:51

Hallo Gemeinde
Ein Systemupdate mit trizen -Syu zeigt mir seit heute folgendes an:

libnm-gtk was not found in AUR -- skipping

Das Paket "libnm-gtk" ist weder in den offiziellen Repo´s noch im AUR zu finden.
Pacman-Paketinfo gibt folgendes aus:

pacman -Qi libnm-gtk
Name                     : libnm-gtk
Version                  : 1.8.19dev+21+geebf7f95-1
Beschreibung             : NetworkManager GUI client library (legacy)
Architektur              : x86_64
URL                      : https://wiki.gnome.org/Projects/NetworkManager/
Lizenzen                 : GPL  LGPL
Gruppen                  : Nichts
Stellt bereit            : Nichts
Hängt ab von             : libnm-glib  gtk3  iso-codes  libgudev
Optionale Abhängigkeiten : Nichts
Benötigt von             : Nichts
Optional für             : Nichts
In Konflikt mit          : Nichts
Ersetzt                  : Nichts
Installationsgröße       : 399,00 KiB
Packer                   : Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
Erstellt am              : Sa 27 Okt 2018 18:52:49 CEST
Installiert am           : So 28 Okt 2018 00:27:22 CEST
Installationsgrund       : Installiert als Abhängigkeit für ein anderes Paket
Installations-Skript     : Nein
Verifiziert durch        : Signatur

Im Pacman -Logfile finde ich diese Einträge:

[2017-12-30 08:52] [ALPM] installed libnm (1.10.2-1)
[2017-12-30 08:52] [ALPM] installed libnm-glib (1.10.2-1)
[2018-01-24 20:31] [ALPM] upgraded libnm (1.10.2-1 -> 1.10.3dev+38+g78ef57197-1)
[2018-01-24 20:31] [ALPM] upgraded libnm-glib (1.10.2-1 -> 1.10.3dev+38+g78ef57197-1)
[2018-02-14 05:15] [ALPM] upgraded libnm (1.10.3dev+38+g78ef57197-1 -> 1.10.5dev+3+g5159c34ea-1)
[2018-02-14 05:15] [ALPM] upgraded libnm-glib (1.10.3dev+38+g78ef57197-1 -> 1.10.5dev+3+g5159c34ea-1)
[2018-03-15 05:10] [ALPM] upgraded libnm (1.10.5dev+3+g5159c34ea-1 -> 1.10.6-1)
[2018-03-15 05:10] [ALPM] upgraded libnm-glib (1.10.5dev+3+g5159c34ea-1 -> 1.10.6-1)
[2018-03-20 05:55] [ALPM] upgraded libnm (1.10.6-1 -> 1.10.6-2)
[2018-03-20 05:55] [ALPM] upgraded libnm-glib (1.10.6-1 -> 1.10.6-2)
[2018-03-29 05:30] [ALPM] upgraded libnm (1.10.6-2 -> 1.10.6-3)
[2018-03-29 05:30] [ALPM] upgraded libnm-glib (1.10.6-2 -> 1.10.6-3)
[2018-05-12 07:48] [ALPM] upgraded libnm (1.10.6-3 -> 1.10.8-1)
[2018-05-12 07:48] [ALPM] upgraded libnm-glib (1.10.6-3 -> 1.10.8-1)
[2018-06-18 06:12] [ALPM] upgraded libnm (1.10.8-1 -> 1.10.10-1)
[2018-06-18 06:12] [ALPM] upgraded libnm-glib (1.10.8-1 -> 1.10.10-1)
[2018-07-11 17:22] [ALPM] upgraded libnm (1.10.10-1 -> 1.12.0-1)
[2018-07-11 17:22] [ALPM] upgraded libnm-glib (1.10.10-1 -> 1.12.0-1)
[2018-07-25 17:16] [ALPM] upgraded libnm (1.12.0-1 -> 1.12.2-1)
[2018-07-25 17:16] [ALPM] upgraded libnm-glib (1.12.0-1 -> 1.12.2-1)
[2018-08-06 06:03] [ALPM] upgraded libnm (1.12.2-1 -> 1.12.3dev+1+g0a3755c17-1)
[2018-08-06 06:03] [ALPM] upgraded libnm-glib (1.12.2-1 -> 1.12.3dev+1+g0a3755c17-1)
[2018-09-15 08:49] [ALPM] upgraded libnm (1.12.3dev+1+g0a3755c17-1 -> 1.14.0-1)
[2018-09-15 08:49] [ALPM] upgraded libnm-glib (1.12.3dev+1+g0a3755c17-1 -> 1.14.0-1)
[2018-09-15 08:49] [ALPM] installed libnma (1.8.18-2)
[2018-09-15 08:49] [ALPM] installed libnm-gtk (1.8.18-2)
[2019-02-09 11:35] [ALPM] upgraded libnma (1.8.19dev+21+geebf7f95-1 -> 1.8.20-1)

Aus diesem Eintrag in der Paketinfo von libnm-gtk

Name                     : libnm-gtk
Version                  : 1.8.19dev+21+geebf7f95-1

und dem Eintag im Logfile

[2018-09-15 08:49] [ALPM] installed libnm-gtk (1.8.18-2)
[2019-02-09 11:35] [ALPM] upgraded libnma (1.8.19dev+21+geebf7f95-1 -> 1.8.20-1)

könnte man schließen, dass sich das Paket libnm-gtk irgendwie in libnma umbenannt hat (zumindest der Versionsnummer nach)


Hier nochmal die Infos beider Pakete (libnma und libnm-gtk) im Vergleich:

Name                     : libnma
Version                  : 1.8.20-1
Beschreibung             : NetworkManager GUI client library
Architektur              : x86_64
URL                      : https://wiki.gnome.org/Projects/NetworkManager/
Lizenzen                 : GPL  LGPL
Gruppen                  : Nichts
Stellt bereit            : Nichts
Hängt ab von             : libnm  gcr  gtk3  iso-codes  mobile-broadband-provider-info
Optionale Abhängigkeiten : Nichts
Benötigt von             : nm-connection-editor
Optional für             : Nichts
In Konflikt mit          : Nichts
Ersetzt                  : Nichts
Installationsgröße       : 723,00 KiB
Packer                   : Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
Erstellt am              : Do 07 Feb 2019 13:06:23 CET
Installiert am           : Sa 09 Feb 2019 11:35:27 CET
Installationsgrund       : Installiert als Abhängigkeit für ein anderes Paket
Installations-Skript     : Nein
Verifiziert durch        : Signatur


Name                     : libnm-gtk
Version                  : 1.8.19dev+21+geebf7f95-1
Beschreibung             : NetworkManager GUI client library (legacy)
Architektur              : x86_64
URL                      : https://wiki.gnome.org/Projects/NetworkManager/
Lizenzen                 : GPL  LGPL
Gruppen                  : Nichts
Stellt bereit            : Nichts
Hängt ab von             : libnm-glib  gtk3  iso-codes  libgudev
Optionale Abhängigkeiten : Nichts
Benötigt von             : Nichts
Optional für             : Nichts
In Konflikt mit          : Nichts
Ersetzt                  : Nichts
Installationsgröße       : 399,00 KiB
Packer                   : Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
Erstellt am              : Sa 27 Okt 2018 18:52:49 CEST
Installiert am           : So 28 Okt 2018 00:27:22 CEST
Installationsgrund       : Installiert als Abhängigkeit für ein anderes Paket
Installations-Skript     : Nein
Verifiziert durch        : Signatur

Der Unterschied goße dieser beiden Pakete ist, dass libnm-gtk von nichts benötigt wird.
Kann es sein, dass dieses libnm-gtk auf libnma upgegradet aber dann nicht entfernt wurde?

Ich würde diesen "Konflikt" gerne bereinigen.
Kann ich libnm-gtk entfernen, ohne meine Kiste in den Abrund zu stürzen?

Fußzeile des Forums

Powered by FluxBB