Eine Antwort schreiben

Schreibe deinen Beitrag und versende ihn
Beitragsoptionen
Deine Antwort

Zurück

Themen-Übersicht (Neuester Beitrag zuerst)

brikler
11.01.2019 20:41:05
frostschutz schrieb:

Das in deinen Screenshots wäre auch auf Japanisch oder Chinesisch einfach nur verkehrt...

du hast recht, es ist einfach phalsch konfiguriert, aber wie stell ichs richtig ein?

frostschutz
11.01.2019 20:16:21
brikler schrieb:

passt wunderbar zu kanji, die man von oben nach unten schreibt und mit einem leerzeichen, quasi eine neue zeile einfügt…

Bei Kanji hast du eigentlich keine übermäßig breiten Leerräume. (Beispiel https://www.w3.org/TR/jlreq/Images-en/img2_8_1.png bzw. komplett https://www.w3.org/TR/jlreq/ )

Das Leerzeichen ist da etwa so breit wie ein einzelnes Schriftzeichen eben auch. (So ähnlich wie bei uns in einer fixed-width Schriftart).

Wenn du eine neue Zeile (oder neuen Abschnitt) haben willst musst du das auch bei Kanji explizit ansagen.

Das in deinen Screenshots wäre auch auf Japanisch oder Chinesisch einfach nur verkehrt...

brikler
11.01.2019 19:48:15

@sc44
du ahnst gar nicht, wie oft ich fontconfig in verschiedenen versionen installiert und den cache gelöscht hab.
soweit funktioniert fontconfig, er setzt die buchstaben so nahe zusammen wie es geht, aber der abstand, zwischen den worten, passt wunderbar zu kanji, die man von oben nach unten schreibt und mit einem leerzeichen, quasi eine neue zeile einfügt… ist ein einstellungs problem.
wenns mich noch lang ärgert, setze ich das system neu auf.

sc44
11.01.2019 19:31:47
brikler schrieb:

jetzt bin ich ein stück schlauer:

Aber, es sieht immer noch nicht gut aus oder?

Falls du die "~/.fontconfig" meinst, die gibt es bei mir nicht, scheint auch nur der Cache zu sein.

<!-- Font cache directory list -->

	<cachedir>/var/cache/fontconfig</cachedir>
	<cachedir prefix="xdg">fontconfig</cachedir>
	<!-- the following element will be removed in the future -->
	<cachedir>~/.fontconfig</cachedir>

Installiere doch fontconfig einfach mal neu, und leere den Cache unter "/var/cache/fontconfig" eventuell bringt es ja was.

brikler
11.01.2019 15:48:25

jetzt bin ich ein stück schlauer: ich hab das ganze noto entfernt und neu gestartet, es war unverändert, die abstände zu groß und unlesbare zahlen… damit wirds sehr wahrscheinlich an fontconfig liegen.

.fontconfig/ ist leer.

frostschutz
11.01.2019 13:03:31
Aning3pa schrieb:

Du solltest es ja auch mit einem anderen Benutzer und nicht einem anderen Browserprofil testen.

Ist ja beides sinnvoll. Im Browser(profil) kann man auch komische Sachen zu Sprache und Encoding und Schriften einstellen. Das wars dann schonmal nicht...

Und so oder so ist es ein Herumstochern im Dunkeln, bis hier jemand vorbeischneit der aus der Hüfte sagen kann, jo des is weil so und so... kann ich halt nicht weil ich mit der Schriftenverwaltung und grafischen Frontends selber ein wenig auf Kriegsfuss stehe. Ich bin definitiv mehr auf der Shell zuhause... ;-)

Aning3pa
11.01.2019 12:58:49

Du solltest es ja auch mit einem anderen Benutzer und nicht einem anderen Browserprofil testen. "es kann blos systemweit sein" ist zunächst nur eine unbewiesene Behauptung, die durch entsprechende Tests erst noch belegt werden muss.

frostschutz
11.01.2019 12:55:38
brikler schrieb:

ich werds mal mit einem neuen browser profil versuchen

Neuen Linux-Benutzer ( /home/testhans ) auf jeden Fall auch probieren

man hat keinen direkten Einfluss/Überblick was im eigenen Home in den .xyz Dateien/Verzeichnissen so abgeht

wenn es bei einem neuen Benutzer auch passiert, muss man auf /etc/ usw. schielen

brikler
11.01.2019 11:33:17

@frostschutz
es kann blos systemweit sein, in meinem profil gibts so keine extra einstellungen aber ich werds mal mit einem neuen browser profil versuchen

edit
ein neues browser profil bringt nichts

frostschutz
11.01.2019 00:34:48

Ich hab ein frisch installiertes ArchLinux, u.a. auch noto-fonts-cjk installiert und keine Probleme im firefox oder sonstwo.

Bei Schriftproblemen beisse ich mir aber auch ab und zu die Zähne aus, bei einer Arch-installation vor einem Jahr waren die Terminalschriften zur Unleserlichkeit verpixelt und ich hab nie rausgefunden, woran das liegt.

Du könntest mal einen neuen Benutzer anlegen und schauen ob der auch das Problem hat. Dann weisst du ob es systemweit ist oder irgendwas in deinem Home umgekippt ist.

brikler
10.01.2019 21:24:06
sc44 schrieb:

Hallo,
ist das überall so oder nur unter Palemoon?

palmoon, waterfox und falkon (ex qupzilla)

sc44
10.01.2019 20:41:01

Hallo,
ist das überall so oder nur unter Palemoon?

brikler
10.01.2019 20:08:40
schard schrieb:

Dein Problem wird eine andere Ursache haben.

sehr wahrscheinlich.
auch nach dem ich das paket entfernt hab, schauts noch so aus…
wo wird festgelegt, wie lange ein leerzeichen ist?

schard
10.01.2019 17:55:28

Das Paket noto-fonts-cjk ändert keine Konfiguration der Leerzeichen.
Dein Problem wird eine andere Ursache haben.

brikler
10.01.2019 14:51:06

grüß euch,

ich hab gestern dummerweise noto-fonts-cjk installiert und das überschrieb mir die größe vom leerzeichen,
jetzt passts zwar für kanji aber nicht mehr für unsere buchtsaben, und zahlen sind so gut wie unsichtbar.

hat wer eine idee, wie ich wieder unseren schönen kleinen abstand hinkriege?

http://pics44.de/img/i/j/q/3uh0thfv.jpeg

edit
noto-fonts-emoji verursachten das problem, warum auch immer, ohne ist es so wie es sein soll

danke fürs helfen smile

Fußzeile des Forums

Powered by FluxBB