Du bist nicht angemeldet.

Eine Antwort schreiben

Schreibe deinen Beitrag und versende ihn
Beitragsoptionen
Deine Antwort

Zurück

Themen-Übersicht (Neuester Beitrag zuerst)

Arno
08.11.2018 12:22:48

Nein habe ich nicht, weil nicht gewusst sad

Wie oben beschrieben ich stecke da noch nicht so tief drin.

Meiner Meinung nach fehlt ein wiki über Troubleshooting, wo solche Greenhorns wie ich besser wissen was sie tun.
Wie das wiki zu Einrichtung, wer lesen kann kommt damit mehr als klar smile

Ich setze gerade den Rechner neu auf, damit ich wieder was arbeiten kann.

Trotzdem danke...

schard
08.11.2018 11:29:28

Hast du bereits versucht via "pacman -r" *alle* Pakete aus dem Live System heraus auf dem gemounteten System neu installiert, oder nicht?

Arno
08.11.2018 10:49:44

Okay, da habe ich mich nicht klar ausgedrückt, ich habe die Datei aus dem Verzeichnis in
ein anderes Verz. geschoben und dann libsystemd neu installiert. Dann wurde sie auch
wieder brav angelegt.
Auch die von Dir vorgeschlagenen Pakete, eigentlich alle die mit udev zu tun haben, sind
auch reinstalliert.

Es ändert aber nicht wiklich etwas, immer file too short!

Und da ich wieder damit arbeiten will und muss, ist vorerst dieser Exkurs vorbei.
Da ich alles auf meiner home Partition habe ist auch nichts verloren. In Zukunft
werde ich nur noch auf der Konsole eine Aktualisierung machen, mal sehen ob es
dann besser wird.
Außerdem werde ich mich ausführlich mit Borg auseinandersetzen, diese Sucherei
ist einfach zu zeitaufwendig, Solche Fehler sind komplex und nicht so ganz einfach
beschreibbar. Vielleicht wenn man tiefer in Materie drin steckt aber davon bin ich
noch ein gutes Stück entfernt.

Trotzdem vielen Dank für eure Mühe cool

schard
07.11.2018 18:56:15
Photor schrieb:

Kann ich noch irgendwie prüfen, ob noch irgendwo ein Rest rumliegt, der aufgeräumt gehört?

pacman -Dk
Photor
07.11.2018 17:46:20

Hallo,

ich hatte heute auch so ein Erlebnis: beim Update klappte Gnome vollständig zu und ich fand mich in normalen Textmodus-Login. Ich habe ich als ROOT eingeloggt und rebootet. Irgendetwas scheint Gnome oder dem X bzw Wayland die Füße unter'm A**** weggezogen zu haben.

Nach dem Reboot war aber noch die db.lock vorhanden (sonst bisher alles gut) so dass ein Update mit "pacman" erstmal nicht möglich war. Ich habe das Lock-File gelöscht und ein "pacman -Syu" sagt, dass alle Paket up-to-date sind.

Kann ich noch irgendwie prüfen, ob noch irgendwo ein Rest rumliegt, der aufgeräumt gehört?

Ciao,
Photor

Arno
07.11.2018 15:21:56

Ich habe jetzt alles reinstalliert, was mit libudev oder udev zu tun hat!
Ich habe zusätzlich libudev.so.1 gelöscht was auch nichts brachte!


Es bleiben diese drei Fehler bei erstellen des Builds

Arno
07.11.2018 14:57:26

Sieht so aus!

ERROR Hook /usr/lib/initcpio/install/udev has no build function
ERROR failed to detect root filsystem

was mich wundert, da es gemountet ist und ich darauf zugreifen kann.

ERROR /usr/lib/libudev.so.1 too short

und dann natürlich

WARNING errors were encountered during the build, The image may not be complete

stimmt aber vm-linuz wurde angelegt!

Arno
07.11.2018 14:12:03

Gut :-)

Ich habe jetzt folgendes getan, ich habe meine / , /boot und /home gemontet,mehr gibt es nicht.
Dann in die Arch-chroot Umgebung gewechselt und mit einem pacman -S systemd aufgerufen.

Dort schreibt er nun das Paket wäre up to date Reinstallation führt zu nichts.
Danach habe ich mkinitcpio -p linux aufgerufen, da meldet er einen Error in usr/lib..
wäre ein file zu kurz.

Ein nochmaliges Aufrufen von mkinitcpio ....  nach einem Systemstart, der leider kein Erfolg war,
bricht er nun direkt ab mit vm-linuz does not exist.

schard
07.11.2018 13:55:27
Arno schrieb:

Sorry falls dumm gefragt, das Kommando mkinitcpio funktioniert auch in der Chroot Umgebung?
Da bei dem Aufsetzen eines frischen Systems der nirgends am Start ist!

Aber sicher doch. Wenn der Kernel mit ge-pacstrap-ed wird, wird auch der initramfs-hook ausgeführt, der mkinitcpio ausführt.

Arno
07.11.2018 13:42:29

Ja genau so ist es passiert, die grafische Oberfläche wurde beendet, gerade so als würde man
das System herunterfahren. Was jetzt hier passiert ist mir im Grunde klar, falls systemd noch
korrekt installiert wurde, so hat hier das

Kommando mkinitcpio -p linux gefehlt.

Sorry falls dumm gefragt, das Kommando mkinitcpio funktioniert auch in der Chroot Umgebung?
Da bei dem Aufsetzen eines frischen Systems der nirgends am Start ist!

schard
07.11.2018 13:00:04

Verstehe ich es richtig, dass während pacman Pakete aktualisierte das System eingefroren ist, du einen Soft-Reset gemacht hast und es seitdem nicht mehr bootet?
Dann wurde womöglich eines der systemrelevanten Pakete nicht vollständig installiert.
Ein

pacman -S $(pacman -Qq)

im chroot aus einem Livesystem heraus könnte dann das Problem beheben.

Arno
07.11.2018 11:39:26

Hallo in die Runde,

ich habe heute morgen eine pacman -Syu gestartet und bei der Aktualisierung
ist der Rechner stehen geblieben. Es wurde dabei eine neue Version von
systemd aktualisiert, wo ich vermute, dass dies wohl das Problem verursacht hat.
Der Kernel der bisher ohne murren lief ist der arch-4-18-16.

Bisher hatte ich nur auf meinem Laptop getestet und es war mir auch nicht
so wichtig wenn das einmal vorgekommen ist und es passiert immer mal.

Aber bei einer Wirkumgebung ist es eher blöd alles neu aufzusetzen und nun
meine Frage. Wie kann ich mich am günstigsten dem Problem nähern ohne
das ganz System zu ruinieren.

Danke schon mal...

Fußzeile des Forums

Powered by FluxBB