Eine Antwort schreiben

Schreibe deinen Beitrag und versende ihn
Beitragsoptionen
Deine Antwort

Zurück

Themen-Übersicht (Neuester Beitrag zuerst)

Greg
19.10.2017 21:16:48

Ich habe mal nachgesehen, ob man grub-mkconfig... anders konfigurieren kann.
Ich habs nicht hinbekommen.
Da habe ich dann die grub.cfg händisch gemacht.
Die ist jetzt hier: http://termbin.com/z7kq
Bevor die du bei dir übernimmst, bootest du zuerst ganz normal als user.
Dann lädst du dir die neue grub.cfg herunter. Daraus machst du am Besten eine grub_neu.cfg
Dann sicherst du deine vorhandene grub.cfg in z.B. grub.cfg.bak
Das kannst du in der Konsole machen als root. Also Konsole öffnen, su passwort
# mv /boot/grub/grub.cfg /boot/grub/grub.cfg.bak
Dann kopierst du die neue grub.cfg in das richtige Verzeichnis rein.
Wechsel in das Verzeichnis in der die grub_neu.cfg ist falls nicht geschehen.
# cp grub_neu.cfg /boot/grub/grub.cfg
Das sollte ohne Fehler geschehen sonst kann grub nicht funktionieren.
Falls das nicht geklappt hat, mußt du auf jedenfall die alte grub.cfg.bak wieder kopieren in grub.cfg

reboot.

Du siehst dann alle Linuxkernel hintereinander auf einer Seite.
Zuerst den default kernel mit der Bezeichnung Arch Linux.
Dann den Arch Linux fallback
Dann den linux-lts
Dann den Linux-lts-fallback.

Viel Glück!!
Gruß aus DN
Greg

stefanhusmann
19.10.2017 15:34:00
brikler schrieb:

da war ich etwas zu kurz^^
also, das geht so:

pacman -Qo /pfad/zum/binarie

du mußt erst den pfad zu libzeitgeist finden:

sudo find /usr -name libzeitgeist

find wird dann den pfad zum binarie ausspucken, der wird wahrscheinlich so ähnlich sein:

/usr/lib/libzeitgeist

den das kopierst du und gibst es pacman zur ansicht:

pacman -Qo /usr/lib/libzeitgeist
Tilrun schrieb:

gstreamer "meckert" eh schon. da gabs letztes mal updaten schon probleme. (konnte nicht geupdated werden)
wie werde ich den los?

wenn du nicht weißt wie du mit einem program umgehen must, dann schau in die man pages.
in dem fall:

man pacman

…die man pages ersparen einem viel ärger smile

ganz allgemein schauts für mich aus, als wäre dieses problem eins für einen neuen thread,
also sei so gut und mach für jedes  problem einen eigenen thread auf.

Bitte das "q" hinter "lib" nicht übersehen.

Pakete wird man los mit pacman -R <paketname>.

Schard-nologin
19.10.2017 14:39:44
brikler schrieb:
pacman -Qo <paketName>

Das ist Schwachsinn.
Die Option -o von pacman -Q sucht nach Besitzern von Dateien.
Einen Paketnamen anzugeben wäre dämlich.

Schard-nologin
19.10.2017 14:36:16

libqzeitgeist ist der Name eines Pakets.
Warum "muss" man dazu einen Pfad finden?
Entweder liegt ein Paket im Cache unter /var/cache/pacman/pkg/libqzeitgeist* oder nicht.
Welche Dateien im Paket enthalten sind, erfährt man mittels

pacman -Ql libqzeitgeist
brikler
19.10.2017 14:21:26

da war ich etwas zu kurz^^
also, das geht so:

pacman -Qo /pfad/zum/binarie

du mußt erst den pfad zu libzeitgeist finden:

sudo find /usr -name libzeitgeist

find wird dann den pfad zum binarie ausspucken, der wird wahrscheinlich so ähnlich sein:

/usr/lib/libzeitgeist

den das kopierst du und gibst es pacman zur ansicht:

pacman -Qo /usr/lib/libzeitgeist
Tilrun schrieb:

gstreamer "meckert" eh schon. da gabs letztes mal updaten schon probleme. (konnte nicht geupdated werden)
wie werde ich den los?

wenn du nicht weißt wie du mit einem program umgehen must, dann schau in die man pages.
in dem fall:

man pacman

…die man pages ersparen einem viel ärger smile

ganz allgemein schauts für mich aus, als wäre dieses problem eins für einen neuen thread,
also sei so gut und mach für jedes  problem einen eigenen thread auf.

Tilrun
19.10.2017 14:03:44
pacman -Qo <paketName>

mir gibt es das aus:

[root@onyx ~]# pacman -Qo <libqzeitgeist 0.8.0-6>
-bash: Syntaxfehler beim unerwarteten Wort `newline'
[root@onyx ~]# pacman -Qo libqzeitgeist 0.8.0-6
Fehler: Konnte 'libqzeitgeist' in PATH nicht finden: Datei oder Verzeichnis nicht gefunden
Fehler: Konnte '0.8.0-6' in PATH nicht finden: Datei oder Verzeichnis nicht gefunden

gstreamer "meckert" eh schon. da gabs letztes mal updaten schon probleme. (konnte nicht geupdated werden)
wie werde ich den los?

brikler
19.10.2017 13:55:36
stefanhusmann schrieb:

Wobei sich mir nicht erschließt, woher libqzeitgeist kommt. Das gibt's noch nicht einmal im AUR.

sie schrieb, daß sie ein paar AUR pakete installiert hat, aber wenigstens beim zeitgeist kann man erfragen woher^^

pacman -Qo <paketName>
stefanhusmann
19.10.2017 13:47:01
Tilrun schrieb:
stefanhusmann schrieb:

Bei den Paketen aus der Liste sind einige dabei, bei denen du versuchen solltest, sie loszuwerden. Es handelt sich um frühere ...

/quote]

also disable xyz und dann deinstallieren?

Mit "disablen" meinst du, sie in der pacman.conf unter IgnorePkg eintragen? Wie auch immer, meine Antwort lautet erst einmal nein. Die Paket sollten meckern, wenn irgendein anderes Paket sie noch benötigt. Und das sollte / muss dann eben auch weg.

Wobei sich mir nicht erschließt, woher libqzeitgeist kommt. Das gibt's noch nicht einmal im AUR.

Tilrun
19.10.2017 13:18:20
stefanhusmann schrieb:

Bei den Paketen aus der Liste sind einige dabei, bei denen du versuchen solltest, sie loszuwerden. Es handelt sich um frühere Pakete aus den Repos, die dort aus guten Gründen nicht mehr enthalten sind.

gstreamer0.10 0.10.36-16
gstreamer0.10-base 0.10.36-10
gstreamer0.10-base-plugins 0.10.36-10
qtwebkit 2.3.4-5
webkitgtk2 2.4.11-6
libqzeitgeist 0.8.0-6

also disable xyz und dann deinstallieren?


cat /boot/grub/grub.cfg | nc termbin.com 9999
http://termbin.com/3rl5

Dann update ich ab sofort mit pacman -Syu und nur die AUR Pakete mit packer -Syu --auronly. Danke!

Greg
19.10.2017 12:49:33
GerBra schrieb:

(offline)Evtl. kann ja Greg noch was zum Thema Grub sagen...

Das kann ich heute abend machen, da ich jetzt hier kein grub drin habe um alles zu testen.

Tilrun, du könntest noch den aktuellen Stand der grub.cfg durchgeben:

cat /boot/grub/grub.cfg | nc termbin.com 9999

Packer nur für AUR Option --auronly z.B.:

packer -Syu --auronly
GerBra(offline)
19.10.2017 12:40:26

Es sind ja wohl nicht sehr viele AUR-Pakete, ich habe nur mal ein paar mir augenscheinliche rausgepickt und in den normalen Repos gesucht:
pacman -Ss acroread-fonts foxitreader megasync minecraft
Das sind wohl AUR-Pakete.

Ich würde dir raten:
Das System an sich mit pacman aktuell zu halten (also pacman -Syu), anstatt ebenfalls/nur durch packer.
Das packer würde ich dann ausschließlich für Pakete aus dem AUR verwenden (immer *nach* pacman), evtl. kennt packer einen entsprechenden Schalter/Parameter um nur AUR-Pakete zu kompilieren/installieren.

Evtl. kann ja Greg noch was zum Thema Grub sagen...

stefanhusmann
19.10.2017 12:39:21

Bei den Paketen aus der Liste sind einige dabei, bei denen du versuchen solltest, sie loszuwerden. Es handelt sich um frühere Pakete aus den Repos, die dort aus guten Gründen nicht mehr enthalten sind.

gstreamer0.10 0.10.36-16
gstreamer0.10-base 0.10.36-10
gstreamer0.10-base-plugins 0.10.36-10
qtwebkit 2.3.4-5
webkitgtk2 2.4.11-6
libqzeitgeist 0.8.0-6
Tilrun
19.10.2017 12:25:37

Mit Lts-Kernel funktioniert es jetzt auch.
Danke sehr an alle!

pacman -Qm | nc termbin.com 9999 (da ist es egal mit welchem kernel ich boote, oder?)
http://termbin.com/irsk

GerBra(offline)
19.10.2017 12:14:55
Greg schrieb:

Dein aktueller kernel funktioniert jetzt mit sddm, kde. Alles startet durch.
Beim linux-lts Kernel noch nicht.

Das schrieb ich ja in meinem letzten Post schon (@alle,Greg, ff.)

Na Heureka!!!
Dann hat das EarlyKMS-Laden also auch hier geholfen. Das (bzw. das im direkten Zusammenspiel mit dem sddm 0.16) war mit Sicherheit seit Threadbeginn der eigentliche Auslöser. Dumm beim Zeitpunkt von Tilruns Hilferuf war halt: Testing (da war die "Lösung" ja noch nicht so offensichtlich) und das der Stock-Kernel zu dem Zeitpunkt der mit dem per Default aktivierten IOMMU-"Fehler" war (was erst später durch IMHO 4.13.5) geändert wurde.

Ich würde noch vorschlagen, den Threadtitel zu ändern, da es ja mit kfd bzw. der Titel-Fehlermeldung weniger was zu tun hat, sonst denkt noch jemand hier würde sich in über 220 Postings "qualifiziert" <g> über kfd/HSA unterhalten ;-) "Bootprobleme" o.ä. trifft es wohl eher...

Was IMHO noch zum Abschluß des Themas hier fehlt wären:
a) Das Aufräumen in Grub (Standardkernel als default usw, ich habe da nicht viel Ahnung von Grub, k.a. ob grub-mkconfig ausreicht...
b) Ein komplettes Systemupdate mit pacman -Syu, nachdem gesichert ist daß das Booten wieder normal funktioniert.
c) Das mit den AUR-Paketen bzw. wie mit Tilruns Nutzung von packer am Besten umgegangen wird.
Ein:
pacman -Qm | nc termbin.com 9999
sollte doch eigentlich (auch) die verwendeten Pakete aus dem AUR anzeigen? Das wäre zumindest ein Ansatz, wie mit pacman und packer zu verfahren ist.

b) und c) wären schon Dinge, die am besten in neuen Threads "zuhause" wären IMHO....

Greg
19.10.2017 11:30:54

Dein aktueller kernel funktioniert jetzt mit sddm, kde. Alles startet durch.
Beim linux-lts Kernel noch nicht.
Versuche jetzt ein update nur für den linux-lts kernel und boote dich dann wieder mit dem neuen linux-lts-kernel als normaluser und passwort ein.

pacman -Sy linux-lts

Fußzeile des Forums

Powered by FluxBB